0daf1bda1dced30afd520e2c82857fcc0a35e384
[apps/native/ug-mobile-ap.git] / packaging / ug-setting-mobileap-efl.spec
1 %define _usrdir /usr
2 %define _ugdir  %{_usrdir}/ug
3
4 Name:       ug-setting-mobileap-efl
5 Summary:    Tethering UI Gadget Library
6 Version:    0.1.164
7 Release:    1
8 Group:      TO_BE/FILLED_IN
9 License:    Flora License Version 1.0
10 Source0:    %{name}-%{version}.tar.gz
11 Requires(post): /usr/bin/vconftool
12 BuildRequires: cmake
13 BuildRequires: edje-bin
14 BuildRequires: gettext-tools
15 BuildRequires: pkgconfig(elementary)
16 BuildRequires: pkgconfig(evas)
17 BuildRequires: pkgconfig(ui-gadget-1)
18 BuildRequires: pkgconfig(wifi-direct)
19 BuildRequires: pkgconfig(capi-network-tethering)
20 BuildRequires: pkgconfig(capi-network-connection)
21 BuildRequires: pkgconfig(capi-network-wifi)
22 BuildRequires: pkgconfig(capi-telephony-sim)
23 BuildRequires: pkgconfig(notification)
24
25 %description
26 Tethering UI Gadget Library
27
28 %prep
29 %setup -q
30
31 %build
32 cmake . -DCMAKE_INSTALL_PREFIX="%{_ugdir}"
33 make %{?jobs:-j%jobs}
34
35 %install
36 rm -rf %{buildroot}
37 %make_install
38
39 %post
40 /usr/bin/vconftool set -t bool db/private/libug-setting-mobileap-efl/prev_wifi_status 0 -u 5000 -f
41 mkdir -p /usr/ug/bin/
42 ln -sf /usr/bin/ug-client /usr/ug/bin/setting-mobileap-efl
43
44 %files
45 %manifest ug-setting-mobileap-efl.manifest
46 %defattr(-,root,root,-)
47 %{_ugdir}/res/edje/ug-setting-mobileap-efl/*.edj
48 %{_ugdir}/res/locale/*/LC_MESSAGES/*
49 %{_ugdir}/res/images/ug-setting-mobileap-efl/*.png
50 %{_ugdir}/lib/libug-setting-mobileap-efl.so
51 /usr/share/packages/ug-setting-mobileap-efl.xml
52
53 %changelog
54 * Tue Apr 09 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.162-1
55 - Maximum connection information is displayed
56 - Implement connection timer
57 - UX Change : Data usage and Connected device
58 - Change ug name & Support appsvc
59 - Translation data is updated
60
61 * Fri Mar 29 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.161-2
62 - Fix : The grouping of genlist item is wrong
63 - Back button position and Naviframe title visibility are changed
64 - Make grouping for genlist expanded item
65 - Editfield change is applied
66 - Ticker notification is implemented for passphrase entry
67 - Implement title slide
68 - Pop-up parent and entry's context menu allowance are changed
69
70 * Mon Jan 28 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.160-1
71 - Remove unrequired log
72
73 * Tue Jan 15 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.159-1
74 - Fix : When device is rotated, guide text is displayed short time
75 - Fix : Security / Hide items are disabled sometimes
76 - Translation data is updated
77 - Pop-up scenario for USB tethering is implemented
78 - IMF is hided by focus out
79 - Wi-Fi tethering is enabled without checking enable state
80
81 * Fri Dec 07 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.158-1
82 - New winset is applied and some bugs are fixed
83
84 * Mon Nov 12 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.157-1
85 - Cellular network state is separated to CONNECTION_CELLULAR_STATE_AVAILABLE and CONNECTION_CELLULAR_STATE_CONNECTED
86
87 * Wed Oct 31 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.156-2
88 - Initial package upload
89
90 * Mon Oct 29 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.156-1
91 - Install path is changed from /opt to /usr
92
93 * Thu Oct 22 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.155-1
94 - License is added
95
96 * Thu Oct 04 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.154-1
97 - Connection / Wi-Fi's changed CAPIs are applied
98
99 * Fri Sep 21 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.153-1
100 - Pop-up button's style is changed
101
102 * Fri Sep 21 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.152-1
103 - Add manifest file for SMACK
104
105 * Wed Aug 29 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.151-1
106 - When client's connection is changed, old handles are freed
107
108 * Wed Aug 17 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.150-1
109 - Managed APIs are used to get Network connection state and control Wi-Fi
110 - Crash issue is fixed because of "Unable to use tethering" pop-up
111 - End separator is added to each genlist
112 - Wi-Fi direct is considered when Wi-Fi tethering is enabled
113
114 * Wed Aug 01 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.149-1
115 - Managed APIs are used to get Wi-Fi tethering settings
116 - Password entry issue("Enter" can be inserted) is fixed
117
118 * Thu Jul 26 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.148-2
119 - Unused resource is removed
120
121 * Thu Jul 26 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.148-1
122 - Apply White theme
123
124 * Wed Jul 18 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.147-2
125 - Upload pkg for ug library change
126
127 * Thu Jul 12 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.147-1
128 - ui-gadget-1 is applied
129 - typedef struct rule is fixed
130 - unnecessary dependency and header include are removed
131
132 * Thu Jul 12 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.146-1
133 - library is stripped
134
135 * Thu Jul 12 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.145-1
136 - "Wi-Fi tethering is not enabled" issue is fixed
137
138 * Fri Jun 29 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.144-1
139 - libmobile-ap is replaced with capi-network-tethering
140
141 * Mon Jun 25 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.143-1
142 - Data usage is got from agent
143
144 * Thu Jun 04 2012 Injun Yang <injun.yang@samsung.com> 0.1.142-1
145 - Initialize vconf key
146 - Remove unused vconf key
147
148 * Thu May 31 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.141-1
149 - Enabled indicatons are handled
150 - Wi-Fi vconf is used to know when Wi-Fi is disabled
151 - Code clean-up
152
153 * Thu May 24 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.140-1
154 - hide option vconfkey is exported to internal vconfkeys
155
156 * Fri May 18 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.139-1
157 - "Tethering" translation data is applied
158
159 * Thu May 17 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.138-1
160 - Private vconfkey is changed following new naming rule
161
162 * Mon Mar 26 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.137-1
163 - Tethering and portable hotspot is changed to Tethering
164
165 * Tue Mar 14 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.135-1
166 - libmobile-ap API's and EFL are changed
167
168 * Wed Feb 06 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.130-1
169 - Deprecated dependencies are removed