Initialize Tizen 2.3
[apps/livebox/livebox-cpp.git] / packaging / liblivebox-cpp.spec
1 Name: liblivebox-cpp
2 Summary: C++ adaptor for a livebox 
3 Version: 0.2.8
4 Release: 1
5 VCS:     magnolia/apps/livebox/livebox-cpp#livebox-cpp_0.2.4-19-g18d4a8671e59384424cf0c3c189e598a8ab2aed2
6 Group: HomeTF/Livebox
7 License: Flora
8 Source0: %{name}-%{version}.tar.gz
9 Source1001: %{name}.manifest
10 BuildRequires: cmake, gettext-tools, coreutils
11 BuildRequires: pkgconfig(dlog)
12 BuildRequires: pkgconfig(livebox)
13 BuildRequires: pkgconfig(evas)
14 BuildRequires: pkgconfig(livebox-service)
15
16 %description
17 Livebox development library (C++)
18
19 %package devel
20 Summary: Files for livebox development
21 Group: Development/Libraries
22 Requires: %{name} = %{version}-%{release}
23
24 %description devel
25 Livebox development library (C++) (dev)
26
27 %prep
28 %setup -q
29 cp %{SOURCE1001} .
30
31 %build
32 %if 0%{?sec_build_binary_debug_enable}
33 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
34 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
35 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
36 %endif
37
38 %if 0%{?tizen_build_binary_release_type_eng}
39 export CFLAGS="${CFLAGS} -DTIZEN_ENGINEER_MODE"
40 export CXXFLAGS="${CXXFLAGS} -DTIZEN_ENGINEER_MODE"
41 export FFLAGS="${FFLAGS} -DTIZEN_ENGINEER_MODE"
42 %endif
43 %cmake .
44 make %{?jobs:-j%jobs}
45
46 %install
47 rm -rf %{buildroot}
48 %make_install
49 mkdir -p %{buildroot}/%{_datarootdir}/license
50
51 %post
52
53 %files -n liblivebox-cpp
54 %manifest %{name}.manifest
55 %defattr(-,root,root,-)
56 %{_libdir}/*.so*
57 %{_datarootdir}/license/*
58
59 %files devel
60 %manifest %{name}.manifest
61 %defattr(-,root,root,-)
62 %{_includedir}/livebox-cpp/livebox-cpp.h
63 %{_datarootdir}/doc/livebox-cpp/livebox-cpp_PG.h
64 %{_libdir}/pkgconfig/*.pc
65
66 # End of a file