Update coding convention
[apps/livebox/livebox-cpp.git] / packaging / liblivebox-cpp.spec
1 Name: liblivebox-cpp
2 Summary: C++ adaptor for a livebox 
3 Version: 0.2.8
4 Release: 1
5 Group: HomeTF/Livebox
6 License: Flora License
7 Source0: %{name}-%{version}.tar.gz
8 BuildRequires: cmake, gettext-tools, coreutils
9 BuildRequires: pkgconfig(dlog)
10 BuildRequires: pkgconfig(livebox)
11 BuildRequires: pkgconfig(evas)
12 BuildRequires: pkgconfig(livebox-service)
13
14 %description
15 Livebox development library (C++)
16
17 %package devel
18 Summary: Files for livebox development.
19 Group: Development/Libraries
20 Requires: %{name} = %{version}-%{release}
21
22 %description devel
23 Livebox development library (C++) (dev)
24
25 %prep
26 %setup -q
27
28 %build
29 %if 0%{?tizen_build_binary_release_type_eng}
30 export CFLAGS="${CFLAGS} -DTIZEN_ENGINEER_MODE"
31 export CXXFLAGS="${CXXFLAGS} -DTIZEN_ENGINEER_MODE"
32 export FFLAGS="${FFLAGS} -DTIZEN_ENGINEER_MODE"
33 %endif
34 %cmake .
35 make %{?jobs:-j%jobs}
36
37 %install
38 rm -rf %{buildroot}
39 %make_install
40 mkdir -p %{buildroot}/%{_datarootdir}/license
41
42 %post
43
44 %files -n liblivebox-cpp
45 %manifest liblivebox-cpp.manifest
46 %defattr(-,root,root,-)
47 %{_libdir}/*.so*
48 %{_datarootdir}/license/*
49
50 %files devel
51 %defattr(-,root,root,-)
52 %{_includedir}/livebox-cpp/livebox-cpp.h
53 %{_datarootdir}/doc/livebox-cpp/livebox-cpp_PG.h
54 %{_libdir}/pkgconfig/*.pc
55
56 # End of a file