Git init
[apps/home/starter.git] / packaging / starter.spec
1 Name:       starter
2 Summary:    starter
3 Version:    0.3
4 Release:    1
5 Group:      TO_BE/FILLED_IN
6 License:    TO_BE/FILLED_IN
7 Source0:    starter-%{version}.tar.gz
8 Requires(post): /usr/bin/vconftool
9 BuildRequires:  cmake
10 BuildRequires:  pkgconfig(glib-2.0)
11 BuildRequires:  pkgconfig(tapi)
12 BuildRequires:  pkgconfig(tapi-priv)
13 BuildRequires:  pkgconfig(vconf)
14 BuildRequires:  pkgconfig(heynoti)
15 BuildRequires:  pkgconfig(aul)
16 BuildRequires:  pkgconfig(x11)
17
18 %description
19 Description: Starter
20
21
22 %prep
23 %setup -q
24
25 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
26
27 %build
28
29 make %{?jobs:-j%jobs}
30 %install
31 rm -rf %{buildroot}
32 %make_install
33
34
35 %post
36 vconftool set -t int "memory/startapps/sequence" 0 -i -u 5000 -g 5000
37
38 ln -sf /etc/init.d/rd4starter /etc/rc.d/rc4.d/S81starter
39 ln -sf /etc/init.d/rd3starter /etc/rc.d/rc3.d/S43starter
40
41 sync
42
43 %files
44 %defattr(-,root,root,-)
45 %{_sysconfdir}/init.d/rd4starter
46 %{_sysconfdir}/init.d/rd3starter
47 %{_datadir}/applications/starter.desktop
48 %{_bindir}/starter
49