tizen 2.3 release
[apps/home/settings.git] / packaging / org.tizen.setting.spec
1 Name:       org.tizen.setting
2 Summary:    Setting application
3 Version:    0.1.98
4 Release:    99
5 Group:      misc
6 License:    samsung
7 Source0:    %{name}-%{version}.tar.gz
8 Source1:    packaging/firewall.service
9 BuildRequires:  pkgconfig(appcore-common)
10 BuildRequires:  pkgconfig(appcore-efl)
11 BuildRequires:  pkgconfig(elementary)
12 BuildRequires:  pkgconfig(vconf)
13 BuildRequires:  pkgconfig(tapi)
14 BuildRequires:  pkgconfig(utilX)
15 BuildRequires:  pkgconfig(bluetooth-api)
16 BuildRequires:  pkgconfig(mm-sound)
17 BuildRequires:  pkgconfig(mm-keysound)
18 BuildRequires:  pkgconfig(openssl)
19 BuildRequires:  pkgconfig(ui-gadget-1)
20 BuildRequires:  pkgconfig(json-glib-1.0)
21 BuildRequires:  pkgconfig(dlog)
22 BuildRequires:  pkgconfig(aul)
23 BuildRequires:  pkgconfig(ecore-input)
24 BuildRequires:  pkgconfig(eina)
25 BuildRequires:  pkgconfig(icu-i18n)
26 BuildRequires:  pkgconfig(ail)
27 BuildRequires:  pkgconfig(glib-2.0)
28 BuildRequires:  pkgconfig(gthread-2.0)
29 BuildRequires:  pkgconfig(dbus-glib-1)
30 BuildRequires:  pkgconfig(dbus-1)
31 BuildRequires:  pkgconfig(ecore-imf)
32 BuildRequires:  pkgconfig(ecore-x)
33 BuildRequires:  pkgconfig(ecore)
34 BuildRequires:  pkgconfig(ecore-file)
35 BuildRequires:  pkgconfig(icu-io)
36 BuildRequires:  pkgconfig(icu-le)
37 BuildRequires:  pkgconfig(icu-lx)
38 BuildRequires:  pkgconfig(icu-uc)
39 BuildRequires:  pkgconfig(ewebkit2)
40 BuildRequires:  pkgconfig(accounts-svc)
41 #BuildRequires:  pkgconfig(drm-client)
42 #BuildRequires:  pkgconfig(drm-trusted)
43 BuildRequires:  pkgconfig(evas)
44 BuildRequires:  pkgconfig(edje)
45 BuildRequires:  pkgconfig(mm-player)
46 BuildRequires:  pkgconfig(capi-network-connection)
47 BuildRequires:  pkgconfig(security-server)
48 BuildRequires:  pkgconfig(feedback)
49 BuildRequires:  pkgconfig(appsvc)
50 BuildRequires:  pkgconfig(libxml-2.0)
51 BuildRequires:  pkgconfig(notification)
52 BuildRequires:  pkgconfig(cairo)
53 BuildRequires:  pkgconfig(capi-system-runtime-info)
54 BuildRequires:  pkgconfig(capi-media-player)
55 BuildRequires:  pkgconfig(capi-media-sound-manager)
56 BuildRequires:  pkgconfig(capi-media-recorder)
57 BuildRequires:  pkgconfig(capi-content-media-content)
58 BuildRequires:  pkgconfig(capi-system-device)
59 BuildRequires:  pkgconfig(capi-appfw-application)
60 BuildRequires:  pkgconfig(capi-appfw-app-manager)
61 BuildRequires:  pkgconfig(capi-appfw-preference)
62 BuildRequires:  pkgconfig(capi-system-sensor)
63 BuildRequires:  pkgconfig(capi-system-info)
64 BuildRequires:  pkgconfig(capi-system-system-settings)
65 BuildRequires:  pkgconfig(capi-network-wifi)
66 BuildRequires:  pkgconfig(capi-network-bluetooth)
67 #BuildRequires:  pkgconfig(capi-network-tethering)
68 BuildRequires:  pkgconfig(capi-media-metadata-extractor)
69 BuildRequires:  pkgconfig(shortcut)
70 BuildRequires:  pkgconfig(xext)
71 BuildRequires:  pkgconfig(ecore-evas)
72 #BuildRequires:  pkgconfig(livebox-service)
73 BuildRequires:  pkgconfig(pkgmgr)
74 BuildRequires:  pkgconfig(storage)
75 BuildRequires:  pkgconfig(pkgmgr-info)
76 BuildRequires:  pkgconfig(iniparser)
77 BuildRequires:  pkgconfig(tts)
78 BuildRequires:  pkgconfig(alarm-service)
79 BuildRequires:  pkgconfig(contacts-service2)
80 #BuildRequires:  pkgconfig(ode_client)
81 BuildRequires:  pkgconfig(deviced)
82 BuildRequires:  pkgconfig(badge)
83 BuildRequires:  pkgconfig(efl-assist)
84 #BuildRequires:  pkgconfig(setting-common-internal)
85 BuildRequires:  pkgconfig(sqlite3)
86 BuildRequires:  pkgconfig(capi-media-camera)
87 BuildRequires:  pkgconfig(notification)
88 BuildRequires: pkgconfig(syspopup)
89 BuildRequires:  pkgconfig(syspopup-caller)
90 #BuildRequires:  pkgconfig(capi-eas-common)
91 #BuildRequires:  pkgconfig(helpui)
92 BuildRequires:  pkgconfig(app2sd)
93 #BuildRequires: pkgconfig(capi-context-manager)
94 BuildRequires:  pkgconfig(capi-media-image-util)
95 BuildRequires:  pkgconfig(capi-appfw-package-manager)
96 BuildRequires:  pkgconfig(capi-telephony)
97 BuildRequires:  libcap-devel
98 BuildRequires:  cmake
99 BuildRequires:  edje-tools
100 BuildRequires:  gettext-tools
101 BuildRequires:  efl-assist-devel
102 BuildRequires:  capi-security-privilege-manager-devel
103 BuildRequires:  hash-signer
104 #BuildRequires:  system-resource-devel-meta
105 BuildRequires: model-build-features
106
107 #Requires: libeas-common
108 Requires: capi-security-privilege-manager
109 Requires(post): attr
110
111 %description
112 Setting application
113  BEAT UI, Setting application.
114
115 %package ref
116 Summary: replacement for org.tizen.setting.xml
117 Group: TO_BE/FILLED_IN
118 Requires(post): org.tizen.setting
119
120 %description ref
121 replace for org.tizen.setting.xml
122  need to check
123
124 %package devel
125 Summary: A setting common library (Development)
126 Group: TO_BE/FILLED_IN
127
128 #Requires: %{name} = %{version}-%{release}
129 #Requires: pkgconfig(setting-common-internal)
130 %description devel
131
132 %prep
133 %setup -q
134
135 %build
136
137 %define PREFIX    "/usr/apps/org.tizen.setting"
138 %define RESDIR    "/usr/apps/org.tizen.setting/res"
139 %define DATADIR    "/usr/apps/org.tizen.setting/data"
140 %define PREF_DATADIR "/opt/usr/apps/org.tizen.setting/data"
141 %define IMAGEDIR    "/usr/apps/org.tizen.setting/res/images"
142 CFLAGS+=" -fPIC -fvisibility=hidden ";export CFLAGS
143 CXXFLAGS+=" -fPIC -fvisibility=hidden ";export CFLAGS
144 LDFLAGS+="-Wl,--rpath=%{PREFIX}/lib -Wl,--hash-style=both -Wl,--as-needed";export LDFLAGS
145
146 %if 0%{?sec_build_binary_debug_enable}
147 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
148 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
149 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
150 %endif
151
152 %if 0%{?tizen_build_binary_release_type_eng}
153 export CFLAGS="$CFLAGS -DTIZEN_ENGINEER_MODE"
154 export CXXFLAGS="$CXXFLAGS -DTIZEN_ENGINEER_MODE"
155 export FFLAGS="$FFLAGS -DTIZEN_ENGINEER_MODE"
156 %endif
157
158
159 %ifarch %{arm}
160 export CFLAGS="$CFLAGS -DTIZEN_BUILD_TARGET"
161 %else
162 export CFLAGS="$CFLAGS -DTIZEN_BUILD_EMULATOR"
163 %endif
164
165 %ifarch %{arm}
166         cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX} -DARCH=arm \
167 %else
168         cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX} -DARCH=x86 \
169 %endif
170 %if 0%{?tizen_build_binary_release_type_eng}
171                 -DBINARY_RELEASE_TYPE_ENG=YES \
172 %endif
173
174 # build all
175 make
176
177 %install
178 rm -rf %{buildroot}
179 %make_install
180
181 %define tizen_sign 1
182 %define tizen_sign_base /usr/apps/org.tizen.setting
183 %define tizen_sign_level platform
184 %define tizen_author_sign 1
185 %define tizen_dist_sign 1
186
187 mkdir -p %{buildroot}%{PREF_DATADIR}
188 mkdir -p %{buildroot}/opt/usr/apps/org.tizen.mode-syspopup/data
189 mkdir -p %{buildroot}%{_libdir}/systemd/system/multi-user.target.wants
190 mkdir -p %{buildroot}%{_libdir}/systemd/system/default.target.wants
191
192 %clean
193
194 %post
195 update-mime-database /usr/share/mime
196
197
198 #setting cap_raw/admin to iptables lib
199 #setcap cap_net_admin,cap_net_raw=ei /usr/sbin/iptables-multi
200 setfattr -n security.capability -v 0sAQAAAgAAAAAAMAAAAAAAAAAAAAA= /usr/sbin/iptables-multi
201
202 #for personal page
203 #mkdir -p /opt/usr/.personalstorage
204 #mkdir -p /opt/storage/personalstorage
205
206 # Set vconf values with -g/-u options
207 GOPTION="-g 6514"
208
209 #Top edit mode
210         vconftool $GOPTION set -t int file/fixedGrid/grid0  "-1" -s org.tizen.setting::private
211         vconftool $GOPTION set -t int file/fixedGrid/grid1  "-1" -s org.tizen.setting::private
212         vconftool $GOPTION set -t int file/fixedGrid/grid2  "-1" -s org.tizen.setting::private
213         vconftool $GOPTION set -t int file/fixedGrid/grid3  "-1" -s org.tizen.setting::private
214         vconftool $GOPTION set -t int file/fixedGrid/grid4  "-1" -s org.tizen.setting::private
215         vconftool $GOPTION set -t int file/fixedGrid/grid5  "-1" -s org.tizen.setting::private
216
217 #resetMenuscreen
218 %ifarch %{arm}
219         vconftool $GOPTION set -t string db/setting/menuscreen/package_name "org.tizen.homescreen" -s system::vconf_inhouse
220 %else
221         vconftool $GOPTION set -t string db/setting/menuscreen/package_name "org.tizen.menu-screen" -s system::vconf_inhouse
222 %endif
223
224 #resetNetwork
225         vconftool $GOPTION set -t bool db/setting/network_restrict_mode "0" -s system::vconf_inhouse
226         vconftool $GOPTION set -t int db/setting/select_network "0" -s org.tizen.setting::private
227         vconftool $GOPTION set -t int db/setting/select_network_act "0" -s org.tizen.setting::private
228         vconftool $GOPTION set -t int db/setting/network_mode "0" -s org.tizen.setting::private
229         vconftool $GOPTION set -t bool db/setting/3gEnabled "1" -s system::vconf_system
230         vconftool $GOPTION set -t bool db/setting/data_roaming "0" -s system::vconf_system
231         vconftool $GOPTION set -t bool memory/setting/network_mode_changed "0" -i -s system::vconf_system
232         vconftool $GOPTION set -t bool db/setting/network/mobile_data_on_reminder "1" -s system::vconf_inhouse
233         vconftool $GOPTION set -t bool db/setting/network/mobile_data_off_reminder "1" -s system::vconf_inhouse
234
235 #resetUsbConnectivity
236         vconftool $GOPTION set -t int memory/setting/usb_mode "-1" -i -s system::vconf_system
237         vconftool $GOPTION set -t int memory/setting/usb_in_mode_change "0" -i -s org.tizen.setting::private
238         vconftool $GOPTION set -t bool db/setting/debug_mode "0" -s system::vconf_system
239         vconftool $GOPTION set -t int db/setting/default_rendering_engine "1" -i -s system::vconf_system
240         vconftool $GOPTION set -t bool db/setting/developer_option_state "0" -s system::vconf_inhouse
241         vconftool $GOPTION set -t bool db/setting/show_cpu_info "0" -s system::vconf_system
242
243 #resetHighTouch
244         vconftool $GOPTION set -t bool memory/setting/enhanced_touch "0" -s org.tizen.setting::private
245
246 #resetSound
247 %ifarch %{arm}
248         DEFAULT_CALL_TONE="/opt/usr/share/settings/Ringtones/Over_the_horizon.ogg"
249 %else
250         DEFAULT_CALL_TONE="/opt/usr/share/settings/Ringtones/ringtone_sdk.mp3"
251 %endif
252
253 %ifarch %{arm}
254         DEFAULT_NOTI_TONE="/opt/usr/share/settings/Alerts/Whistle.ogg"
255 %else
256         DEFAULT_NOTI_TONE="/opt/usr/share/settings/Alerts/General notification_sdk.wav"
257 %endif
258
259         vconftool $GOPTION set -t bool db/setting/sound/sound_on "1" -s system::vconf_inhouse
260         vconftool $GOPTION set -t bool db/setting/sound/vibration_on "0" -s system::vconf_inhouse
261
262         vconftool $GOPTION set -t bool db/setting/sound/vibrate_when_ringing "0" -s system::vconf_setting
263         vconftool $GOPTION set -t bool db/setting/sound/vibrate_when_notification "1" -s system::vconf_setting
264
265         vconftool $GOPTION set -t int db/setting/sound/noti/vibration_level "5" -s system::vconf_inhouse
266         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/vibration_level "3" -s system::vconf_inhouse
267
268         vconftool $GOPTION set -t string db/setting/sound/call/ringtone_path "${DEFAULT_CALL_TONE}" -f -s system::vconf_inhouse
269         vconftool $GOPTION set -t string db/setting/sound/call/ringtone_default_path "${DEFAULT_CALL_TONE}" -f -s system::vconf_setting
270         vconftool $GOPTION set -t string db/setting/sound/noti/msg_ringtone_path        "${DEFAULT_NOTI_TONE}" -f -s system::vconf_inhouse
271         vconftool $GOPTION set -t string db/setting/sound/noti/ringtone_default_path    "${DEFAULT_NOTI_TONE}" -f -s system::vconf_inhouse
272         vconftool $GOPTION set -t int db/setting/sound/noti/msg_alert_rep_type          "0" -s system::vconf_inhouse
273
274         vconftool $GOPTION set -t string db/setting/sound/noti/email_ringtone_path      "${DEFAULT_NOTI_TONE}" -f -s system::vconf_inhouse
275
276         vconftool $GOPTION set -t bool db/setting/sound/button_sounds "1" -s system::vconf_inhouse
277         vconftool $GOPTION set -t bool db/setting/sound/touch_sounds "1" -s system::vconf_inhouse
278         vconftool $GOPTION set -t bool db/setting/sound/sound_lock "1" -s system::vconf_inhouse
279         vconftool $GOPTION set -t bool db/setting/sound/haptic_feedback_on "0" -s system::vconf_inhouse
280
281 #resetSound
282 %ifarch %{arm}
283         DEFAULT_HOME="/opt/usr/share/settings/Wallpapers/Home_default.png"
284         DEFAULT_LOCK="/opt/usr/share/settings/Wallpapers/Lock_default.png"
285 %else
286         # for emulator
287         DEFAULT_HOME="/opt/usr/share/settings/Wallpapers/Home_default.jpg"
288         DEFAULT_LOCK="/opt/usr/share/settings/Wallpapers/Default.jpg"
289 %endif
290
291         vconftool $GOPTION set -t string db/menu_widget/bgset "${DEFAULT_HOME}" -f -s system::vconf_setting
292         vconftool $GOPTION set -t string db/idle_lock/bgset "${DEFAULT_LOCK}" -f -s system::vconf_setting
293
294 #resetTilt
295         vconftool $GOPTION set -t bool db/setting/use_tilt "0" -s system::vconf_inhouse
296
297 #resetPanning
298         vconftool $GOPTION set -t bool db/setting/use_panning "0" -s system::vconf_inhouse
299         vconftool $GOPTION set -t int db/setting/panning_sensitivity "3" -s system::vconf_setting
300         vconftool $GOPTION set -t bool db/setting/use_panning_browser "0" -s system::vconf_inhouse
301         vconftool $GOPTION set -t int db/setting/panning_browser_sensitivity "3" -s org.tizen.setting::private
302
303 #resetDoubleTap
304         vconftool $GOPTION set -t bool db/setting/use_double_tap "0" -s system::vconf_setting
305
306 #resetShake
307         vconftool $GOPTION set -t bool db/setting/use_shake "0" -s system::vconf_inhouse
308
309 #resetPickup
310         vconftool $GOPTION set -t bool db/setting/use_pick_up "1" -s system::vconf_setting
311         vconftool $GOPTION set -t bool db/setting/use_pick_up_call "1" -s system::vconf_inhouse
312
313 #resetTurnOver
314         vconftool $GOPTION set -t bool db/setting/use_turn_over "0" -s system::vconf_setting
315
316 #resetMotions
317         vconftool $GOPTION set -t bool db/setting/motion_active "1" -s system::vconf_system
318         vconftool $GOPTION set -t bool db/setting/motion/palm_motion "0" system::vconf_system
319         vconftool $GOPTION set -t bool db/setting/motion/palm_swipe_capture "1" -s system::vconf_setting
320         vconftool $GOPTION set -t bool db/setting/motion/tap_twist "1" -s system::vconf_setting
321
322 #resetDisplay
323         #backlight
324 %ifarch %{arm}
325         vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "30" -s system::vconf_system
326 %else
327         vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "0" -s system::vconf_system
328 %endif
329         vconftool $GOPTION set -t int db/setting/automatic_brightness_level "50" -f -s system::vconf_inhouse
330         #brightness
331         vconftool $GOPTION set -t int db/setting/Brightness "100" -s system::vconf_system
332         vconftool $GOPTION set -t int db/setting/brightness_automatic "0" -s system::vconf_inhouse
333         vconftool $GOPTION set -t bool db/setting/auto_display_adjustment "1" -s system::vconf_inhouse
334
335         #battery
336         vconftool $GOPTION set -t bool db/setting/battery_percentage "0" -s system::vconf_inhouse
337
338         #smart screen
339         vconftool $GOPTION set -t bool db/setting/auto_adjust_screen_tone "1" -s system::vconf_inhouse
340
341         vconftool $GOPTION set -t int db/setting/display/touchkey_light_duration "90" -s system::vconf_inhouse
342         vconftool $GOPTION set -t int db/setting/display/screen_capture_destination "0" -s system::vconf_inhouse
343         vconftool $GOPTION set -t bool db/setting/display/edit_after_screen_capture "0" -s system::vconf_inhouse
344         vconftool $GOPTION set -t bool db/setting/display/dynamic_status_bar "0" -s system::vconf_inhouse
345
346         #LED indicator
347         vconftool $GOPTION set -t bool db/setting/led_indicator/charging "1" -s system::vconf_setting
348         vconftool $GOPTION set -t bool db/setting/led_indicator/low_batt "0" -s system::vconf_setting
349         vconftool $GOPTION set -t bool db/setting/led_indicator/notifications "1" -s system::vconf_setting
350         vconftool $GOPTION set -t bool db/setting/led_indicator/voice_rec "1" -s system::vconf_setting
351
352 #resetRotationLock
353
354         # to be removed
355         vconftool $GOPTION set -t bool db/setting/rotate_lock "1"  -s system::vconf_inhouse
356
357         vconftool $GOPTION set -t bool db/setting/auto_rotate_screen "1" -s system::vconf_inhouse
358
359 #resetTimeAndData
360 %ifarch %{arm}
361         vconftool $GOPTION set -t bool db/setting/automatic_time_update "1" -s system::vconf_inhouse
362 %else
363         vconftool $GOPTION set -t bool db/setting/automatic_time_update "0" -s system::vconf_inhouse
364 %endif
365
366         vconftool $GOPTION set -t int db/menu_widget/regionformat_time1224 "1" -s system::vconf_setting
367         vconftool $GOPTION set -t int db/setting/date_format "0" -s system::vconf_setting
368         vconftool $GOPTION set -t int db/setting/weekofday_format  "0" -s system::vconf_inhouse
369
370         vconftool $GOPTION set -t string db/setting/timezone "+9:00" -s system::vconf_setting
371         # to be removed
372         vconftool $GOPTION set -t string db/setting/cityname_id "Seoul" -s system::vconf_setting
373
374         vconftool $GOPTION set -t string db/setting/timezone_id "Asia/Seoul" -s system::vconf_inhouse
375
376         rm -f /opt/etc/localtime
377         ln -s /usr/share/zoneinfo/Asia/Seoul /opt/etc/localtime
378         rm -f /etc/localtime
379         ln -s /opt/etc/localtime /etc/localtime
380
381 #resetAccessibility
382         vconftool $GOPTION set -t bool db/setting/accessibility/high_contrast "0" -s system::vconf_system
383         vconftool $GOPTION set -t bool db/setting/accessibility/screen_zoom "0" -s system::vconf_inhouse
384         vconftool $GOPTION set -t int db/setting/accessibility/font_size "1" -s system::vconf_misc
385         vconftool $GOPTION set -t string db/setting/accessibility/font_name "HelveticaNeue" -s system::vconf_misc
386         vconftool $GOPTION set -t bool db/setting/accessibility/tts "0" -s system::vconf_system
387         vconftool $GOPTION set -t int db/setting/accessibility/speech_rate "2" -s system::vconf_inhouse
388         vconftool $GOPTION set -t bool db/setting/accessibility/rapid_key_input "0" -s system::vconf_system
389
390         vconftool $GOPTION set -t bool memory/setting/accessibility/torch_light "0" -i -s system::vconf_system
391         vconftool $GOPTION set -t bool db/setting/accessibility/mono_audio "0" -s system::vconf_setting
392         vconftool $GOPTION set -t int db/setting/accessibility/power_key_hold "1" -s system::vconf_inhouse
393         vconftool $GOPTION set -t bool db/setting/accessibility/turn_off_all_sounds "0" -s system::vconf_setting
394
395         vconftool $GOPTION set -t int db/setting/accessibility/lock_time "5" -s system::vconf_setting
396         vconftool $GOPTION set -t string db/setting/accessibility/taphold_delay "IDS_COM_POP_SHORT" -s system::vconf_setting
397
398 #resetLanguageAndRegion
399         vconftool $GOPTION set -t bool db/setting/lang_automatic "0" -s org.tizen.setting::private
400         vconftool $GOPTION set -t bool db/setting/region_automatic "1" -s org.tizen.setting::private
401         vconftool $GOPTION set -t string db/menu_widget/language "en_US.UTF-8" -s system::vconf_inhouse
402         vconftool $GOPTION set -t string db/menu_widget/regionformat "en_US.UTF-8" -s system::vconf_inhouse
403
404 #resetSecurity
405         rm -rf /opt/usr/data/setting/set_info
406
407         vconftool $GOPTION set -t int db/setting/screen_lock_type "1" -s system::vconf_inhouse
408         vconftool $GOPTION set -t string db/setting/3rd_lock_pkg_name "org.tizen.lockscreen" -s system::vconf_inhouse
409         vconftool $GOPTION set -t bool db/setting/fmm/sim_change_alert "0" -s system::vconf_inhouse
410         vconftool $GOPTION set -t string db/setting/fmm/recipients "" -s system::vconf_inhouse
411         vconftool $GOPTION set -t string db/setting/fmm/sender "" -s system::vconf_inhouse
412         vconftool $GOPTION set -t string db/setting/fmm/alert_message "" -s system::vconf_inhouse
413
414         # for MMC encryption
415         vconftool $GOPTION set -t bool db/setting/mmc_encryption/status "0" -s system::vconf_system
416         vconftool $GOPTION set -t int db/setting/mmc_encryption/option "0" -s org.tizen.setting::private
417         vconftool $GOPTION set -t bool db/setting/mmc_encryption/exclude_multimedia "0" -s org.tizen.setting::private
418
419 #resetMemory
420         vconftool $GOPTION set -t int db/setting/default_memory/install_applications "0" -s system::vconf_system
421
422         vconftool $GOPTION set -t int db/setting/default_memory/bluetooth "0" -s system::vconf_system
423
424 #resetAbout
425         vconftool $GOPTION set -t string db/setting/device_name "Tizen" -s system::vconf_network
426
427 #resetDevoptions
428         vconftool $GOPTION -i set -t int db/setting/devoption/bgprocess "0" -s system::vconf_setting
429
430 #resetDatausage
431         vconftool $GOPTION set -t bool db/setting/set_data_usage_limit "0" -s org.tizen.setting::private
432         vconftool $GOPTION set -t int db/setting/data_limit "-1" -s org.tizen.setting::private
433         vconftool $GOPTION set -t int db/setting/data_each_month "1" -s org.tizen.setting::private
434         vconftool $GOPTION set -t int db/setting/data_each_month_app "1" -s org.tizen.setting::private
435         vconftool $GOPTION set -t int db/setting/data_limit_roaming "-1" -s org.tizen.setting::private
436         vconftool $GOPTION set -t bool db/setting/set_data_usage_limit_roaming "0" -s org.tizen.setting::private
437
438 #resetDisplay
439         vconftool $GOPTION set -t string db/setting/screenmode/selected_name "Dynamic" -f -s org.tizen.setting::private
440
441 #resetMostRecentlySetting
442         vconftool $GOPTION set -t string db/setting/most_recently_setting "" -s org.tizen.setting::private
443
444 #psmode(power saving mode)
445         vconftool $GOPTION set -t int db/setting/psmode "0" -s system::vconf_setting
446         vconftool $GOPTION set -t bool db/setting/win_gray "0" -s system::vconf_setting
447         vconftool $GOPTION set -t bool db/setting/win_fps "0" -s system::vconf_setting
448         vconftool $GOPTION set -t int db/setting/emergency/mode "1" -s system::vconf_setting
449
450 #resetPowersaving
451         vconftool $GOPTION set -t bool db/setting/pwrsv/system_mode/status "0" -s org.tizen.setting::private
452
453         #v0.4
454         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/cpu "0" -s system::vconf_inhouse
455
456 # personal page(not include on vconf internal yet)
457         vconftool $GOPTION set -t bool memory/setting/personal "0" -i -s system::vconf_setting
458         vconftool $GOPTION set -t int db/setting/personal_unlock_method "-1" -s system::vconf_setting
459         vconftool $GOPTION set -t string db/setting/personal_key "" -s system::vconf_setting
460
461 #usb otg
462         vconftool $GOPTION set -t bool db/setting/usb_otg "1" -s system::vconf_inhouse
463
464 #hands-free reminder
465         vconftool $GOPTION set -t int db/setting/handsfree_sound_reminder "0" -s org.tizen.setting::private
466
467 #hands-free reminder
468         vconftool $GOPTION set -t bool db/setting/firewall "0" -s org.tizen.setting::private
469
470 # changeable UI - color theme
471         vconftool $GOPTION set -t int db/setting/change_ui/theme "0" -s system::vconf_inhouse
472         vconftool $GOPTION set -t bool db/setting/change_ui/color_theme_wallpaper_set "0" -s system::vconf_inhouse
473
474 # multi-window
475         vconftool $GOPTION set -t bool db/setting/open_via_multi "0" -s system::vconf_setting
476
477 #------------------------------------------
478 #create directory /opt/usr/data/setting
479 #------------------------------------------
480 #create directory /opt/usr/apps/org.tizen.setting.data
481 if [ ! -d /opt/usr/apps/org.tizen.setting ]
482 then
483     mkdir -p /opt/usr/apps/org.tizen.setting
484     mkdir -p %{PREF_DATADIR}
485 fi
486
487
488 if [ ! -d /var/kdb/file/fixedGrid ]
489 then
490     mkdir -p /var/kdb/file/fixedGrid
491 fi
492
493 if [ -d /var/kdb/file/fixedGrid ]
494 then
495         chown app:app /var/kdb/file/fixedGrid -R
496 fi
497
498 # for support shared menu icons
499 ln -s /usr/apps/org.tizen.setting/res/icons /usr/apps/org.tizen.setting/shared/res/icons
500
501
502 /usr/apps/org.tizen.setting/bin/setting_conf_util timezone_init
503 chown 5000:5000 %{PREF_DATADIR} -R
504 #------------------------------------------
505 sync
506
507 if [ -d /opt/share/settings ]
508 then
509         rm -rf /opt/share/settings
510 fi
511
512 ln -s /opt/usr/share/settings /opt/share/settings
513
514
515 mkdir -p /usr/ug/bin/
516 # help directory
517 mkdir -p /usr/apps/org.tizen.setting/shared
518 mkdir -p /usr/apps/org.tizen.setting/shared/res
519 mkdir -p /usr/apps/org.tizen.mode-syspopup/res/edje
520 mkdir -p /usr/apps/org.tizen.mode-syspopup/bin/
521
522 #%post ref
523 #Requires(post): org.tizen.setting
524
525
526 %post ref
527 rm -rf /usr/share/packages/org.tizen.setting.xml
528 mv /usr/share/packages/org.tizen.setting.xml.ref /usr/share/packages/org.tizen.setting.xml
529
530 %posttrans
531
532 #%files -n settings
533 %files -n org.tizen.setting
534 %manifest org.tizen.setting.manifest
535
536
537 /usr/apps/org.tizen.setting/author-signature.xml
538 /usr/apps/org.tizen.setting/signature1.xml
539
540 # Smack default --------------------------------------------------
541 /etc/smack/accesses.d/org.tizen.setting.efl
542
543 # Firewall -------------------------------------------------------
544 /etc/opt/upgrade/210.org.tizen.setting.patch.sh
545
546 %defattr(-,root,root,-)
547 /usr/apps/org.tizen.mode-syspopup/bin/mode-syspopup
548 /usr/apps/org.tizen.mode-syspopup/res/images/*
549 /usr/apps/org.tizen.mode-syspopup/res/edje/mode-syspopup.edj
550 /usr/apps/org.tizen.mode-syspopup/res/edje/popup-custom.edj
551 /usr/apps/org.tizen.mode-syspopup/res/edje/ultra-popup.edj
552 /usr/apps/org.tizen.mode-syspopup/res/locale/*
553
554 %attr(-,app,app) %dir /opt/usr/apps/org.tizen.mode-syspopup/data
555
556 %attr(-,app,app) %dir %{PREF_DATADIR}
557 /usr/apps/org.tizen.setting/bin/setting
558 /usr/apps/org.tizen.setting/data/*
559 /usr/apps/org.tizen.setting/bin/setting_conf_util
560 /usr/apps/org.tizen.setting/bin/setting_turnoff_light
561 /usr/apps/org.tizen.setting/bin/setting_volume_popup
562
563 %attr(0755,root,root) /usr/apps/org.tizen.setting/bin/setting_help_ringtone
564
565 /usr/lib/lib*.so.*
566
567 /usr/share/packages/org.tizen.setting.xml
568
569 /usr/share/icons/default/small/org.tizen.setting.png
570 /opt/usr/share/settings/*
571 /usr/apps/org.tizen.setting/res/*
572 /usr/share/mime/packages/*
573
574 /usr/apps/org.tizen.setting/shared/res/*
575 %attr(-,app,app) %dir /usr/apps/org.tizen.setting/shared
576
577 /usr/apps/org.tizen.setting/data/*
578
579 /opt/usr/apps/org.tizen.setting/data/langlist.xml
580 /opt/usr/apps/org.tizen.setting/data/langlist_all.xml
581 /opt/usr/apps/org.tizen.setting/data/test.db
582
583
584 # new
585 /usr/apps/org.tizen.setting/lib/ug/*
586
587 %files devel
588 #---------------------------------------------
589 # moved from org.tizen.setting
590 #---------------------------------------------
591 #/usr/apps/org.tizen.setting/lib/lib*.so
592 /usr/lib/lib*.so
593 /usr/apps/org.tizen.setting/lib/ug/*
594
595 %{_libdir}/pkgconfig/*.pc
596 /usr/lib/pkgconfig/setting-common-internal.pc
597 /usr/include/setting-cfg.h
598 /usr/include/setting-common-data-edj-define.h
599 /usr/include/setting-common-data-error.h
600 /usr/include/setting-common-data-type.h
601 /usr/include/setting-common-draw-widget.h
602 /usr/include/setting-common-general-func.h
603 /usr/include/setting-common-resource.h
604 /usr/include/setting-common-search.h
605
606 %files ref
607 /usr/share/mime/packages/mime.setting.xml
608 /usr/share/packages/org.tizen.setting.xml.ref