Initialize Tizen 2.3
[apps/home/b2-clocksetting.git] / packaging / org.tizen.setting.spec
1 %define PREFIX /usr/apps/org.tizen.clocksetting
2 Name: org.tizen.clocksetting
3 Version:    0.0.2
4 Release:    1
5 Summary: Tizen W ClockSetting application
6 URL: http://slp-source.sec.samsung.net
7 Source: %{name}-%{version}.tar.gz
8 License: SAMSUNG
9 Group: TO_BE/FILLED_IN
10
11 BuildRequires: cmake
12 BuildRequires: pkgconfig(edje)
13 BuildRequires: pkgconfig(embryo)
14 BuildRequires: pkgconfig(ecore)
15 BuildRequires: pkgconfig(elementary)
16 BuildRequires: pkgconfig(utilX)
17 BuildRequires: pkgconfig(appcore-efl)
18 BuildRequires: pkgconfig(appcore-common)
19 BuildRequires: pkgconfig(dlog)
20 BuildRequires: pkgconfig(glib-2.0)
21 BuildRequires: pkgconfig(capi-appfw-application)
22 BuildRequires: pkgconfig(capi-appfw-app-manager)
23 BuildRequires: pkgconfig(feedback)
24 BuildRequires: pkgconfig(vconf)
25 BuildRequires: pkgconfig(json-glib-1.0)
26 BuildRequires: pkgconfig(deviced)
27 BuildRequires: pkgconfig(pkgmgr)
28 BuildRequires: pkgconfig(pkgmgr-info)
29 BuildRequires: efl-assist-devel
30 BuildRequires: gettext-tools
31 BuildRequires: edje-bin, embryo-bin
32 BuildRequires: elementary-devel
33 BuildRequires: efl-assist-devel
34 BuildRequires: pkgconfig(bluetooth-api)
35 BuildRequires: pkgconfig(capi-network-bluetooth)
36 BuildRequires: pkgconfig(capi-base-common)
37 BuildRequires: pkgconfig(capi-system-device)
38 BuildRequires: pkgconfig(capi-media-sound-manager)
39 BuildRequires: pkgconfig(capi-media-player)
40 BuildRequires: pkgconfig(capi-content-media-content)
41 BuildRequires: pkgconfig(capi-system-info)
42 BuildRequires: pkgconfig(capi-system-system-settings)
43 BuildRequires: pkgconfig(mm-player)
44 BuildRequires: pkgconfig(mm-sound)
45 BuildRequires: pkgconfig(libxml-2.0)
46 BuildRequires: pkgconfig(capi-media-wav-player)
47 BuildRequires: pkgconfig(ail)
48 BuildRequires: pkgconfig(aul)
49
50 %description
51 W ClockSetting application
52
53 %prep
54 %setup -q
55
56 %build
57 %if 0%{?tizen_build_binary_release_type_eng}
58 export CFLAGS+=" -DTIZEN_ENGINEER_MODE"
59 export CXXFLAGS+=" -DTIZEN_ENGINEER_MODE"
60 export FFLAGS+=" -DTIZEN_ENGINEER_MODE"
61 %endif
62 %if 0%{?sec_build_binary_debug_enable}
63 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
64 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
65 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
66 %endif
67
68 LDFLAGS+="-Wl,--rpath=%{PREFIX}/lib -Wl,--as-needed -Wl,--hash-style=both"; export LDFLAGS
69 cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX} -DFEATURE_SETTING_SDK=YES \
70 %ifarch %{ix86}
71         -DFEATURE_SETTING_EMUL=YES \
72 %endif
73
74 make %{?jobs:-j%jobs}
75
76
77 %install
78 rm -rf %{buildroot}
79
80 %make_install
81 mkdir -p %{buildroot}/opt/usr/apps/org.tizen.clocksetting
82 mkdir -p %{buildroot}/opt/usr/apps/org.tizen.clocksetting/data/images
83
84 %clean
85
86 %post
87
88 # Set vconf values with -g/-u options
89 GOPTION="-g 6514"
90
91 #resetMenuscreen
92         #vconftool $GOPTION set -t string db/setting/menuscreen/selected "org.tizen.cluster-home"
93 %ifarch %{arm}
94         vconftool $GOPTION set -t string db/setting/menuscreen/package_name "org.tizen.cluster-home" -s system::vconf_inhouse
95         vconftool $GOPTION set -t string db/setting/homescreen/package_name "org.tizen.cluster-home" -s system::vconf_setting
96 %else
97         vconftool $GOPTION set -t string db/setting/menuscreen/package_name "org.tizen.menu-screen" -s system::vconf_inhouse
98         vconftool $GOPTION set -t string db/setting/homescreen/package_name "org.tizen.menu-screen" -s system::vconf_setting
99 %endif
100
101 #resetFlightmode
102 #       vconftool $GOPTION set -t bool db/telephony/flight_mode "0" -f -s system::vconf_network
103
104 #resetHomeBG
105         vconftool $GOPTION set -t int db/setting/home_bg_color_type "0" -s system::vconf_inhouse
106
107         vconftool $GOPTION set -t int db/setting/idle_clock_type "9" -s system::vconf_inhouse
108         vconftool $GOPTION set -t bool db/setting/hourly_alert "0" -s system::vconf_inhouse
109         vconftool $GOPTION set -t bool db/setting/prefer_arm_left "1" -s system::vconf_inhouse
110
111 #resetMotions
112         vconftool $GOPTION set -t int db/setting/motion_wake_up_guesture "2" -s system::vconf_inhouse
113         vconftool $GOPTION set -t bool db/setting/motion_smart_relay "0" -s system::vconf_inhouse
114
115
116 #resetNetwork
117         vconftool $GOPTION set -t int db/setting/select_network "0" -s org.tizen.setting::private
118         vconftool $GOPTION set -t int db/setting/select_network_act "0" -s org.tizen.setting::private
119         vconftool $GOPTION set -t int db/setting/network_mode "0" -s org.tizen.setting::private
120         vconftool $GOPTION set -t bool db/setting/3gEnabled "1" -s org.tizen.setting::system
121         vconftool $GOPTION set -t bool db/setting/data_roaming "0" -s system::vconf_system
122         vconftool $GOPTION set -t bool memory/setting/network_mode_changed "0" -i -s system::vconf_system
123
124 #resetUsbConnectivity
125         vconftool $GOPTION set -t int memory/setting/usb_mode "-1" -i -s system::vconf_system
126         vconftool $GOPTION set -t int memory/setting/usb_sel_mode "0" -i -s system::vconf_system
127         vconftool $GOPTION set -t int memory/setting/usb_in_mode_change "0" -i -s org.tizen.setting::private
128         vconftool $GOPTION set -t bool db/setting/debug_mode "0" -s system::vconf_system
129         vconftool $GOPTION set -t int db/setting/default_rendering_engine "1" -i -s system::vconf_system
130
131 #resetSound
132 %ifarch %{arm}
133         DEFAULT_CALL_TONE="/opt/share/settings/Ringtones/Twinkle.ogg"
134         #DEFAULT_CALL_TONE="/opt/share/settings/Ringtones/Ringtone1.ogg"
135 %else
136         DEFAULT_CALL_TONE="/opt/share/settings/Ringtones/Ringtone.ogg"
137         #DEFAULT_CALL_TONE="/opt/share/settings/Ringtones/Ringtone1.ogg"
138 %endif
139
140 %ifarch %{arm}
141         DEFAULT_NOTI_TONE="/opt/share/settings/Alerts/Flicker.ogg"
142         #DEFAULT_NOTI_TONE="/opt/share/settings/Alerts/Notification1.ogg"
143 %else
144         DEFAULT_NOTI_TONE="/opt/share/settings/Alerts/Notification.ogg"
145         #DEFAULT_NOTI_TONE="/opt/share/settings/Alerts/Notification1.ogg"
146 %endif
147
148         vconftool $GOPTION set -t bool db/setting/sound/sound_on "0" -s system::vconf_inhouse
149         vconftool $GOPTION set -t bool db/setting/sound/vibration_on "1" -s system::vconf_inhouse
150
151         vconftool $GOPTION set -t bool db/setting/sound/vibrate_when_ringing "1" -s system::vconf_setting
152         vconftool $GOPTION set -t bool db/setting/sound/vibrate_when_notification "1" -s system::vconf_setting
153
154         vconftool $GOPTION set -t int db/setting/sound/call/ringtone_sound_volume "11" -s system::vconf_setting
155         vconftool $GOPTION set -t int db/setting/sound/call/rmd_ringtone_volume "11" -s system::vconf_setting
156         vconftool $GOPTION set -t int db/setting/sound/noti/sound_volume "11" -s system::vconf_inhouse
157         vconftool $GOPTION set -t int db/setting/sound/media/sound_volume "11" -s org.tizen.setting::private
158         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/sound_volume "9" -s org.tizen.setting::private
159
160         vconftool $GOPTION set -t int db/setting/sound/noti/vibration_level "3" -s system::vconf_inhouse
161         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/vibration_level "3" -s system::vconf_inhouse
162         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/vibration_level_bak "3" -s org.tizen.setting::private
163
164         vconftool $GOPTION set -t string db/setting/sound/call/ringtone_path "${DEFAULT_CALL_TONE}" -f -s system::vconf_inhouse
165         vconftool $GOPTION set -t string db/setting/sound/call/ringtone_default_path "${DEFAULT_CALL_TONE}" -f -s system::vconf_setting
166         vconftool $GOPTION set -t int db/setting/sound/call/vibration_type "2" -s system::vconf_setting
167         vconftool $GOPTION set -t string db/setting/sound/call/vibration_pattern_path "/opt/share/settings/Vibrations/haptic/default/Notification_Call.ivt" -f -s system::vconf_setting
168         vconftool $GOPTION set -t string db/setting/sound/noti/msg_ringtone_path        "${DEFAULT_NOTI_TONE}" -f -s system::vconf_inhouse
169         vconftool $GOPTION set -t string db/setting/sound/noti/ringtone_default_path    "${DEFAULT_NOTI_TONE}" -f -s system::vconf_inhouse
170         vconftool $GOPTION set -t int db/setting/sound/noti/msg_alert_rep_type          "0" -s system::vconf_inhouse
171
172         vconftool $GOPTION set -t string db/setting/sound/noti/email_ringtone_path      "${DEFAULT_NOTI_TONE}" -f -s system::vconf_inhouse
173         vconftool $GOPTION set -t int db/setting/sound/noti/email_alert_rep_type                "0" -s system::vconf_inhouse
174
175         vconftool $GOPTION set -t bool db/setting/sound/button_sounds "0" -s system::vconf_inhouse
176         vconftool $GOPTION set -t bool db/setting/sound/touch_sounds "0" -s system::vconf_inhouse
177         vconftool $GOPTION set -t bool db/setting/sound/sound_lock "0" -s system::vconf_inhouse
178         vconftool $GOPTION set -t bool db/setting/sound/haptic_feedback_on "1" -s system::vconf_inhouse
179
180         vconftool $GOPTION set -t bool db/setting/sound/sound_on_bak "1" -s org.tizen.setting::private
181         vconftool $GOPTION set -t bool db/setting/sound/touch_sounds_bak "1" -s org.tizen.setting::private
182         vconftool $GOPTION set -t bool db/setting/sound/sound_lock_bak "1" -s org.tizen.setting::private
183 #resetWallpaper
184         vconftool $GOPTION set -t string db/menu_widget/bgset "/opt/share/settings/Wallpapers/wallpaper_01.png" -f -s system::vconf_inhouse
185         vconftool $GOPTION set -t string db/idle_lock/bgset "/opt/usr/share/settings/Wallpapers/Lock_default.png" -f -s system::vconf_inhouse
186
187 #resetTilt
188         vconftool $GOPTION set -t bool db/setting/use_tilt "0" -s system::vconf_inhouse
189         vconftool $GOPTION set -t int db/setting/tilt_sensitivity "3" -s org.tizen.setting::private
190         vconftool $GOPTION set -t bool db/setting/use_tilt_scroll "1" -s org.tizen.setting::private
191         vconftool $GOPTION set -t int db/setting/tilt_scroll_sensitivity "3" -s org.tizen.setting::private
192
193 #resetPanning
194         vconftool $GOPTION set -t bool db/setting/use_panning "0" -s system::vconf_inhouse
195         vconftool $GOPTION set -t int db/setting/panning_sensitivity "3" -s org.tizen.setting::private
196         vconftool $GOPTION set -t bool db/setting/use_panning_browser "0" -s system::vconf_inhouse
197         vconftool $GOPTION set -t int db/setting/panning_browser_sensitivity "3" -s org.tizen.setting::private
198
199 #resetDoubleTap
200         vconftool $GOPTION set -t bool db/setting/use_double_tap "0" -s system::vconf_setting
201
202 #resetShake
203         vconftool $GOPTION set -t bool db/setting/use_shake "0" -s system::vconf_inhouse
204
205 #resetPickup
206         vconftool $GOPTION set -t bool db/setting/use_pick_up "1" -s system::vconf_setting
207         vconftool $GOPTION set -t bool db/setting/use_pick_up_call "0" -s system::vconf_inhouse
208
209 #resetTurnOver
210         vconftool $GOPTION set -t bool db/setting/use_turn_over "0" -s system::vconf_setting
211
212 #resetMotions
213         vconftool $GOPTION set -t bool db/setting/motion_active "0" -s system::vconf_system
214         vconftool $GOPTION set -t bool db/setting/motion/palm_swipe_capture "1" -s org.tizen.setting::private
215         vconftool $GOPTION set -t bool db/setting/motion/palm_touch_mute "1" -s org.tizen.setting::private
216         vconftool $GOPTION set -t bool db/setting/motion/tap_twist "1" -s org.tizen.setting::private
217
218 #resetDisplay
219         #backlight
220 %ifarch %{arm}
221         vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "10" -s system::vconf_system
222 %else
223         vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "0" -s system::vconf_system
224 %endif
225         vconftool $GOPTION set -t int db/setting/lcd_timeout_normal_backup "10" -s org.tizen.setting::private
226         vconftool $GOPTION set -t int db/setting/automatic_brightness_level "60" -f -s org.tizen.setting::private
227         #brightness
228         vconftool $GOPTION set -t int db/setting/Brightness "80" -s system::vconf_system
229         vconftool $GOPTION set -t int db/setting/brightness_automatic "0" -s system::vconf_inhouse
230         vconftool $GOPTION set -t bool db/setting/auto_display_adjustment "1" -s system::vconf_inhouse
231
232         #battery
233         vconftool $GOPTION set -t bool db/setting/battery_percentage "1" -s system::vconf_inhouse
234         #launch
235         #vconftool $GOPTION set -t string db/menu_widget/launch_effect "0"
236
237         #smart screen
238         vconftool $GOPTION set -t int db/pm/smartstay_status "0" -f -s org.tizen.setting::private
239         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_rotation "0" -s system::vconf_inhouse
240         vconftool $GOPTION set -t bool db/setting/auto_adjust_screen_tone "1" -s system::vconf_inhouse
241         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_stay_r "1" -s org.tizen.setting::private
242         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_rotation_r "1" -s org.tizen.setting::private
243         vconftool $GOPTION set -t int db/setting/display/touchkey_light_duration "90" -s system::vconf_inhouse
244         vconftool $GOPTION set -t int db/setting/display/screen_capture_destination "0" -s system::vconf_inhouse
245         vconftool $GOPTION set -t bool db/setting/display/edit_after_screen_capture "0" -s system::vconf_inhouse
246
247         #LED indicator
248         vconftool $GOPTION set -t bool db/setting/led_indicator/charging "1" -s system::vconf_setting
249         vconftool $GOPTION set -t bool db/setting/led_indicator/low_batt "0" -s system::vconf_setting
250         vconftool $GOPTION set -t bool db/setting/led_indicator/notifications "1" -s system::vconf_setting
251         vconftool $GOPTION set -t bool db/setting/led_indicator/voice_rec "1" -s system::vconf_setting
252
253         #Accessory SViewer
254         vconftool $GOPTION set -t bool db/setting/accessories/atuomatic_unlock "1" -s system::vconf_setting
255         vconftool $GOPTION set -t bool db/setting/accessories/dock_sound "0" -s system::vconf_setting
256         vconftool $GOPTION set -t bool db/setting/accessories/audio_output_mode "0" -s system::vconf_setting
257         vconftool $GOPTION set -t bool db/setting/accessories/audio_output_mode_reminder "0" -f -s org.tizen.setting::private
258         vconftool $GOPTION set -t bool db/setting/accessories/desk_home_screen_display "1" -s system::vconf_setting
259         vconftool $GOPTION set -t bool db/setting/accessories/hdmi_application "0" -s system::vconf_setting
260         vconftool $GOPTION set -t int db/setting/accessories/audio_output "0" -s system::vconf_setting
261         vconftool $GOPTION set -t bool db/setting/accessories/audio_applications "0" -s system::vconf_setting
262
263
264 #resetPowersaving
265         vconftool $GOPTION set -t bool db/setting/pwrsv/system_mode/status "0" -s org.tizen.setting::private
266
267         # remove this - and use 'preference'
268         vconftool $GOPTION set -t bool db/setting/pwrsv/system_mode/reminder "1" -s org.tizen.setting::private
269         #---------------------------------------------------------------------------
270
271         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/status "0" -s system::vconf_inhouse
272
273         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/at "30" -s org.tizen.setting::private
274         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/wifi "1" -s org.tizen.setting::private
275         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/bt "0" -s org.tizen.setting::private
276         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/gps "1" -s org.tizen.setting::private
277         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/data_sync "1" -s org.tizen.setting::private
278         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/hotspot "1" -s org.tizen.setting::private
279
280         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/brt/status  "1" -s org.tizen.setting::private
281         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/brt/auto/status "0" -s org.tizen.setting::private
282         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/brt/value "10" -s org.tizen.setting::private
283         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/backlight/time "15" -s org.tizen.setting::private
284
285         #v0.4
286         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/cpu "0" -s system::vconf_inhouse
287         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/display "0" -s system::vconf_inhouse
288         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/bg_color "0" -s system::vconf_inhouse
289         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/screen_vib "0" -s system::vconf_inhouse
290
291 #resetFont
292         vconftool $GOPTION set -t int db/setting/font_size "1" -s org.tizen.setting::private
293         vconftool $GOPTION set -t int db/setting/font_type "0" -s org.tizen.setting::private
294         vconftool $GOPTION set -t string memory/setting/tmp_font_name ""  -i -s org.tizen.setting::private
295
296 #resetRotationLock
297
298         # to be removed
299         vconftool $GOPTION set -t bool db/setting/rotate_lock "1"  -s org.tizen.setting::private
300
301         vconftool $GOPTION set -t bool db/setting/auto_rotate_screen "1" -s system::vconf_inhouse
302         vconftool $GOPTION set -t bool memory/setting/rotate_hold "0" -i -f -s org.tizen.setting::private
303
304 #resetTimeAndData
305 %ifarch %{arm}
306         vconftool $GOPTION set -t bool db/setting/automatic_time_update "1" -s system::vconf_inhouse
307 %else
308         vconftool $GOPTION set -t bool db/setting/automatic_time_update "0" -s system::vconf_inhouse
309 %endif
310
311         vconftool $GOPTION set -t int db/menu_widget/regionformat_time1224 "1" -s system::vconf_setting
312         vconftool $GOPTION set -t int db/setting/date_format "0" -s system::vconf_setting
313         vconftool $GOPTION set -t int db/setting/weekofday_format  "0" -s system::vconf_inhouse
314
315         vconftool $GOPTION set -t string db/setting/timezone "+9:00" -s system::vconf_setting
316         # to be removed
317         vconftool $GOPTION set -t string db/setting/cityname_id "IDS_WCL_BODY_CITYNAME_SEOUL" -s system::vconf_setting
318
319         vconftool $GOPTION set -t string db/setting/timezone_id "Asia/Seoul" -s system::vconf_inhouse
320
321         touch /opt/etc/initial_localtime
322         ln -sf /opt/etc/initial_localtime /opt/etc/localtime
323         ln -sf /opt/etc/localtime /etc/localtime
324
325 #resetAccessibility
326         vconftool $GOPTION set -t bool db/setting/accessibility/high_contrast "0" -s system::vconf_system
327         vconftool $GOPTION set -t bool db/setting/accessibility/screen_zoom "0" -s system::vconf_inhouse
328         vconftool $GOPTION set -t int db/setting/accessibility/font_size "1" -s system::vconf_inhouse   #vconftool $GOPTION set -t int db/setting/accessibility/font_style "0"
329         vconftool $GOPTION set -t string db/setting/accessibility/font_name "HelveticaNeue" -s system::vconf_misc
330         vconftool $GOPTION set -t bool db/setting/accessibility/tts "0" -s system::vconf_system
331         vconftool $GOPTION set -t int db/setting/accessibility/speech_rate "2" -s system::vconf_inhouse
332
333         vconftool $GOPTION set -t bool memory/setting/accessibility/torch_light "0" -i -s system::vconf_system
334         vconftool $GOPTION set -t bool db/setting/accessibility/assistive_light_reminder "1" -s system::vconf_inhouse
335         vconftool $GOPTION set -t bool db/setting/accessibility/mono_audio "0" -s system::vconf_setting
336         vconftool $GOPTION set -t int db/setting/accessibility/power_key_hold "1" -s system::vconf_inhouse
337         vconftool $GOPTION set -t bool db/setting/accessibility/led_notify "0" -s system::vconf_setting
338         vconftool $GOPTION set -t string db/setting/accessibility/led_playing_path "/usr/share/feedback/led/default/Ticktock.led" -s org.tizen.setting::private
339         vconftool $GOPTION set -t bool db/setting/accessibility/turn_off_all_sounds "0" -s system::vconf_setting
340
341         vconftool $GOPTION set -t bool db/setting/accessibility/speak_passwd  "0" -s org.tizen.setting::private
342         vconftool $GOPTION set -t int db/setting/accessibility/lock_time "5" -s system::vconf_setting
343         vconftool $GOPTION set -t string db/setting/accessibility/taphold_delay "IDS_COM_POP_SHORT" -s org.tizen.setting::private
344
345 # duplicated key creation (it's in Call setting)
346 #       vconftool $GOPTION set -t bool db/ciss/call_answering_key "0"
347 #       vconftool $GOPTION set -t bool db/ciss/call_power_key_ends_call "0"
348 #       vconftool $GOPTION set -t int db/ciss/answering_mode "0"
349 #       vconftool $GOPTION set -t int db/ciss/answering_mode_time "3"
350
351         vconftool $GOPTION set -t bool db/setting/accessibility/accept_call "0" -s org.tizen.setting::private
352         vconftool $GOPTION set -t bool db/setting/accessibility/enable_auto_answer "0" -s org.tizen.setting::private
353         vconftool $GOPTION set -t int db/setting/accessibility/auto_answer "1" -s org.tizen.setting::private
354         vconftool $GOPTION set -t bool db/setting/accessibility/powerkey_end_calls "0" -s org.tizen.setting::private
355
356         vconftool $GOPTION set -t int db/setting/accessibility/sound_balance "50" -s org.tizen.setting::private
357 # Colorblind
358         vconftool $GOPTION set -t bool db/setting/colorblind/status "0" -s org.tizen.setting::private
359         vconftool $GOPTION set -t string db/setting/colorblind/chip_array "" -s org.tizen.setting::private
360         vconftool $GOPTION set -t string db/setting/colorblind/rgbcmy "" -s org.tizen.setting::private
361         vconftool $GOPTION set -t double db/setting/colorblind/user_adjustment "0.0" -s org.tizen.setting::private
362 # Driving Mode
363         vconftool $GOPTION set -t bool db/setting/drivingmode/drivingmode "0" -s system::vconf_inhouse
364         vconftool $GOPTION set -t bool db/setting/drivingmode/incomingcall "0" -s system::vconf_setting
365         vconftool $GOPTION set -t bool db/setting/drivingmode/message "0" -s system::vconf_setting
366         vconftool $GOPTION set -t bool db/setting/drivingmode/newemails "0" -s system::vconf_setting
367         vconftool $GOPTION set -t bool db/setting/drivingmode/newvoicemails "0" -s system::vconf_setting
368         vconftool $GOPTION set -t bool db/setting/drivingmode/alarm "0" -s system::vconf_setting
369         vconftool $GOPTION set -t bool db/setting/drivingmode/schedule "0" -s system::vconf_setting
370         vconftool $GOPTION set -t bool db/setting/drivingmode/unlockscreen "0" -s system::vconf_setting
371
372 # Easymode
373         vconftool $GOPTION set -t bool db/setting/homescreen/easymode "0" -s system::vconf_inhouse
374
375 # Blocking Mode
376         vconftool $GOPTION set -t bool db/setting/blockingmode/blockingmode "0" -s system::vconf_setting
377         vconftool $GOPTION set -t bool db/setting/blockingmode/inter/incomingcall "0" -s system::vconf_setting
378         vconftool $GOPTION set -t bool db/setting/blockingmode/inter/notifications "0" -s system::vconf_setting
379         vconftool $GOPTION set -t bool db/setting/blockingmode/inter/alarm_and_timer "0" -s system::vconf_setting
380
381         vconftool $GOPTION set -t int db/setting/blockingmode/start_hour "21" -s org.tizen.setting::private
382         vconftool $GOPTION set -t int db/setting/blockingmode/start_min "0" -s org.tizen.setting::private
383         vconftool $GOPTION set -t int db/setting/blockingmode/end_hour "6" -s org.tizen.setting::private
384         vconftool $GOPTION set -t int db/setting/blockingmode/end_min "0" -s org.tizen.setting::private
385         vconftool $GOPTION set -t bool db/setting/blockingmode/incomingcall "0" -s org.tizen.setting::private
386         vconftool $GOPTION set -t bool db/setting/blockingmode/notifications "0" -s org.tizen.setting::private
387         vconftool $GOPTION set -t bool db/setting/blockingmode/alarm_and_timer "0" -s org.tizen.setting::private
388         vconftool $GOPTION set -t bool db/setting/blockingmode/allday "1" -s org.tizen.setting::private
389         vconftool $GOPTION set -t int db/setting/blockingmode/allowed_contact_type "0" -s system::vconf_setting
390         vconftool $GOPTION set -t string db/setting/blockingmode/allowed_contact_list "" -s system::vconf_setting
391         vconftool $GOPTION set -t int db/setting/blockingmode/start_alarm_id "" -s org.tizen.setting::private
392         vconftool $GOPTION set -t int db/setting/blockingmode/end_alarm_id "" -s org.tizen.setting::private
393
394 #resetLanguageAndRegion
395         vconftool $GOPTION set -t int db/setting/lang "9" -s org.tizen.setting::private
396         vconftool $GOPTION set -t bool db/setting/lang_automatic "0" -s org.tizen.setting::private
397         vconftool $GOPTION set -t bool db/setting/region_automatic "1" -s org.tizen.setting::private
398         vconftool $GOPTION set -t string db/menu_widget/language "en_GB.UTF-8" -s system::vconf_inhouse
399         vconftool $GOPTION set -t string db/menu_widget/regionformat "en_GB.UTF-8" -s system::vconf_inhouse
400
401 #resetViewtype
402         #vconftool $GOPTION set -t int db/menuscreen/viewtype "0"
403         #vconftool $GOPTION set -t int db/taskswitcher/viewtype "0"
404
405 #resetTouch
406         #vconftool $GOPTION set -t int db/setting/vib_feedback "3"
407         #vconftool $GOPTION set -t bool db/setting/touch_panel_autolock "0"
408
409 #resetLicense
410         vconftool $GOPTION set -t bool db/setting/transaction_tracking "0" -s org.tizen.setting::private
411         vconftool $GOPTION set -t bool db/setting/expiry_reminder "0" -s org.tizen.setting::private
412         vconftool $GOPTION set -t int db/setting/roaming_network "0" -s org.tizen.setting::private
413
414 #resetNotification
415         vconftool $GOPTION set -t bool db/setting/ticker_noti/messages "1" -s system::vconf_setting
416         vconftool $GOPTION set -t bool db/setting/ticker_noti/email "1" -s system::vconf_inhouse
417         vconftool $GOPTION set -t bool db/setting/ticker_noti/im "1" -s system::vconf_setting
418         vconftool $GOPTION set -t bool db/setting/ticker_noti/twitter "1" -s org.tizen.setting::private
419         vconftool $GOPTION set -t bool db/setting/ticker_noti/facebook "1" -s org.tizen.setting::private
420
421                 vconftool $GOPTION set -t bool db/setting/ticker_noti/sound/email "1" -s org.tizen.setting::private
422                 vconftool $GOPTION set -t bool db/setting/ticker_noti/sound/messages "1" -s org.tizen.setting::private
423                 vconftool $GOPTION set -t bool db/setting/ticker_noti/sound/im "1" -s org.tizen.setting::private
424
425         # display content
426         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/messages "1" -s org.tizen.setting::private
427         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/email "1" -s org.tizen.setting::private
428         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/im "1" -s org.tizen.setting::private
429         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/twitter "1" -s org.tizen.setting::private
430         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/facebook "1" -s org.tizen.setting::private
431
432         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/messages "1" -s org.tizen.setting::private
433         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/email "1" -s org.tizen.setting::private
434         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/im "1" -s org.tizen.setting::private
435         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/twitter "1" -s org.tizen.setting::private
436         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/facebook "1" -s org.tizen.setting::private
437
438 #resetSecurity
439         rm -rf /opt/usr/data/setting/set_info
440         #vconftool $GOPTION set -t string db/setting/privacy_passwd ""
441
442         vconftool $GOPTION set -t bool db/setting/power_on_lock "0" -s system::vconf_setting
443         vconftool $GOPTION set -t bool db/setting/simple_password "1" -s org.tizen.setting::private
444         vconftool $GOPTION set -t int db/setting/screen_lock_type "0" -s system::vconf_inhouse
445         vconftool $GOPTION set -t string db/setting/3rd_lock_pkg_name "org.tizen.lockscreen" -s system::vconf_inhouse
446         vconftool $GOPTION set -t bool db/setting/fmm/sim_change_alert "0" -s system::vconf_inhouse
447         vconftool $GOPTION set -t string db/setting/fmm/recipients "" -s system::vconf_inhouse
448         vconftool $GOPTION set -t string db/setting/fmm/sender "" -s system::vconf_inhouse
449         vconftool $GOPTION set -t string db/setting/fmm/alert_message "" -s system::vconf_inhouse
450         vconftool $GOPTION set -t bool db/setting/fmm/remote_control "0" -s system::vconf_inhouse
451         vconftool $GOPTION set -t bool db/setting/fmm/location_consent "0" -s system::vconf_inhouse
452
453         # for MMC encryption
454         vconftool $GOPTION set -t bool db/setting/mmc_encryption/status "0" -s system::vconf_system
455         vconftool $GOPTION set -t int db/setting/mmc_encryption/option "0" -s org.tizen.setting::private
456         vconftool $GOPTION set -t bool db/setting/mmc_encryption/exclude_multimedia "0" -s org.tizen.setting::private
457
458         # NOT USED NOW.
459         #vconftool $GOPTION set -t bool db/setting/rcs "0"
460
461         vconftool $GOPTION set -t int db/setting/phone_lock_attempts_left "5" -s system::vconf_inhouse
462         vconftool $GOPTION set -t string db/setting/phone_lock_timestamp "" -s system::vconf_inhouse
463         vconftool $GOPTION set -t int db/setting/sim_lock_attempts_left "5" -s org.tizen.setting::private
464         vconftool $GOPTION set -t string db/setting/sim_lock_timestamp "" -s org.tizen.setting::private
465         vconftool $GOPTION set -t bool db/setting/fixed_dialing_mode "0" -s org.tizen.setting::private
466 #resetMemory
467         vconftool $GOPTION set -t int db/setting/default_memory/wap "0" -s system::vconf_system
468         vconftool $GOPTION set -t int db/setting/default_memory/download "0" -s system::vconf_system
469         vconftool $GOPTION set -t int db/setting/default_memory/download_nfc "0" -s system::vconf_system
470         vconftool $GOPTION set -t int db/setting/default_memory/download_contents "0" -s system::vconf_system
471         vconftool $GOPTION set -t int db/setting/default_memory/download_application "0" -s system::vconf_system
472         vconftool $GOPTION set -t int db/setting/default_memory/wifi_direct "0" -s system::vconf_system
473         vconftool $GOPTION set -t int db/setting/default_memory/install_applications "0" -s system::vconf_system
474
475         vconftool $GOPTION set -t int db/setting/default_memory/bluetooth "0" -s system::vconf_system
476         vconftool $GOPTION set -t int db/setting/default_memory/camera "0" -s system::vconf_system
477         vconftool $GOPTION set -t int db/setting/default_memory/voice_recorder "0" -s system::vconf_system
478         vconftool $GOPTION set -t int db/setting/default_memory/fm_radio "0" -s system::vconf_system
479         vconftool $GOPTION set -t int db/setting/default_memory/all_share "0" -s system::vconf_system
480         vconftool $GOPTION set -t int db/setting/default_memory/adobe_air "0" -s system::vconf_system
481         vconftool $GOPTION set -t int db/setting/default_memory/dvb_h "0" -s system::vconf_system
482
483         # format - system server
484         #vconftool $GOPTION -i set -t int memory/mmc/format "0"
485
486 #resetAbout
487         vconftool $GOPTION set -t string db/setting/device_name "Gear 2" -s system::vconf_network
488         vconftool $GOPTION set -t string db/setting/selected_num "" -s org.tizen.setting::private
489 #resetMenuWidgets
490         vconftool $GOPTION -i set -t int memory/setting/font_changed "0" -s org.tizen.setting::private
491         #vconftool $GOPTION -i set -t int memory/mobile_hotspot/skin_changed "0"
492
493 #resetDevoptions
494         vconftool $GOPTION -i set -t int db/setting/devoption/bgprocess "0" -s system::vconf_setting
495
496 #resetDatausage
497         vconftool $GOPTION set -t bool db/setting/set_data_usage_limit "0" -s org.tizen.setting::private
498         vconftool $GOPTION set -t int db/setting/data_limit "-1" -s org.tizen.setting::private
499         vconftool $GOPTION set -t int db/setting/data_usage_cycle "0" -s org.tizen.setting::private
500         vconftool $GOPTION set -t int db/setting/data_each_month "1" -s org.tizen.setting::private
501         vconftool $GOPTION set -t int db/setting/data_each_month_app "1" -s org.tizen.setting::private
502         vconftool $GOPTION set -t bool db/setting/data_usage_roaming_status "0" -s org.tizen.setting::private
503         vconftool $GOPTION set -t int db/setting/data_limit_roaming "-1" -s org.tizen.setting::private
504         vconftool $GOPTION set -t bool db/setting/set_data_usage_limit_roaming "0" -s org.tizen.setting::private
505
506 #resetDisplay
507         vconftool $GOPTION set -t string db/setting/screenmode/selected_name "Dynamic" -f -s org.tizen.setting::private
508
509 #resetMostRecentlySetting
510         vconftool $GOPTION set -t string db/setting/most_recently_setting "" -s org.tizen.setting::private
511
512 #psmode(power saving mode)
513         vconftool $GOPTION set -t int db/setting/psmode "0" -s system::vconf_setting
514
515 #resetMyplace
516         vconftool $GOPTION set -t string db/setting/myplace_home "" -s system::vconf_inhouse
517         vconftool $GOPTION set -t string db/setting/myplace_office "" -s system::vconf_inhouse
518
519 # personal page(not include on vconf internal yet)
520         vconftool $GOPTION set -t bool memory/setting/personal "0" -i -s system::vconf_setting
521         vconftool $GOPTION set -t string db/setting/personal_key "" -s system::vconf_setting
522
523 # homescreen layout type
524         vconftool $GOPTION set -t int db/setting/homescreen_type "1" -s system::vconf_inhouse
525
526 # privacy setting
527         vconftool $GOPTION set -t int db/setting/lock_type "0" -s system::vconf_inhouse
528         vconftool $GOPTION set -t bool db/setting/see_pattern "1" -s system::vconf_inhouse
529
530 # display screen rotation
531         vconftool $GOPTION set -t int db/setting/screen_rotation "0" -s system::vconf_inhouse
532
533 # display home screen bg set
534         vconftool $GOPTION set -t int db/setting/homescreen_bg "0" -s system::vconf_inhouse
535
536 # support emergency mode
537         vconftool $GOPTION set -t bool db/setting/support_emergency "1" -s system::vconf_setting
538         vconftool $GOPTION set -t bool db/setting/emergency_status "0" -s system::vconf_setting
539
540 # volume toast show
541 #       vconftool $GOPTION set -t int memory/setting/volume_ring_toast_show "0" -i -f -s org.tizen.setting::private
542 #       vconftool $GOPTION set -t int memory/setting/volume_noti_toast_show "0" -i -f -s org.tizen.setting::private
543
544 # safety, emergency mode
545         vconftool $GOPTION set -t int db/setting/emergency_wakeup_gesture "0" -s system::vconf_setting
546         vconftool $GOPTION set -t int db/setting/emergency_brightness "1" -s system::vconf_setting
547         vconftool $GOPTION set -t int db/setting/emergency_lcd_timeout "10" -s system::vconf_setting
548         vconftool $GOPTION set -t string db/setting/emergency_ringtone "/opt/share/settings/Emergency/Low_power_ringtone.ogg" -s system::vconf_setting
549
550 # power saver wearable
551         vconftool $GOPTION set -t int db/setting/pws_wakeup_gesture "0" -s system::vconf_setting
552         vconftool $GOPTION set -t int db/setting/pws_brightness "1" -s system::vconf_setting
553         vconftool $GOPTION set -t int db/setting/pws_lcd_timeout "10" -s system::vconf_setting
554         vconftool $GOPTION set -t string db/setting/pws_ringtone "/opt/share/settings/Emergency/Low_power_ringtone.ogg" -s system::vconf_setting
555
556 if [ -d /opt/share/settings ]
557 then
558         rm -rf /opt/share/settings
559 fi
560
561 ln -s /opt/usr/share/settings /opt/share/settings
562
563 # shared dir
564 mkdir -p /usr/apps/org.tizen.clocksetting/shared
565 mkdir -p /usr/apps/org.tizen.clocksetting/shared/res
566
567 mkdir -p /opt/usr/data/setting
568
569 %files
570 %manifest %{name}.manifest
571 /etc/smack/accesses2.d/org.tizen.clocksetting.rule
572 %defattr(-,root,root,-)
573 %attr(-,inhouse,inhouse)
574 %dir %{PREFIX}/data
575 /usr/share/packages/*
576 /usr/share/icons/default/small/*
577 /usr/apps/org.tizen.clocksetting/*
578 /opt/usr/share/settings/*
579 /usr/share/Safety.zip
580 /opt/usr/data/setting/*