tizen 2.3.1 release
[apps/home/b2-clocksetting.git] / packaging / org.tizen.setting.spec
1 %define PREFIX /usr/apps/org.tizen.clocksetting
2 Name: org.tizen.clocksetting
3 Version:    0.0.2
4 Release:    1
5 Summary: Tizen W ClockSetting application
6 URL: http://slp-source.sec.samsung.net
7 Source: %{name}-%{version}.tar.gz
8 License: Flora-1.1
9 Group: misc
10
11 %if "%{?tizen_profile_name}" == "mobile"
12 ExcludeArch: %{arm} %ix86 x86_64
13 %endif
14
15 BuildRequires: cmake
16 BuildRequires: pkgconfig(edje)
17 BuildRequires: pkgconfig(embryo)
18 BuildRequires: pkgconfig(ecore)
19 BuildRequires: pkgconfig(elementary)
20 BuildRequires: pkgconfig(utilX)
21 BuildRequires: pkgconfig(appcore-efl)
22 BuildRequires: pkgconfig(appcore-common)
23 BuildRequires: pkgconfig(dlog)
24 BuildRequires: pkgconfig(glib-2.0)
25 BuildRequires: pkgconfig(capi-appfw-application)
26 BuildRequires: pkgconfig(capi-appfw-app-manager)
27 BuildRequires: pkgconfig(feedback)
28 BuildRequires: pkgconfig(vconf)
29 BuildRequires: pkgconfig(json-glib-1.0)
30 BuildRequires: pkgconfig(deviced)
31 BuildRequires: pkgconfig(pkgmgr)
32 BuildRequires: pkgconfig(pkgmgr-info)
33 BuildRequires: efl-assist-devel
34 BuildRequires: gettext-tools
35 BuildRequires: edje-bin, embryo-bin
36 BuildRequires: elementary-devel
37 BuildRequires: efl-assist-devel
38 BuildRequires: pkgconfig(bluetooth-api)
39 BuildRequires: pkgconfig(capi-network-bluetooth)
40 BuildRequires: pkgconfig(capi-base-common)
41 BuildRequires: pkgconfig(capi-system-device)
42 BuildRequires: pkgconfig(capi-media-sound-manager)
43 BuildRequires: pkgconfig(capi-media-player)
44 BuildRequires: pkgconfig(capi-content-media-content)
45 BuildRequires: pkgconfig(capi-system-info)
46 BuildRequires: pkgconfig(capi-system-system-settings)
47 BuildRequires: pkgconfig(mm-player)
48 BuildRequires: pkgconfig(mm-sound)
49 BuildRequires: pkgconfig(libxml-2.0)
50 BuildRequires: pkgconfig(capi-media-wav-player)
51 #BuildRequires: pkgconfig(capability-manager)
52 BuildRequires: model-build-features
53 BuildRequires: pkgconfig(ail)
54 BuildRequires: pkgconfig(aul)
55
56 BuildRequires: pkgconfig(efl-extension)
57
58 %description
59 W ClockSetting application
60
61 %prep
62 %setup -q
63
64 %build
65
66 %if 0%{?tizen_build_binary_release_type_eng}
67 export CFLAGS+=" -DTIZEN_ENGINEER_MODE"
68 export CXXFLAGS+=" -DTIZEN_ENGINEER_MODE"
69 export FFLAGS+=" -DTIZEN_ENGINEER_MODE"
70 %endif
71 %if 0%{?sec_build_binary_debug_enable}
72 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
73 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
74 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
75 %endif
76
77 %if "%{?model_build_feature_formfactor}" == "circle"
78 export CFLAGS+="$CFLAGS -D_CIRCLE"
79 %endif
80
81 %if %{?model_build_feature_location_position}
82 export CFLAGS+="$CFLAGS -D_LOCATION_MENU_ON"
83 %endif
84
85
86 LDFLAGS+="-Wl,--rpath=%{PREFIX}/lib -Wl,--as-needed -Wl,--hash-style=both"; export LDFLAGS
87 cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX} \
88 %if 0%{?sec_build_binary_sdk}
89         -DFEATURE_SETTING_SDK=YES \
90 %endif
91 %ifarch %{ix86}
92         -DFEATURE_SETTING_EMUL=YES \
93 %endif
94 #%if "%{?sec_build_project_name}" == "rinato_eur_open"
95 #       -DFEATURE_SETTING_TIZENW2=YES \
96 #%endif
97
98 make %{?jobs:-j%jobs}
99
100
101 %install
102 rm -rf %{buildroot}
103
104 %make_install
105 mkdir -p %{buildroot}/opt/usr/apps/org.tizen.clocksetting
106 mkdir -p %{buildroot}/opt/usr/apps/org.tizen.clocksetting/data/images
107
108 %clean
109
110 %post
111
112 # Set vconf values with -g/-u options
113 GOPTION="-g 6514"
114
115 # location
116         #vconftool $GOPTION set -t int db/location/setting/GpsEnabled "0" -s system::vconf_inhouse
117
118 #AmbientMode
119         vconftool $GOPTION set -t bool db/setting/ambient_mode "0" -s system::vconf_inhouse
120 #resetMenuscreen
121         #vconftool $GOPTION set -t string db/setting/menuscreen/selected "org.tizen.cluster-home"
122 %ifarch %{arm}
123         vconftool $GOPTION set -t string db/setting/menuscreen/package_name "org.tizen.cluster-home" -s system::vconf_inhouse
124         vconftool $GOPTION set -t string db/setting/homescreen/package_name "org.tizen.cluster-home" -s system::vconf_setting
125 %else
126         vconftool $GOPTION set -t string db/setting/menuscreen/package_name "org.tizen.menu-screen" -s system::vconf_inhouse
127         vconftool $GOPTION set -t string db/setting/homescreen/package_name "org.tizen.menu-screen" -s system::vconf_setting
128 %endif
129
130 #resetFlightmode
131 #       vconftool $GOPTION set -t bool db/telephony/flight_mode "0" -f -s system::vconf_network
132
133 #resetHomeBG
134         vconftool $GOPTION set -t int db/setting/home_bg_color_type "0" -s system::vconf_inhouse
135
136         vconftool $GOPTION set -t int db/setting/idle_clock_type "9" -s system::vconf_inhouse
137         vconftool $GOPTION set -t bool db/setting/hourly_alert "0" -s system::vconf_inhouse
138         vconftool $GOPTION set -t bool db/setting/prefer_arm_left "1" -s system::vconf_inhouse
139
140 #resetMotions
141         vconftool $GOPTION set -t int db/setting/motion_wake_up_guesture "2" -s system::vconf_inhouse
142         vconftool $GOPTION set -t bool db/setting/motion_smart_relay "0" -s system::vconf_inhouse
143
144
145 #resetNetwork
146         vconftool $GOPTION set -t int db/setting/select_network "0" -s org.tizen.setting::private
147         vconftool $GOPTION set -t int db/setting/select_network_act "0" -s org.tizen.setting::private
148         vconftool $GOPTION set -t int db/setting/network_mode "0" -s org.tizen.setting::private
149         vconftool $GOPTION set -t bool db/setting/3gEnabled "1" -s system::vconf_system
150         vconftool $GOPTION set -t bool db/setting/data_roaming "0" -s system::vconf_system
151         vconftool $GOPTION set -t bool memory/setting/network_mode_changed "0" -i -s system::vconf_system
152
153 #resetUsbConnectivity
154         vconftool $GOPTION set -t int memory/setting/usb_mode "-1" -i -s system::vconf_system
155         vconftool $GOPTION set -t int memory/setting/usb_sel_mode "0" -i -s system::vconf_system
156         vconftool $GOPTION set -t int memory/setting/usb_in_mode_change "0" -i -s org.tizen.setting::private
157         vconftool $GOPTION set -t bool db/setting/debug_mode "0" -s system::vconf_system
158         vconftool $GOPTION set -t int db/setting/default_rendering_engine "1" -i -s system::vconf_system
159
160 #resetSound
161 %ifarch %{arm}
162         DEFAULT_CALL_TONE="/opt/share/settings/Ringtones/Twinkle.ogg"
163         #DEFAULT_CALL_TONE="/opt/share/settings/Ringtones/Ringtone1.ogg"
164 %else
165         DEFAULT_CALL_TONE="/opt/share/settings/Ringtones/Ringtone.ogg"
166         #DEFAULT_CALL_TONE="/opt/share/settings/Ringtones/Ringtone1.ogg"
167 %endif
168
169 %ifarch %{arm}
170         DEFAULT_NOTI_TONE="/opt/share/settings/Alerts/Flicker.ogg"
171         #DEFAULT_NOTI_TONE="/opt/share/settings/Alerts/Notification1.ogg"
172 %else
173         DEFAULT_NOTI_TONE="/opt/share/settings/Alerts/Notification.ogg"
174         #DEFAULT_NOTI_TONE="/opt/share/settings/Alerts/Notification1.ogg"
175 %endif
176
177         vconftool $GOPTION set -t bool db/setting/sound/sound_on "0" -s system::vconf_inhouse
178         vconftool $GOPTION set -t bool db/setting/sound/vibration_on "1" -s system::vconf_inhouse
179
180         vconftool $GOPTION set -t bool db/setting/sound/vibrate_when_ringing "1" -s system::vconf_setting
181         vconftool $GOPTION set -t bool db/setting/sound/vibrate_when_notification "1" -s system::vconf_setting
182
183         vconftool $GOPTION set -t int db/setting/sound/call/ringtone_sound_volume "11" -s system::vconf_setting
184         vconftool $GOPTION set -t int db/setting/sound/call/rmd_ringtone_volume "11" -s system::vconf_setting
185         vconftool $GOPTION set -t int db/setting/sound/noti/sound_volume "11" -s system::vconf_inhouse
186         vconftool $GOPTION set -t int db/setting/sound/media/sound_volume "11" -s org.tizen.setting::private
187         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/sound_volume "9" -s org.tizen.setting::private
188
189         vconftool $GOPTION set -t int db/setting/sound/noti/vibration_level "3" -s system::vconf_inhouse
190         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/vibration_level "3" -s system::vconf_inhouse
191         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/vibration_level_bak "3" -s org.tizen.setting::private
192
193         vconftool $GOPTION set -t string db/setting/sound/call/ringtone_path "${DEFAULT_CALL_TONE}" -f -s system::vconf_inhouse
194         vconftool $GOPTION set -t string db/setting/sound/call/ringtone_default_path "${DEFAULT_CALL_TONE}" -f -s system::vconf_setting
195         vconftool $GOPTION set -t int db/setting/sound/call/vibration_type "2" -s system::vconf_setting
196         vconftool $GOPTION set -t string db/setting/sound/call/vibration_pattern_path "/opt/share/settings/Vibrations/haptic/default/Notification_Call.ivt" -f -s system::vconf_setting
197         vconftool $GOPTION set -t string db/setting/sound/noti/msg_ringtone_path        "${DEFAULT_NOTI_TONE}" -f -s system::vconf_inhouse
198         vconftool $GOPTION set -t string db/setting/sound/noti/ringtone_default_path    "${DEFAULT_NOTI_TONE}" -f -s system::vconf_inhouse
199         vconftool $GOPTION set -t int db/setting/sound/noti/msg_alert_rep_type          "0" -s system::vconf_inhouse
200
201         vconftool $GOPTION set -t string db/setting/sound/noti/email_ringtone_path      "${DEFAULT_NOTI_TONE}" -f -s system::vconf_inhouse
202         vconftool $GOPTION set -t int db/setting/sound/noti/email_alert_rep_type                "0" -s system::vconf_inhouse
203
204         vconftool $GOPTION set -t bool db/setting/sound/button_sounds "0" -s system::vconf_inhouse
205         vconftool $GOPTION set -t bool db/setting/sound/touch_sounds "0" -s system::vconf_inhouse
206         vconftool $GOPTION set -t bool db/setting/sound/sound_lock "0" -s system::vconf_inhouse
207         vconftool $GOPTION set -t bool db/setting/sound/haptic_feedback_on "1" -s system::vconf_inhouse
208
209         vconftool $GOPTION set -t bool db/setting/sound/sound_on_bak "1" -s org.tizen.setting::private
210         vconftool $GOPTION set -t bool db/setting/sound/touch_sounds_bak "1" -s org.tizen.setting::private
211         vconftool $GOPTION set -t bool db/setting/sound/sound_lock_bak "1" -s org.tizen.setting::private
212 #resetWallpaper
213         vconftool $GOPTION set -t string db/menu_widget/bgset "" -f -s system::vconf_inhouse
214         vconftool $GOPTION set -t string db/idle_lock/bgset "/opt/usr/share/settings/Wallpapers/Lock_default.png" -f -s system::vconf_inhouse
215
216 #resetTilt
217         vconftool $GOPTION set -t bool db/setting/use_tilt "0" -s system::vconf_inhouse
218         vconftool $GOPTION set -t int db/setting/tilt_sensitivity "3" -s org.tizen.setting::private
219         vconftool $GOPTION set -t bool db/setting/use_tilt_scroll "1" -s org.tizen.setting::private
220         vconftool $GOPTION set -t int db/setting/tilt_scroll_sensitivity "3" -s org.tizen.setting::private
221
222 #resetPanning
223         vconftool $GOPTION set -t bool db/setting/use_panning "0" -s system::vconf_inhouse
224         vconftool $GOPTION set -t int db/setting/panning_sensitivity "3" -s org.tizen.setting::private
225         vconftool $GOPTION set -t bool db/setting/use_panning_browser "0" -s system::vconf_inhouse
226         vconftool $GOPTION set -t int db/setting/panning_browser_sensitivity "3" -s org.tizen.setting::private
227
228 #resetDoubleTap
229         vconftool $GOPTION set -t bool db/setting/use_double_tap "0" -s system::vconf_setting
230
231 #resetShake
232         vconftool $GOPTION set -t bool db/setting/use_shake "0" -s system::vconf_inhouse
233
234 #resetPickup
235         vconftool $GOPTION set -t bool db/setting/use_pick_up "1" -s system::vconf_setting
236         vconftool $GOPTION set -t bool db/setting/use_pick_up_call "0" -s system::vconf_inhouse
237
238 #resetTurnOver
239         vconftool $GOPTION set -t bool db/setting/use_turn_over "0" -s system::vconf_setting
240
241 #resetMotions
242         vconftool $GOPTION set -t bool db/setting/motion_active "0" -s system::vconf_system
243         vconftool $GOPTION set -t bool db/setting/motion/palm_swipe_capture "1" -s org.tizen.setting::private
244         vconftool $GOPTION set -t bool db/setting/motion/palm_touch_mute "1" -s org.tizen.setting::private
245         vconftool $GOPTION set -t bool db/setting/motion/tap_twist "1" -s org.tizen.setting::private
246
247 #resetDisplay
248         #backlight
249 %ifarch %{arm}
250         vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "10" -s system::vconf_system
251 %else
252         vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "10" -s system::vconf_system
253 %endif
254         vconftool $GOPTION set -t int db/setting/lcd_timeout_normal_backup "10" -s org.tizen.setting::private
255         vconftool $GOPTION set -t int db/setting/automatic_brightness_level "60" -f -s org.tizen.setting::private
256         #brightness
257         vconftool $GOPTION set -t int db/setting/Brightness "80" -s system::vconf_system
258         vconftool $GOPTION set -t int db/setting/brightness_automatic "0" -s system::vconf_inhouse
259         vconftool $GOPTION set -t bool db/setting/auto_display_adjustment "1" -s system::vconf_inhouse
260
261         #battery
262         vconftool $GOPTION set -t bool db/setting/battery_percentage "1" -s system::vconf_inhouse
263         #launch
264         #vconftool $GOPTION set -t string db/menu_widget/launch_effect "0"
265
266         #smart screen
267         vconftool $GOPTION set -t int db/pm/smartstay_status "0" -f -s org.tizen.setting::private
268         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_rotation "0" -s system::vconf_inhouse
269         vconftool $GOPTION set -t bool db/setting/auto_adjust_screen_tone "1" -s system::vconf_inhouse
270         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_stay_r "1" -s org.tizen.setting::private
271         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_rotation_r "1" -s org.tizen.setting::private
272         vconftool $GOPTION set -t int db/setting/display/touchkey_light_duration "90" -s system::vconf_inhouse
273         vconftool $GOPTION set -t int db/setting/display/screen_capture_destination "0" -s system::vconf_inhouse
274         vconftool $GOPTION set -t bool db/setting/display/edit_after_screen_capture "0" -s system::vconf_inhouse
275
276         #LED indicator
277         vconftool $GOPTION set -t bool db/setting/led_indicator/charging "1" -s system::vconf_setting
278         vconftool $GOPTION set -t bool db/setting/led_indicator/low_batt "0" -s system::vconf_setting
279         vconftool $GOPTION set -t bool db/setting/led_indicator/notifications "1" -s system::vconf_setting
280         vconftool $GOPTION set -t bool db/setting/led_indicator/voice_rec "1" -s system::vconf_setting
281
282         #Accessory SViewer
283         vconftool $GOPTION set -t bool db/setting/accessories/atuomatic_unlock "1" -s system::vconf_setting
284         vconftool $GOPTION set -t bool db/setting/accessories/dock_sound "0" -s system::vconf_setting
285         vconftool $GOPTION set -t bool db/setting/accessories/audio_output_mode "0" -s system::vconf_setting
286         vconftool $GOPTION set -t bool db/setting/accessories/audio_output_mode_reminder "0" -f -s org.tizen.setting::private
287         vconftool $GOPTION set -t bool db/setting/accessories/desk_home_screen_display "1" -s system::vconf_setting
288         vconftool $GOPTION set -t bool db/setting/accessories/hdmi_application "0" -s system::vconf_setting
289         vconftool $GOPTION set -t int db/setting/accessories/audio_output "0" -s system::vconf_setting
290         vconftool $GOPTION set -t bool db/setting/accessories/audio_applications "0" -s system::vconf_setting
291
292
293 #resetPowersaving
294         vconftool $GOPTION set -t bool db/setting/pwrsv/system_mode/status "0" -s org.tizen.setting::private
295
296         # remove this - and use 'preference'
297         vconftool $GOPTION set -t bool db/setting/pwrsv/system_mode/reminder "1" -s org.tizen.setting::private
298         #---------------------------------------------------------------------------
299
300         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/status "0" -s system::vconf_inhouse
301
302         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/at "30" -s org.tizen.setting::private
303         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/wifi "1" -s org.tizen.setting::private
304         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/bt "0" -s org.tizen.setting::private
305         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/gps "1" -s org.tizen.setting::private
306         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/data_sync "1" -s org.tizen.setting::private
307         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/hotspot "1" -s org.tizen.setting::private
308
309         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/brt/status  "1" -s org.tizen.setting::private
310         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/brt/auto/status "0" -s org.tizen.setting::private
311         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/brt/value "10" -s org.tizen.setting::private
312         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/backlight/time "15" -s org.tizen.setting::private
313
314         #v0.4
315         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/cpu "0" -s system::vconf_inhouse
316         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/display "0" -s system::vconf_inhouse
317         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/bg_color "0" -s system::vconf_inhouse
318         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/screen_vib "0" -s system::vconf_inhouse
319
320 #resetFont
321         vconftool $GOPTION set -t int db/setting/font_size "1" -s org.tizen.setting::private
322         vconftool $GOPTION set -t int db/setting/font_type "0" -s org.tizen.setting::private
323         vconftool $GOPTION set -t string memory/setting/tmp_font_name ""  -i -s org.tizen.setting::private
324
325 #resetRotationLock
326
327         # to be removed
328         vconftool $GOPTION set -t bool db/setting/rotate_lock "1"  -s org.tizen.setting::private
329
330         vconftool $GOPTION set -t bool db/setting/auto_rotate_screen "1" -s system::vconf_inhouse
331         vconftool $GOPTION set -t bool memory/setting/rotate_hold "0" -i -f -s org.tizen.setting::private
332
333 #resetTimeAndData
334 %ifarch %{arm}
335         vconftool $GOPTION set -t bool db/setting/automatic_time_update "1" -s system::vconf_inhouse
336 %else
337         vconftool $GOPTION set -t bool db/setting/automatic_time_update "0" -s system::vconf_inhouse
338 %endif
339
340         vconftool $GOPTION set -t int db/menu_widget/regionformat_time1224 "1" -s system::vconf_setting
341         vconftool $GOPTION set -t int db/setting/date_format "0" -s system::vconf_setting
342         vconftool $GOPTION set -t int db/setting/weekofday_format  "0" -s system::vconf_inhouse
343
344         vconftool $GOPTION set -t string db/setting/timezone "+9:00" -s system::vconf_setting
345         # to be removed
346         vconftool $GOPTION set -t string db/setting/cityname_id "IDS_WCL_BODY_CITYNAME_SEOUL" -s system::vconf_setting
347
348         vconftool $GOPTION set -t string db/setting/timezone_id "Asia/Seoul" -s system::vconf_inhouse
349
350         rm -f /opt/etc/localtime
351         ln -s /usr/share/zoneinfo/Asia/Seoul /opt/etc/localtime
352         rm -f /etc/localtime
353         ln -s /opt/etc/localtime /etc/localtime
354
355 #resetAccessibility
356         vconftool $GOPTION set -t bool db/setting/accessibility/high_contrast "0" -s system::vconf_system
357         vconftool $GOPTION set -t bool db/setting/accessibility/screen_zoom "0" -s system::vconf_inhouse
358         vconftool $GOPTION set -t int db/setting/accessibility/font_size "1" -s system::vconf_inhouse   #vconftool $GOPTION set -t int db/setting/accessibility/font_style "0"
359         vconftool $GOPTION set -t string db/setting/accessibility/font_name "HelveticaNeue" -s system::vconf_misc
360         vconftool $GOPTION set -t bool db/setting/accessibility/tts "0" -s system::vconf_system
361         vconftool $GOPTION set -t int db/setting/accessibility/speech_rate "2" -s system::vconf_inhouse
362
363         vconftool $GOPTION set -t bool memory/setting/accessibility/torch_light "0" -i -s system::vconf_system
364         vconftool $GOPTION set -t bool db/setting/accessibility/assistive_light_reminder "1" -s system::vconf_inhouse
365         vconftool $GOPTION set -t bool db/setting/accessibility/mono_audio "0" -s system::vconf_setting
366         vconftool $GOPTION set -t int db/setting/accessibility/power_key_hold "1" -s system::vconf_inhouse
367         vconftool $GOPTION set -t bool db/setting/accessibility/led_notify "0" -s system::vconf_setting
368         vconftool $GOPTION set -t string db/setting/accessibility/led_playing_path "/usr/share/feedback/led/default/Ticktock.led" -s org.tizen.setting::private
369         vconftool $GOPTION set -t bool db/setting/accessibility/turn_off_all_sounds "0" -s system::vconf_setting
370
371         vconftool $GOPTION set -t bool db/setting/accessibility/speak_passwd  "0" -s org.tizen.setting::private
372         vconftool $GOPTION set -t int db/setting/accessibility/lock_time "5" -s system::vconf_setting
373         vconftool $GOPTION set -t string db/setting/accessibility/taphold_delay "IDS_COM_POP_SHORT" -s org.tizen.setting::private
374
375 # duplicated key creation (it's in Call setting)
376 #       vconftool $GOPTION set -t bool db/ciss/call_answering_key "0"
377 #       vconftool $GOPTION set -t bool db/ciss/call_power_key_ends_call "0"
378 #       vconftool $GOPTION set -t int db/ciss/answering_mode "0"
379 #       vconftool $GOPTION set -t int db/ciss/answering_mode_time "3"
380
381         vconftool $GOPTION set -t bool db/setting/accessibility/accept_call "0" -s org.tizen.setting::private
382         vconftool $GOPTION set -t bool db/setting/accessibility/enable_auto_answer "0" -s org.tizen.setting::private
383         vconftool $GOPTION set -t int db/setting/accessibility/auto_answer "1" -s org.tizen.setting::private
384         vconftool $GOPTION set -t bool db/setting/accessibility/powerkey_end_calls "0" -s org.tizen.setting::private
385
386         vconftool $GOPTION set -t int db/setting/accessibility/sound_balance "50" -s org.tizen.setting::private
387 # Colorblind
388         vconftool $GOPTION set -t bool db/setting/colorblind/status "0" -s org.tizen.setting::private
389         vconftool $GOPTION set -t string db/setting/colorblind/chip_array "" -s org.tizen.setting::private
390         vconftool $GOPTION set -t string db/setting/colorblind/rgbcmy "" -s org.tizen.setting::private
391         vconftool $GOPTION set -t double db/setting/colorblind/user_adjustment "0.0" -s org.tizen.setting::private
392 # Driving Mode
393         vconftool $GOPTION set -t bool db/setting/drivingmode/drivingmode "0" -s system::vconf_inhouse
394         vconftool $GOPTION set -t bool db/setting/drivingmode/incomingcall "0" -s system::vconf_setting
395         vconftool $GOPTION set -t bool db/setting/drivingmode/message "0" -s system::vconf_setting
396         vconftool $GOPTION set -t bool db/setting/drivingmode/newemails "0" -s system::vconf_setting
397         vconftool $GOPTION set -t bool db/setting/drivingmode/newvoicemails "0" -s system::vconf_setting
398         vconftool $GOPTION set -t bool db/setting/drivingmode/alarm "0" -s system::vconf_setting
399         vconftool $GOPTION set -t bool db/setting/drivingmode/schedule "0" -s system::vconf_setting
400         vconftool $GOPTION set -t bool db/setting/drivingmode/unlockscreen "0" -s system::vconf_setting
401
402 # Easymode
403         vconftool $GOPTION set -t bool db/setting/homescreen/easymode "0" -s system::vconf_inhouse
404
405 # Blocking Mode
406         vconftool $GOPTION set -t bool db/setting/blockingmode/blockingmode "0" -s system::vconf_setting
407         vconftool $GOPTION set -t bool db/setting/blockingmode/inter/incomingcall "0" -s system::vconf_setting
408         vconftool $GOPTION set -t bool db/setting/blockingmode/inter/notifications "0" -s system::vconf_setting
409         vconftool $GOPTION set -t bool db/setting/blockingmode/inter/alarm_and_timer "0" -s system::vconf_setting
410
411         vconftool $GOPTION set -t int db/setting/blockingmode/start_hour "21" -s org.tizen.setting::private
412         vconftool $GOPTION set -t int db/setting/blockingmode/start_min "0" -s org.tizen.setting::private
413         vconftool $GOPTION set -t int db/setting/blockingmode/end_hour "6" -s org.tizen.setting::private
414         vconftool $GOPTION set -t int db/setting/blockingmode/end_min "0" -s org.tizen.setting::private
415         vconftool $GOPTION set -t bool db/setting/blockingmode/incomingcall "0" -s org.tizen.setting::private
416         vconftool $GOPTION set -t bool db/setting/blockingmode/notifications "0" -s org.tizen.setting::private
417         vconftool $GOPTION set -t bool db/setting/blockingmode/alarm_and_timer "0" -s org.tizen.setting::private
418         vconftool $GOPTION set -t bool db/setting/blockingmode/allday "1" -s org.tizen.setting::private
419         vconftool $GOPTION set -t int db/setting/blockingmode/allowed_contact_type "0" -s system::vconf_setting
420         vconftool $GOPTION set -t string db/setting/blockingmode/allowed_contact_list "" -s system::vconf_setting
421         vconftool $GOPTION set -t int db/setting/blockingmode/start_alarm_id "" -s org.tizen.setting::private
422         vconftool $GOPTION set -t int db/setting/blockingmode/end_alarm_id "" -s org.tizen.setting::private
423
424 #resetLanguageAndRegion
425         vconftool $GOPTION set -t int db/setting/lang "9" -s org.tizen.setting::private
426         vconftool $GOPTION set -t bool db/setting/lang_automatic "0" -s org.tizen.setting::private
427         vconftool $GOPTION set -t bool db/setting/region_automatic "1" -s org.tizen.setting::private
428         vconftool $GOPTION set -t string db/menu_widget/language "en_GB.UTF-8" -s system::vconf_inhouse
429         vconftool $GOPTION set -t string db/menu_widget/regionformat "en_GB.UTF-8" -s system::vconf_inhouse
430
431 #resetViewtype
432         #vconftool $GOPTION set -t int db/menuscreen/viewtype "0"
433         #vconftool $GOPTION set -t int db/taskswitcher/viewtype "0"
434
435 #resetTouch
436         #vconftool $GOPTION set -t int db/setting/vib_feedback "3"
437         #vconftool $GOPTION set -t bool db/setting/touch_panel_autolock "0"
438
439 #resetLicense
440         vconftool $GOPTION set -t bool db/setting/transaction_tracking "0" -s org.tizen.setting::private
441         vconftool $GOPTION set -t bool db/setting/expiry_reminder "0" -s org.tizen.setting::private
442         vconftool $GOPTION set -t int db/setting/roaming_network "0" -s org.tizen.setting::private
443
444 #resetNotification
445         vconftool $GOPTION set -t bool db/setting/ticker_noti/messages "1" -s system::vconf_setting
446         vconftool $GOPTION set -t bool db/setting/ticker_noti/email "1" -s system::vconf_inhouse
447         vconftool $GOPTION set -t bool db/setting/ticker_noti/im "1" -s system::vconf_setting
448         vconftool $GOPTION set -t bool db/setting/ticker_noti/twitter "1" -s org.tizen.setting::private
449         vconftool $GOPTION set -t bool db/setting/ticker_noti/facebook "1" -s org.tizen.setting::private
450
451                 vconftool $GOPTION set -t bool db/setting/ticker_noti/sound/email "1" -s org.tizen.setting::private
452                 vconftool $GOPTION set -t bool db/setting/ticker_noti/sound/messages "1" -s org.tizen.setting::private
453                 vconftool $GOPTION set -t bool db/setting/ticker_noti/sound/im "1" -s org.tizen.setting::private
454
455         # display content
456         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/messages "1" -s org.tizen.setting::private
457         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/email "1" -s org.tizen.setting::private
458         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/im "1" -s org.tizen.setting::private
459         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/twitter "1" -s org.tizen.setting::private
460         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/facebook "1" -s org.tizen.setting::private
461
462         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/messages "1" -s org.tizen.setting::private
463         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/email "1" -s org.tizen.setting::private
464         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/im "1" -s org.tizen.setting::private
465         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/twitter "1" -s org.tizen.setting::private
466         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/facebook "1" -s org.tizen.setting::private
467
468 #resetSecurity
469         rm -rf /opt/usr/data/setting/set_info
470         #vconftool $GOPTION set -t string db/setting/privacy_passwd ""
471
472         vconftool $GOPTION set -t bool db/setting/power_on_lock "0" -s system::vconf_setting
473         vconftool $GOPTION set -t bool db/setting/simple_password "1" -s org.tizen.setting::private
474         vconftool $GOPTION set -t int db/setting/screen_lock_type "0" -s system::vconf_inhouse
475         vconftool $GOPTION set -t string db/setting/3rd_lock_pkg_name "org.tizen.lockscreen" -s system::vconf_inhouse
476         vconftool $GOPTION set -t bool db/setting/fmm/sim_change_alert "0" -s system::vconf_inhouse
477         vconftool $GOPTION set -t string db/setting/fmm/recipients "" -s system::vconf_inhouse
478         vconftool $GOPTION set -t string db/setting/fmm/sender "" -s system::vconf_inhouse
479         vconftool $GOPTION set -t string db/setting/fmm/alert_message "" -s system::vconf_inhouse
480         vconftool $GOPTION set -t bool db/setting/fmm/remote_control "0" -s system::vconf_inhouse
481         vconftool $GOPTION set -t bool db/setting/fmm/location_consent "0" -s system::vconf_inhouse
482
483         # for MMC encryption
484         vconftool $GOPTION set -t bool db/setting/mmc_encryption/status "0" -s system::vconf_system
485         vconftool $GOPTION set -t int db/setting/mmc_encryption/option "0" -s org.tizen.setting::private
486         vconftool $GOPTION set -t bool db/setting/mmc_encryption/exclude_multimedia "0" -s org.tizen.setting::private
487
488         # NOT USED NOW.
489         #vconftool $GOPTION set -t bool db/setting/rcs "0"
490
491         vconftool $GOPTION set -t int db/setting/phone_lock_attempts_left "5" -s system::vconf_inhouse
492         vconftool $GOPTION set -t string db/setting/phone_lock_timestamp "" -s system::vconf_inhouse
493         vconftool $GOPTION set -t int db/setting/sim_lock_attempts_left "5" -s org.tizen.setting::private
494         vconftool $GOPTION set -t string db/setting/sim_lock_timestamp "" -s org.tizen.setting::private
495         vconftool $GOPTION set -t bool db/setting/fixed_dialing_mode "0" -s org.tizen.setting::private
496 #resetMemory
497         vconftool $GOPTION set -t int db/setting/default_memory/wap "0" -s system::vconf_system
498         vconftool $GOPTION set -t int db/setting/default_memory/download "0" -s system::vconf_system
499         vconftool $GOPTION set -t int db/setting/default_memory/download_nfc "0" -s system::vconf_system
500         vconftool $GOPTION set -t int db/setting/default_memory/download_contents "0" -s system::vconf_system
501         vconftool $GOPTION set -t int db/setting/default_memory/download_application "0" -s system::vconf_system
502         vconftool $GOPTION set -t int db/setting/default_memory/wifi_direct "0" -s system::vconf_system
503         vconftool $GOPTION set -t int db/setting/default_memory/install_applications "0" -s system::vconf_system
504
505         vconftool $GOPTION set -t int db/setting/default_memory/bluetooth "0" -s system::vconf_system
506         vconftool $GOPTION set -t int db/setting/default_memory/camera "0" -s system::vconf_system
507         vconftool $GOPTION set -t int db/setting/default_memory/voice_recorder "0" -s system::vconf_system
508         vconftool $GOPTION set -t int db/setting/default_memory/fm_radio "0" -s system::vconf_system
509         vconftool $GOPTION set -t int db/setting/default_memory/all_share "0" -s system::vconf_system
510         vconftool $GOPTION set -t int db/setting/default_memory/adobe_air "0" -s system::vconf_system
511         vconftool $GOPTION set -t int db/setting/default_memory/dvb_h "0" -s system::vconf_system
512
513         # format - system server
514         #vconftool $GOPTION -i set -t int memory/mmc/format "0"
515
516 #resetAbout
517         vconftool $GOPTION set -t string db/setting/device_name "Gear 2" -s system::vconf_network
518         vconftool $GOPTION set -t string db/setting/selected_num "" -s org.tizen.setting::private
519 #resetMenuWidgets
520         vconftool $GOPTION -i set -t int memory/setting/font_changed "0" -s org.tizen.setting::private
521         #vconftool $GOPTION -i set -t int memory/mobile_hotspot/skin_changed "0"
522
523 #resetDevoptions
524         vconftool $GOPTION -i set -t int db/setting/devoption/bgprocess "0" -s system::vconf_setting
525
526 #resetDatausage
527         vconftool $GOPTION set -t bool db/setting/set_data_usage_limit "0" -s org.tizen.setting::private
528         vconftool $GOPTION set -t int db/setting/data_limit "-1" -s org.tizen.setting::private
529         vconftool $GOPTION set -t int db/setting/data_usage_cycle "0" -s org.tizen.setting::private
530         vconftool $GOPTION set -t int db/setting/data_each_month "1" -s org.tizen.setting::private
531         vconftool $GOPTION set -t int db/setting/data_each_month_app "1" -s org.tizen.setting::private
532         vconftool $GOPTION set -t bool db/setting/data_usage_roaming_status "0" -s org.tizen.setting::private
533         vconftool $GOPTION set -t int db/setting/data_limit_roaming "-1" -s org.tizen.setting::private
534         vconftool $GOPTION set -t bool db/setting/set_data_usage_limit_roaming "0" -s org.tizen.setting::private
535
536 #resetDisplay
537         vconftool $GOPTION set -t string db/setting/screenmode/selected_name "Dynamic" -f -s org.tizen.setting::private
538
539 #resetMostRecentlySetting
540         vconftool $GOPTION set -t string db/setting/most_recently_setting "" -s org.tizen.setting::private
541
542 #psmode(power saving mode)
543         vconftool $GOPTION set -t int db/setting/psmode "0" -s system::vconf_setting
544
545 #resetMyplace
546         vconftool $GOPTION set -t string db/setting/myplace_home "" -s system::vconf_inhouse
547         vconftool $GOPTION set -t string db/setting/myplace_office "" -s system::vconf_inhouse
548
549 # personal page(not include on vconf internal yet)
550         vconftool $GOPTION set -t bool memory/setting/personal "0" -i -s system::vconf_setting
551         vconftool $GOPTION set -t string db/setting/personal_key "" -s system::vconf_setting
552
553 # homescreen layout type
554         vconftool $GOPTION set -t int db/setting/homescreen_type "1" -s system::vconf_inhouse
555
556 # privacy setting
557         vconftool $GOPTION set -t int db/setting/lock_type "0" -s system::vconf_inhouse
558         vconftool $GOPTION set -t bool db/setting/see_pattern "1" -s system::vconf_inhouse
559
560 # display screen rotation
561         vconftool $GOPTION set -t int db/setting/screen_rotation "0" -s system::vconf_inhouse
562
563 # display home screen bg set
564         vconftool $GOPTION set -t int db/setting/homescreen_bg "0" -s system::vconf_inhouse
565
566 # support emergency mode
567         vconftool $GOPTION set -t bool db/setting/support_emergency "1" -s system::vconf_setting
568         vconftool $GOPTION set -t bool db/setting/emergency_status "0" -s system::vconf_setting
569
570 # volume toast show
571 #       vconftool $GOPTION set -t int memory/setting/volume_ring_toast_show "0" -i -f -s org.tizen.setting::private
572 #       vconftool $GOPTION set -t int memory/setting/volume_noti_toast_show "0" -i -f -s org.tizen.setting::private
573
574 # safety, emergency mode
575         vconftool $GOPTION set -t int db/setting/emergency_wakeup_gesture "0" -s system::vconf_setting
576         vconftool $GOPTION set -t int db/setting/emergency_brightness "1" -s system::vconf_setting
577         vconftool $GOPTION set -t int db/setting/emergency_lcd_timeout "10" -s system::vconf_setting
578         vconftool $GOPTION set -t string db/setting/emergency_ringtone "/opt/share/settings/Emergency/Low_power_ringtone.ogg" -s system::vconf_setting
579
580 # power saver wearable
581         vconftool $GOPTION set -t int db/setting/pws_wakeup_gesture "0" -s system::vconf_setting
582         vconftool $GOPTION set -t int db/setting/pws_brightness "1" -s system::vconf_setting
583         vconftool $GOPTION set -t int db/setting/pws_lcd_timeout "10" -s system::vconf_setting
584         vconftool $GOPTION set -t string db/setting/pws_ringtone "/opt/share/settings/Emergency/Low_power_ringtone.ogg" -s system::vconf_setting
585
586         vconftool $GOPTION set -t string db/wms/clocks_set_idle "org.tizen.idle-clock-digital"  -u 5000 -s system::vconf
587         vconftool $GOPTION set -t int db/wms/home_bg_mode 0 -u 5000 -s system::vconf
588         vconftool $GOPTION set -t string db/wms/home_bg_palette "000000" -u 5000 -s system::vconf
589         vconftool $GOPTION set -t string db/wms/home_bg_wallpaper "wallpaper_01.png"  -u 5000 -s system::vconf
590         vconftool $GOPTION set -t string db/wms/home_bg_gallery "/opt/usr/media/.bgwallpaper.jpg" -u 5000 -s system::vconf
591
592         # Idle clock edit mode ( with Home )
593     vconftool $GOPTION set -t int db/setting/idle_clock_show "0" -s system::vconf_inhouse
594
595 if [ -d /opt/share/settings ]
596 then
597         rm -rf /opt/share/settings
598 fi
599
600 ln -s /opt/usr/share/settings /opt/share/settings
601
602 # shared dir
603 mkdir -p /usr/apps/org.tizen.clocksetting/shared
604 mkdir -p /usr/apps/org.tizen.clocksetting/shared/res
605
606 mkdir -p /opt/usr/data/setting
607
608 %files
609 %manifest %{name}.manifest
610 /etc/smack/accesses.d/org.tizen.clocksetting.efl
611 %defattr(-,root,root,-)
612 %attr(-,inhouse,inhouse)
613 %dir %{PREFIX}/data
614 #%{PREFIX}/bin/*
615 #%{PREFIX}/res/*
616 /usr/share/packages/*
617 /usr/share/icons/default/small/*
618 #/usr/share/packages/%{name}.xml
619 #/usr/apps/org.tizen.clocksetting/data/images/*
620 /usr/apps/org.tizen.clocksetting/*
621 #/usr/apps/org.tizen.clocksetting/shared/res/*
622 /opt/usr/share/settings/*
623 /usr/share/Safety.zip
624 /opt/usr/data/setting/*