tizen 2.4 release
[apps/home/attach-panel.git] / packaging / attach-panel.spec
1 Name:       attach-panel
2 Summary:    Attach Panel
3 Version:    0.1.0
4 Release:    0
5 Group:      Application
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8
9 %if "%{?tizen_profile_name}" == "wearable"
10 ExcludeArch: %{arm} %ix86 x86_64
11 %endif
12
13 BuildRequires: cmake
14 BuildRequires: edje-tools
15 BuildRequires: gettext-tools
16
17 BuildRequires: pkgconfig(appcore-efl)
18 BuildRequires: pkgconfig(aul)
19 BuildRequires: pkgconfig(bundle)
20 BuildRequires: pkgconfig(capi-base-common)
21 BuildRequires: pkgconfig(capi-system-info)
22 BuildRequires: pkgconfig(dlog)
23 BuildRequires: pkgconfig(ecore)
24 BuildRequires: pkgconfig(edje)
25 BuildRequires: pkgconfig(efl-extension)
26 BuildRequires: pkgconfig(elementary)
27 BuildRequires: pkgconfig(evas)
28 BuildRequires: pkgconfig(feedback)
29 BuildRequires: pkgconfig(isf)
30 BuildRequires: pkgconfig(security-privilege-checker)
31 BuildRequires: pkgconfig(ui-gadget-1)
32 BuildRequires: pkgconfig(rua)
33
34 %description
35 Description: Attach Panel
36
37 %prep
38 %setup -q
39
40 %package devel
41 Summary:    Attach panel library (devel)
42 Group:      Application
43 Requires:   %{name} = %{version}-%{release}
44
45 %description devel
46 Development files needed to build software that needs Attach panel.
47
48 %build
49 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
50 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
51 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
52
53 %if 0%{?tizen_build_binary_release_type_eng}
54 export CFLAGS="$CFLAGS -DTIZEN_ENGINEER_MODE"
55 export CXXFLAGS="$CXXFLAGS -DTIZEN_ENGINEER_MODE"
56 export FFLAGS="$FFLAGS -DTIZEN_ENGINEER_MODE"
57 %endif
58
59 %cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
60 make %{?jobs:-j%jobs}
61
62 %install
63 rm -rf %{buildroot}
64 %make_install
65
66 %post
67
68 %files
69 %manifest %{name}.manifest
70 %{_prefix}/lib/*.so*
71 %{_datadir}/attach-panel/edje/*.edj
72 %{_datadir}/attach-panel/sample/*
73 %{_datadir}/icons/*.png
74 %{_prefix}/ug/res/locale/*/LC_MESSAGES/*
75
76 %files devel
77 %defattr(-,root,root,-)
78 %{_includedir}/attach-panel/attach_panel.h
79 %{_libdir}/pkgconfig/%{name}.pc