Fix undeclared error by ADD_DEFINITIONS not CMAKE_CXX_FLAGS.
[apps/core/preloaded/wrt-setting.git] / packaging / wrt-setting.spec
1 Name: wrt-setting
2 Version: 0.0.40
3 Release: 1
4 Summary: WRT Setting UI Gadgets
5 Group:   Development/Libraries
6 License: Flora Software License
7 Source0: %{name}-%{version}.tar.gz
8
9 BuildRequires: edje-bin
10 BuildRequires: gettext
11 BuildRequires: edje-tools
12 BuildRequires: cmake
13 BuildRequires: pkgconfig(elementary)
14 BuildRequires: pkgconfig(ecore)
15 BuildRequires: pkgconfig(ui-gadget-1)
16 BuildRequires: pkgconfig(dpl-wrt-dao-ro)
17 BuildRequires: pkgconfig(dpl-wrt-dao-rw)
18 BuildRequires: pkgconfig(dpl-efl)
19 BuildRequires: pkgconfig(security-settings)
20
21 %description
22 WRT Setting UI Gadgets
23
24 %prep
25 %setup -q
26 %cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DUG_INSTALL_PREFIX=/usr -DPROJECT_API_VERSION=0 -DPROJECT_VERSION=%{version}
27
28 %build
29 make %{?jobs:-j%jobs}
30
31 %install
32 rm -rf %{buildroot}
33 mkdir -p %{buildroot}/usr/share/license
34 cp LICENSE.Flora %{buildroot}/usr/share/license/%{name}
35 %make_install
36
37
38 %clean
39 rm -rf %{buildroot}
40
41 %post -p /bin/ldconfig
42
43 %postun -p /bin/ldconfig
44
45 %files
46 %manifest wrt-setting.manifest
47 /etc/smack/accesses2.d/ug.webapp-common-efl.include
48 /etc/smack/accesses2.d/ug.webapp-detail-efl.include
49 %defattr(-,root,root,-)
50 %{_datadir}/license/%{name}
51 /usr/ug/lib/*
52 /usr/ug/res/*