[Task-mgr] Merge 3.0 into 2.4
[apps/core/preloaded/taskmanager.git] / packaging / org.tizen.task-mgr.spec
1 %define Exec task-mgr
2 %define AppInstallPath /usr/apps/%{name}
3
4 Name:           org.tizen.task-mgr
5 Summary:        Taskmanager application
6 Version:        0.0.1
7 Release:        1
8 License:        Apache-2.0
9 Source0:        %{name}-%{version}.tar.gz
10
11 %if "%{?tizen_profile_name}" == "wearable"
12 ExcludeArch: %{arm} %ix86 x86_64
13 %endif
14
15 %if "%{?tizen_profile_name}" == "tv"
16 ExcludeArch: %{arm} %ix86 x86_64
17 %endif
18
19 BuildRequires:  pkgconfig(appcore-efl)
20 BuildRequires:  pkgconfig(capi-appfw-application)
21 BuildRequires:  pkgconfig(ecore)
22 BuildRequires:  pkgconfig(eina)
23 BuildRequires:  pkgconfig(evas)
24 BuildRequires:  pkgconfig(edje)
25 BuildRequires:  edje-tools
26 BuildRequires:  gettext-tools
27 BuildRequires:  pkgconfig(dlog)
28 BuildRequires:  pkgconfig(elementary)
29 BuildRequires:  pkgconfig(capi-system-info)
30 BuildRequires:  pkgconfig(capi-appfw-package-manager)
31 BuildRequires:  pkgconfig(capi-appfw-app-manager)
32 BuildRequires:  cmake
33 BuildRequires:  pkgconfig(pkgmgr-info)
34 BuildRequires:  pkgconfig(rua)
35 BuildRequires:  pkgconfig(feedback)
36
37 %description
38 Taskmanager application.
39
40 %prep
41 %setup -q
42
43 %build
44 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
45 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
46 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
47
48 cmake . -DCMAKE_INSTALL_PREFIX="%{AppInstallPath}" -DCMAKE_TARGET="%{Exec}" -DCMAKE_PACKAGE="%{name}"
49 make %{?jobs:-j%jobs}
50
51 %install
52 rm -rf %{buildroot}
53 %make_install
54
55 %post
56 /sbin/ldconfig
57
58 %postun -p /sbin/ldconfig
59
60 %files
61 %manifest %{name}.manifest
62 %defattr(-,root,root,-)
63 %{AppInstallPath}/bin/task-mgr
64 %{AppInstallPath}/res/*
65 %{_datarootdir}/packages/%{name}.xml
66 /etc/smack/accesses.d/%{name}.efl
67 %{AppInstallPath}/res/locale/*/LC_MESSAGES/*