merge with master
[apps/core/preloaded/lockscreen.git] / packaging / org.tizen.lockscreen.spec
1 %define PREFIX /usr/apps/org.tizen.lockscreen
2
3 Name:       org.tizen.lockscreen
4 Summary:    lockscreen application
5 Version:    0.1.15
6 Release:    1
7 Group:      TBD
8 License:    Apache
9 Source0:    %{name}-%{version}.tar.gz
10 BuildRequires: pkgconfig(capi-appfw-application)
11 BuildRequires: pkgconfig(ecore-x)
12 BuildRequires: pkgconfig(appcore-efl)
13 BuildRequires: pkgconfig(utilX)
14 BuildRequires: pkgconfig(ail)
15 BuildRequires: pkgconfig(notification)
16 BuildRequires: pkgconfig(security-server)
17 BuildRequires: pkgconfig(ui-gadget-1)
18 BuildRequires: pkgconfig(heynoti)
19 BuildRequires: pkgconfig(capi-system-info)
20
21 BuildRequires: cmake
22 BuildRequires: gettext
23 BuildRequires: edje-tools
24 %description
25 lockscreen application.
26
27 %prep
28 %setup -q
29
30 %build
31 LDFLAGS+="-Wl,--rpath=%{PREFIX}/lib -Wl,--as-needed";export LDFLAGS
32 cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX}
33 make %{?jobs:-j%jobs}
34
35 %install
36 %make_install
37 mkdir -p %{buildroot}/usr/apps/org.tizen.lockscreen/data
38 mkdir -p %{buildroot}/usr/share/license
39 install -m 0755 LICENSE.Flora %{buildroot}/usr/share/license/org.tizen.lockscreen
40
41 %post
42 /sbin/ldconfig
43
44 GOPTION="-g 6514"
45
46 %postun -p /sbin/ldconfig
47
48 %files
49 %manifest org.tizen.lockscreen.manifest
50 %defattr(-,root,root,-)
51 %attr(-,inhouse,inhouse) %dir /usr/apps/org.tizen.lockscreen/data
52 /usr/apps/org.tizen.lockscreen/*
53 /usr/share/packages/org.tizen.lockscreen.xml
54 /usr/share/license/org.tizen.lockscreen
55 /usr/apps/org.tizen.lockscreen/res/locale/*/LC_MESSAGES/lockscreen.mo