[UI]Remove mdm
[apps/core/preloaded/lockscreen.git] / packaging / org.tizen.lockscreen.spec
1 %define PREFIX /usr/apps/org.tizen.lockscreen
2
3 Name:       org.tizen.lockscreen
4 Summary:    lockscreen application
5 Version: 0.1.3
6 Release:    1
7 Group:      TBD
8 License:    Apache
9 Source0:    %{name}-%{version}.tar.gz
10 BuildRequires: pkgconfig(capi-appfw-application)
11 BuildRequires: pkgconfig(ecore-x)
12 BuildRequires: pkgconfig(appcore-efl)
13 BuildRequires: pkgconfig(utilX)
14 BuildRequires: pkgconfig(ail)
15 BuildRequires: pkgconfig(notification)
16 BuildRequires: pkgconfig(security-server)
17
18 BuildRequires: cmake
19 BuildRequires: gettext
20 BuildRequires: edje-tools
21 %description
22 lockscreen application.
23
24 %prep
25 %setup -q
26
27 %build
28 LDFLAGS+="-Wl,--rpath=%{PREFIX}/lib -Wl,--as-needed";export LDFLAGS
29 cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX}
30 make %{?jobs:-j%jobs}
31
32 %install
33 %make_install
34 mkdir -p %{buildroot}/usr/apps/org.tizen.lockscreen/data
35 mkdir -p %{buildroot}/usr/share/license
36 install -m 0755 LICENSE %{buildroot}/usr/share/license/org.tizen.lockscreen
37
38 %post
39 /sbin/ldconfig
40
41 GOPTION="-g 6514"
42
43 %postun -p /sbin/ldconfig
44
45 %files
46 %manifest org.tizen.lockscreen.manifest
47 %defattr(-,root,root,-)
48 %attr(-,inhouse,inhouse) %dir /usr/apps/org.tizen.lockscreen/data
49 /usr/apps/org.tizen.lockscreen/*
50 /usr/share/packages/org.tizen.lockscreen.xml
51 /usr/share/license/org.tizen.lockscreen