modified code to use efl_util_set_notification_window_level() for setting notificatio...
[apps/core/preloaded/lockscreen.git] / packaging / org.tizen.lockscreen.spec
1 %bcond_with wayland
2
3 %define AppInstallPath /usr/apps/org.tizen.lockscreen
4 %define Exec lockscreen
5
6 Name:       org.tizen.lockscreen
7 Summary:    Lockscreen app
8 Version:    0.0.1
9 Release:    1
10 License:    Apache-2.0
11 Source0:    %{name}-%{version}.tar.gz
12
13 %if "%{profile}" == "wearable"
14 ExcludeArch: %{arm} %ix86 x86_64
15 %endif
16
17 %if "%{profile}" == "tv"
18 ExcludeArch: %{arm} %ix86 x86_64
19 %endif
20
21 BuildRequires:  pkgconfig(appcore-efl)
22 BuildRequires:  pkgconfig(ecore)
23 BuildRequires:  pkgconfig(eina)
24 BuildRequires:  pkgconfig(evas)
25 BuildRequires:  pkgconfig(bundle)
26 BuildRequires:  pkgconfig(capi-system-sensor)
27 BuildRequires:  pkgconfig(capi-system-info)
28 BuildRequires:  pkgconfig(capi-system-runtime-info)
29 BuildRequires:  pkgconfig(capi-system-system-settings)
30 BuildRequires:  pkgconfig(capi-system-device)
31 BuildRequires:  pkgconfig(capi-appfw-application)
32 BuildRequires:  pkgconfig(capi-appfw-preference)
33 BuildRequires:  pkgconfig(capi-appfw-app-manager)
34 BuildRequires:  pkgconfig(capi-ui-efl-util)
35 BuildRequires:  pkgconfig(deviced)
36 BuildRequires:  pkgconfig(edje)
37 BuildRequires:  pkgconfig(aul)
38 BuildRequires:  pkgconfig(ail)
39 BuildRequires:  pkgconfig(dlog)
40 BuildRequires:  pkgconfig(glib-2.0)
41 BuildRequires:  pkgconfig(dbus-1)
42 BuildRequires:  pkgconfig(dbus-glib-1)
43 BuildRequires:  pkgconfig(elementary)
44 BuildRequires:  pkgconfig(notification)
45 BuildRequires:  pkgconfig(minicontrol-viewer)
46 BuildRequires:  pkgconfig(security-server)
47 BuildRequires:  pkgconfig(minicontrol-monitor)
48 BuildRequires:  pkgconfig(ui-gadget-1)
49 BuildRequires:  pkgconfig(feedback)
50 BuildRequires:  pkgconfig(msg-service)
51 BuildRequires:  pkgconfig(tapi)
52 BuildRequires:  pkgconfig(efl-extension)
53 BuildRequires:  pkgconfig(key-manager)
54 BuildRequires:  pkgconfig(accounts-svc)
55 BuildRequires:  cmake
56 BuildRequires:  edje-tools
57 BuildRequires:  gettext-tools
58 #BuildRequires:  model-build-features
59
60 %if %{with wayland}
61 BuildRequires:  pkgconfig(ecore-wayland)
62 %else
63 BuildRequires:  pkgconfig(ecore-x)
64 BuildRequires:  pkgconfig(utilX)
65 %endif
66
67 %description
68 Lockscreen application for Tizen.
69
70 %prep
71 %setup -q
72
73 %build
74 %if 0%{?tizen_build_binary_release_type_eng}
75 export CFLAGS="$CFLAGS -DTIZEN_ENGINEER_MODE"
76 export CXXFLAGS="$CXXFLAGS -DTIZEN_ENGINEER_MODE"
77 export FFLAGS="$FFLAGS -DTIZEN_ENGINEER_MODE"
78 %endif
79
80 %ifarch %{arm}
81 export CFLAGS="$CFLAGS -DTIZEN_BUILD_TARGET"
82 export CXXFLAGS="$CXXFLAGS -DTIZEN_BUILD_TARGET"
83 export FFLAGS="$FFLAGS -DTIZEN_BUILD_TARGET"
84 %else
85 export CFLAGS="$CFLAGS -DTIZEN_BUILD_EMULATOR"
86 export CXXFLAGS="$CXXFLAGS -DTIZEN_BUILD_EMULATOR"
87 export FFLAGS="$FFLAGS -DTIZEN_BUILD_EMULATOR"
88 %endif
89
90 %if %{with wayland}
91 export WAYLAND_SUPPORT=On
92 export X11_SUPPORT=Off
93 %else
94 export WAYLAND_SUPPORT=Off
95 export X11_SUPPORT=On
96 %endif
97
98 cmake . -DCMAKE_INSTALL_PREFIX="%{AppInstallPath}" -DCMAKE_TARGET="%{Exec}" -DCMAKE_PACKAGE="%{name}" -DWAYLAND_SUPPORT=${WAYLAND_SUPPORT} -DX11_SUPPORT=${X11_SUPPORT}
99 make %{?jobs:-j%jobs}
100
101 %install
102 rm -rf %{buildroot}
103 %make_install
104
105 %post
106 /sbin/ldconfig
107
108 %postun -p /sbin/ldconfig
109
110 %files
111 %manifest org.tizen.lockscreen.manifest
112 %defattr(-,root,root,-)
113 %{AppInstallPath}/bin/lockscreen
114 %{AppInstallPath}/res/images/*.png
115 %{AppInstallPath}/res/edje/*.edj
116 %{AppInstallPath}/res/locale/*/LC_MESSAGES/*
117 /usr/share/packages/org.tizen.lockscreen.xml