0b7ee1651d76d435b5ab41d74d4ce2a15cc9e2ae
[apps/core/preloaded/charging-animation.git] / packaging / charging-animation.spec
1 Name:       charging-animation
2 Summary:    charging-animation
3 ExclusiveArch:  %{arm}
4 Version:    0.0.2
5 Release:    1
6 Group:      misc
7 License:    Flora Software License
8 Source0:    %{name}-%{version}.tar.gz
9
10 BuildRequires: cmake
11
12 BuildRequires: pkgconfig(libpng)
13 BuildRequires: pkgconfig(libdrm)
14 BuildRequires: pkgconfig(libkms)
15
16 %description
17 charging-animation
18
19 %prep
20 %setup -q
21
22
23 %build
24 export LDFLAGS+="-Wl,--rpath=%{_prefix}/lib -Wl,--as-needed"
25 mkdir cmake_tmp
26 cd cmake_tmp
27 LDFLAGS="$LDFLAGS" cmake .. -DCMAKE_INSTALL_PREFIX=%{_prefix}
28
29 make %{?jobs:-j%jobs}
30
31 %install
32 cd cmake_tmp
33 %make_install
34
35 %post
36 chmod 755 /etc/rc.d/init.d/run-chg-ani
37 mkdir -p /etc/rc.d/rc2.d
38 ln -s /etc/rc.d/init.d/run-chg-ani /etc/rc.d/rc2.d/S01charging-animation
39
40 %files
41 %defattr(-,root,root,-)
42 %{_prefix}/bin/*
43 %{_prefix}/share/*
44 /etc/*
45
46