Add firstboot systemd service file
[adaptation/system-plugin-ia-generic.git] / packaging / system-plugin-ia-generic.spec
1 Summary: The inittab file and the /etc/init.d scripts
2 Name: system-plugin-ia-generic
3 Version: 0.0.10
4 License: Apache v2.0
5 Group: System/Base
6 Release: 1
7 Source: %{name}-%{version}.tar.bz2
8 Source1001: packaging/system-plugin-ia-generic.manifest 
9 # >> gbp-patch-tags         # auto-added by gbp
10 # << gbp-patch-tags         # auto-added by gbp
11 Requires: udev
12 Requires: corewatcher
13 Requires: systemd
14 Requires(post):   systemd
15 Requires(preun):  systemd
16 Requires(postun): systemd
17 ExclusiveArch: %ix86 x86_64
18
19
20 %description
21 Startup files
22
23 %prep
24 %setup -q
25 # >> gbp-apply-patches    # auto-added by gbp
26 # << gbp-apply-patches    # auto-added by gbp
27
28 %build
29 cp %{SOURCE1001} .
30
31 %install
32 cp -a etc %{buildroot}
33 cp -a usr %{buildroot}
34 mkdir -p %{buildroot}%{_prefix}/etc/bluetooth/
35 install -m 0755 scripts/bt-dev-end.sh  %{buildroot}%{_prefix}/etc/bluetooth/
36 install -m 0755 scripts/bt-dev-start.sh  %{buildroot}%{_prefix}/etc/bluetooth/
37 install -m 0755 scripts/bt-set-addr.sh  %{buildroot}%{_prefix}/etc/bluetooth/
38
39 %post
40 systemctl daemon-reload
41 systemctl restart firstboot.service
42
43 %preun
44 systemctl stop firstboot.service
45
46 %postun
47 systemctl daemon-reload
48
49 %files
50 %manifest system-plugin-ia-generic.manifest
51 /etc/fstab
52 %config(noreplace) /etc/inittab
53 %exclude %config(noreplace) /etc/mtools.conf
54 /etc/profile.d/system.sh
55 /etc/profile.d/fonts.sh
56 /etc/rc.d/rc.entersleep
57 /etc/rc.d/rc.firstboot
58 /etc/rc.d/rc.leavesleep
59 /etc/rc.d/rc.shutdown
60 /etc/rc.d/rc.sysinit
61 /etc/rc.d/rc.*
62 /usr/bin/wlan.sh
63 /usr/lib/systemd/system/firstboot.service
64 /usr/lib/systemd/system/sysinit.target.wants/firstboot.service
65 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-end.sh
66 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-start.sh
67 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-set-addr.sh