Comment out missing file in files section
[adaptation/panda/libdrm.git] / packaging / libdrm.spec
1 Name:       libdrm
2 Summary:    Userspace interface to kernel DRM services -- runtime
3 Version:    2.4.39
4 Release:    1
5 Group:      libs
6 License:    MIT 
7 Source0:    libdrm-%{version}.tar.bz2
8 Patch0:     0001-Adding-slp-subpackage.patch
9 Patch1:     0002-Adding-changes-to-configure.ac.patch
10 Requires(post): /sbin/ldconfig
11 Requires(postun): /sbin/ldconfig
12 BuildRequires:  pkgconfig(x11)
13 BuildRequires:  pkgconfig(pthread-stubs)
14 BuildRequires:  pkgconfig(pciaccess)
15 BuildRequires:  automake
16 BuildRequires:  libtool
17
18
19 %description
20 Userspace interface to kernel DRM services -- runtime
21  This library implements the userspace interface to the kernel DRM
22  services.  DRM stands for "Direct Rendering Manager", which is the
23  kernelspace portion of the "Direct Rendering Infrastructure" (DRI).
24  The DRI is currently used on Linux to provide hardware-accelerated
25  OpenGL drivers.
26  
27 This package provides the runtime environment for libdrm..
28
29 %package devel
30 Summary:    Userspace interface to kernel DRM services -- development files
31 Group:      libdevel
32 Requires:   libdrm = %{version}-%{release}
33 Obsoletes:   linux-libc-dev >= 2.6.29
34
35 %description devel
36 Userspace interface to kernel DRM services -- development files
37  This library implements the userspace interface to the kernel DRM
38  services.  DRM stands for "Direct Rendering Manager", which is the
39  kernelspace portion of the "Direct Rendering Infrastructure" (DRI).
40  The DRI is currently used on Linux to provide hardware-accelerated
41  OpenGL drivers.
42  
43  This package provides the development environment for libdrm..
44
45 %package slp1
46 Summary:        Userspace interface to slp-specific kernel DRM services
47 Group:          Development/Libraries
48
49 %description slp1
50 Userspace interface to slp-specific kernel DRM services
51
52
53 %package -n libkms
54 Summary:    Userspace interface to kernel DRM buffer management
55 Group:      libs
56 Requires(post): /sbin/ldconfig
57 Requires(postun): /sbin/ldconfig
58
59 %description -n libkms
60 Userspace interface to kernel DRM buffer management
61  This library implements a unified userspace interface to the different buffer
62  management interfaces of the kernel DRM hardware drivers..
63
64 %prep
65 %setup -q -n %{name}-%{version}
66
67 %patch0 -p1
68 %patch1 -p1
69
70 %build
71 %configure --disable-static --enable-nouveau-experimental-api
72 make %{?jobs:-j%jobs}
73
74 %install
75 rm -rf %{buildroot}
76 %make_install
77
78 %post -p /sbin/ldconfig
79
80 %postun -p /sbin/ldconfig
81
82 %post -n libkms -p /sbin/ldconfig
83
84 %postun -n libkms -p /sbin/ldconfig
85
86 %files
87 %defattr(-,root,root,-)
88 %{_libdir}/libdrm.so.*
89 #%{_libdir}/libdrm_intel.so.*
90 %{_libdir}/libdrm_radeon.so.*
91 %{_libdir}/libdrm_nouveau.so.*
92
93 %files devel
94 %defattr(-,root,root,-)
95 %{_includedir}/libdrm/*
96 %{_includedir}/xf86drmMode.h
97 %{_includedir}/xf86drm.h
98 %{_includedir}/libkms/*
99
100 %{_libdir}/lib*.so
101 %{_libdir}/pkgconfig/*
102
103 %files slp1
104 %{_libdir}/libdrm_slp*.so.*
105
106 %files -n libkms
107 %defattr(-,root,root,-)
108 %{_libdir}/libkms.so.*
109