Initialize Tizen 2.3
[adaptation/devices/alsa-scenario-scn-data-0-ymu831.git] / packaging / alsa-scenario-scn-data-0-ymu831.spec
1 Name:       alsa-scenario-scn-data-0-ymu831
2 Summary:    alsa scenario data for ymu831 codec
3 Version:    0.2.3
4 Release:    0
5 Group:      TO_BE/FILLED_IN
6 License:    Apache-2.0
7 BuildArch:  noarch
8 Source0:    %{name}-%{version}.tar.gz
9 Requires(post): coreutils
10 Requires(post): setup
11 BuildRequires: setup
12
13 %description
14 Alsa scenario data ymu831 codec
15
16
17 %package cis
18 Summary:    alsa scenario data for ymu831 codec on Redwood 3G CIS
19 Group:      TO_BE/FILLED_IN
20 License:    Apache-2.0
21
22 %description cis
23 Alsa scenario data ymu831 codec for 3G CIS
24
25
26 %package ora_lte
27 Summary:    alsa scenario data for ymu831 codec on Redwood Orange LTE
28 Group:      TO_BE/FILLED_IN
29 License:    Apache-2.0
30
31 %description ora_lte
32 Alsa scenario data ymu831 codec for Orange LTE
33
34
35 %package dcm_lte
36 Summary:    alsa scenario data for ymu831 codec on Redwood NTT DoCoMo LTE
37 Group:      TO_BE/FILLED_IN
38 License:    Apache-2.0
39
40 %description dcm_lte
41 Alsa scenario data ymu831 codec for NTT DoCoMo LTE
42
43
44 %package B1
45 Summary:    alsa scenario data for ymu831 codec on B1 target
46 Group:      TO_BE/FILLED_IN
47 License:    Apache-2.0
48
49 %description B1
50 Alsa scenario data ymu831 codec for B1 target
51
52
53 %package B2
54 Summary:    alsa scenario data for ymu831 codec on B2 target
55 Group:      TO_BE/FILLED_IN
56 License:    Apache-2.0
57
58 %description B2
59 Alsa scenario data ymu831 codec for B2 target
60
61
62 %prep
63 %setup -q
64
65 %build
66
67 %install
68 /bin/rm -rf %{buildroot}
69 /bin/mkdir -p %{buildroot}/usr/etc/sound/
70 /bin/cp -arf ymu831* %{buildroot}/usr/etc/sound/
71
72 mkdir -p %{buildroot}/usr/share/license
73 cp LICENSE %{buildroot}/usr/share/license/%{name}-B1
74 cp LICENSE %{buildroot}/usr/share/license/%{name}-B2
75
76
77 %post
78 BASE_PATH=/usr/etc/sound
79 CODEC=ymu831
80 TARGET=ymu831_base
81
82 ln -s $BASE_PATH/$TARGET.conf $BASE_PATH/$CODEC.conf
83 ln -s $BASE_PATH/$TARGET $BASE_PATH/$CODEC
84 ln -s $BASE_PATH/$TARGET.conf $BASE_PATH/default.conf
85 ln -s $BASE_PATH/$TARGET $BASE_PATH/default
86
87 %post cis
88 BASE_PATH=/usr/etc/sound
89 CODEC=ymu831
90 TARGET=ymu831_3g_cis
91
92 ln -s $BASE_PATH/$TARGET.conf $BASE_PATH/$CODEC.conf
93 ln -s $BASE_PATH/$TARGET $BASE_PATH/$CODEC
94 ln -s $BASE_PATH/$TARGET.conf $BASE_PATH/default.conf
95 ln -s $BASE_PATH/$TARGET $BASE_PATH/default
96
97 %post ora_lte
98 BASE_PATH=/usr/etc/sound
99 CODEC=ymu831
100 TARGET=ymu831_lte_ora
101
102 ln -s $BASE_PATH/$TARGET.conf $BASE_PATH/$CODEC.conf
103 ln -s $BASE_PATH/$TARGET $BASE_PATH/$CODEC
104 ln -s $BASE_PATH/$TARGET.conf $BASE_PATH/default.conf
105 ln -s $BASE_PATH/$TARGET $BASE_PATH/default
106
107 %post dcm_lte
108 BASE_PATH=/usr/etc/sound
109 CODEC=ymu831
110 TARGET=ymu831_lte_dcm
111
112 ln -s $BASE_PATH/$TARGET.conf $BASE_PATH/$CODEC.conf
113 ln -s $BASE_PATH/$TARGET $BASE_PATH/$CODEC
114 ln -s $BASE_PATH/$TARGET.conf $BASE_PATH/default.conf
115 ln -s $BASE_PATH/$TARGET $BASE_PATH/default
116
117
118 %post B1
119 BASE_PATH=/usr/etc/sound
120 CODEC=ymu831
121 TARGET=ymu831_B1
122
123 ln -s $BASE_PATH/$TARGET.conf $BASE_PATH/$CODEC.conf
124 ln -s $BASE_PATH/$TARGET $BASE_PATH/$CODEC
125 ln -s $BASE_PATH/$TARGET.conf $BASE_PATH/default.conf
126 ln -s $BASE_PATH/$TARGET $BASE_PATH/default
127
128 %post B2
129 BASE_PATH=/usr/etc/sound
130 CODEC=ymu831
131 TARGET=ymu831_B2
132
133 ln -s $BASE_PATH/$TARGET.conf $BASE_PATH/$CODEC.conf
134 ln -s $BASE_PATH/$TARGET $BASE_PATH/$CODEC
135 ln -s $BASE_PATH/$TARGET.conf $BASE_PATH/default.conf
136 ln -s $BASE_PATH/$TARGET $BASE_PATH/default
137
138 %pre
139 BASE_PATH=/usr/etc/sound
140 /bin/rm -rf $BASE_PATH/default*
141 /bin/rm -rf $BASE_PATH/ymu831
142 /bin/rm -rf $BASE_PATH/ymu831.conf
143
144 %pre cis
145 BASE_PATH=/usr/etc/sound
146 /bin/rm -rf $BASE_PATH/default*
147 /bin/rm -rf $BASE_PATH/ymu831
148 /bin/rm -rf $BASE_PATH/ymu831.conf
149
150 %pre ora_lte
151 BASE_PATH=/usr/etc/sound
152 /bin/rm -rf $BASE_PATH/default*
153 /bin/rm -rf $BASE_PATH/ymu831
154 /bin/rm -rf $BASE_PATH/ymu831.conf
155
156 %pre dcm_lte
157 BASE_PATH=/usr/etc/sound
158 /bin/rm -rf $BASE_PATH/default*
159 /bin/rm -rf $BASE_PATH/ymu831
160 /bin/rm -rf $BASE_PATH/ymu831.conf
161
162 %pre B1
163 BASE_PATH=/usr/etc/sound
164 /bin/rm -rf $BASE_PATH/default*
165 /bin/rm -rf $BASE_PATH/ymu831
166 /bin/rm -rf $BASE_PATH/ymu831.conf
167
168 %pre B2
169 BASE_PATH=/usr/etc/sound
170 /bin/rm -rf $BASE_PATH/default*
171 /bin/rm -rf $BASE_PATH/ymu831
172 /bin/rm -rf $BASE_PATH/ymu831.conf
173
174 %files
175 %manifest alsa-scenario-scn-data-0-ymu831.manifest
176 %defattr(-,root,soundpath,-)
177 /usr/etc/sound/ymu831_base.conf
178 /usr/etc/sound/ymu831_base/*
179
180 %files cis
181 %manifest alsa-scenario-scn-data-0-ymu831.manifest
182 %defattr(-,root,soundpath,-)
183 /usr/etc/sound/ymu831_3g_cis.conf
184 /usr/etc/sound/ymu831_3g_cis/*
185
186 %files ora_lte
187 %manifest alsa-scenario-scn-data-0-ymu831.manifest
188 %defattr(-,root,soundpath,-)
189 /usr/etc/sound/ymu831_lte_ora.conf
190 /usr/etc/sound/ymu831_lte_ora/*
191
192 %files dcm_lte
193 %manifest alsa-scenario-scn-data-0-ymu831.manifest
194 %defattr(-,root,soundpath,-)
195 /usr/etc/sound/ymu831_lte_dcm.conf
196 /usr/etc/sound/ymu831_lte_dcm/*
197
198 %files B1
199 %manifest alsa-scenario-scn-data-0-ymu831.manifest
200 %defattr(-,root,soundpath,-)
201 /usr/etc/sound/ymu831_B1.conf
202 /usr/etc/sound/ymu831_B1/*
203 /usr/share/license/%{name}-B1
204
205 %files B2
206 %manifest alsa-scenario-scn-data-0-ymu831.manifest
207 %defattr(-,root,soundpath,-)
208 /usr/etc/sound/ymu831_B2.conf
209 /usr/etc/sound/ymu831_B2/*
210 /usr/share/license/%{name}-B2