tizen: update specs after v2021.10 rebase and cleanup
[platform/kernel/u-boot.git] / packaging / u-boot-rpi3.spec
index c49a4af..34994e3 100644 (file)
@@ -10,8 +10,10 @@ Source0: u-boot-%{version}.tar.bz2
 Source1001: u_boot_rpi3.manifest
 
 BuildRequires: gcc >= 6.0
+BuildRequires: bc
 BuildRequires: flex
 BuildRequires: bison
+BuildRequires: libopenssl1.1-devel
 
 %description
 u-boot - Tizen bootloader for RPI3 boards based
@@ -19,7 +21,6 @@ u-boot - Tizen bootloader for RPI3 boards based
 %package -n u-boot-tools
 Summary: Companion tools for Das U-Boot bootloader
 Group: System/Kernel
-Provides: dtc
 
 %description -n u-boot-tools
 This package includes the mkimage program, which allows generation of U-Boot
@@ -38,9 +39,6 @@ CONFIG=rpi_3_defconfig
 
 make mrproper
 
-# Build dtc
-make HOSTCC="gcc $RPM_OPT_FLAGS" -C tools/dtc
-
 # Set configuration
 make $CONFIG
 
@@ -50,7 +48,7 @@ make %{?_smp_mflags} HOSTCC="gcc $RPM_OPT_FLAGS" HOSTSTRIP=/bin/true tools
 make HOSTCC="gcc $RPM_OPT_FLAGS" envtools
 
 # Build u-boot
-export PATH="$PATH:tools:tools/dtc/"
+export PATH="$PATH:tools"
 make %{?_smp_mflags} EXTRAVERSION=`echo %{vcs} | sed 's/.*u-boot.*#\(.\{9\}\).*/-g\1-TIZEN.org/'`
 
 # Generate params.bin
@@ -68,7 +66,6 @@ rm -rf %{buildroot}
 mkdir -p %{buildroot}%{_bindir}
 install -p -m 0755 tools/mkimage %{buildroot}%{_bindir}
 install -p -m 0755 tools/env/fw_printenv %{buildroot}%{_bindir}
-install -p -m 0755 tools/dtc/dtc %{buildroot}%{_bindir}
 ( cd %{buildroot}%{_bindir}; ln -sf fw_printenv fw_setenv )
 
 # u-boot installation
@@ -92,4 +89,3 @@ install -m 755 boot.scr.uimg %{buildroot}/boot/
 %{_bindir}/mkimage
 %{_bindir}/fw_printenv
 %{_bindir}/fw_setenv
-%{_bindir}/dtc