modified logs to add agent fields settings
[platform/core/connectivity/net-config.git] / packaging / net-config.spec
index bfb3fac..6ed9250 100755 (executable)
@@ -1,7 +1,7 @@
 Name:          net-config
 Summary:       TIZEN Network Configuration service
-Version:       1.1.120
-Release:       2
+Version:       1.1.125
+Release:       3
 Group:         System/Network
 License:       Apache-2.0
 Source0:       %{name}-%{version}.tar.gz
@@ -20,6 +20,8 @@ Requires:             vconf
 Requires:              connman
 Requires:              systemd
 Requires:              security-config
+Requires:              iproute2
+Requires:              iptables
 Requires(post):                systemd
 Requires(preun):       systemd
 Requires(postun):      systemd
@@ -37,6 +39,12 @@ Requires:       %{name} = %{version}-%{release}
 %description profile_tv
 TIZEN Network Configuration service extension for Tizen TV profile.
 
+%package profile_wearable
+Summary:        net-config extension for wearable profile
+Requires:       %{name} = %{version}-%{release}
+%description profile_wearable
+TIZEN Network Configuration service extension for Tizen wearable profile.
+
 %package plugin-headed
 Summary:        net-config extension for headed profile
 BuildRequires: pkgconfig(bundle)
@@ -58,31 +66,31 @@ TIZEN Network Configuration service extension for telephony FW.
 %prep
 %setup -q
 
-# NOTE: the following macros are undefined.
-# PLEASE DO NOT USE model_build_features in the future with Tizen 4.0+.
-#{?model_build_feature_wlan_concurrent_mode}
-#{?model_build_feature_wlan_p2p_disable}
-#{?model_build_feature_network_tethering_disable}
-#{?model_build_feature_wlan_wearable}
-# In case, we have commercializing team using such unwelcomed
-# macros in their productin build, we are keeping those.
-# However, it is recommended to remove all if/endif with model_build_feature
-
-# NOTE: Are we really going to make "mobile" == "SPRD"?
-
 %build
+# Build for wearable
 cmake -DCMAKE_INSTALL_PREFIX=%{_prefix} \
        -DTIZEN_WLAN_PASSPOINT=1 \
        -DTIZEN_WLAN_USE_P2P_INTERFACE=1 \
        -DTIZEN_DEBUG_ENABLE=1 \
-%if 0%{?model_build_feature_wlan_concurrent_mode}
-       -DWLAN_CONCURRENT_MODE=1 \
-%endif
-%if 0%{?model_build_feature_wlan_wearable} == 1
        -DTIZEN_WEARABLE=1 \
        -DTIZEN_CAPTIVE_PORTAL=1 \
-%endif
-        -DLIB_PATH=%{_lib} \
+       -DLIB_PATH=%{_lib} \
+       .
+
+%make_install
+mv %{buildroot}%{_bindir}/net-config %{_builddir}/%{name}-%{version}/net-config.wearable
+
+make %{?_smp_mflags}
+
+
+# Build for common packages
+cmake -DCMAKE_INSTALL_PREFIX=%{_prefix} \
+       -DTIZEN_WLAN_PASSPOINT=1 \
+       -DTIZEN_WLAN_USE_P2P_INTERFACE=1 \
+       -DTIZEN_DEBUG_ENABLE=1 \
+       -DTIZEN_WEARABLE=0 \
+       -DTIZEN_CAPTIVE_PORTAL=0 \
+       -DLIB_PATH=%{_lib} \
        .
 
 make %{?_smp_mflags}
@@ -134,11 +142,11 @@ cp resources/opt/etc/dump.d/module.d/network_dump.sh %{buildroot}/opt/etc/dump.d
 mkdir -p %{buildroot}/opt/var/lib/net-config/
 cp resources/opt/etc/dump.d/module.d/network_dump.sh %{buildroot}/opt/var/lib/net-config/network_dump.sh
 
-%if 0%{?model_build_feature_wlan_wearable} == 1
 #softreset scripts
 mkdir -p %{buildroot}/usr/system/RestoreDir/softreset
 cp resources/usr/system/RestoreDir/softreset/network_softreset.sh %{buildroot}/usr/system/RestoreDir/softreset/network_softreset.sh
-%endif
+
+mv %{_builddir}/%{name}-%{version}/net-config.wearable %{buildroot}%{_bindir}
 
 %post
 chsmack -a 'System::Shared' %{_sysconfdir}/resolv.conf
@@ -177,7 +185,7 @@ ln -sf %{_unitdir}/net-config.service %{_sysconfdir}/systemd/default-extra-depen
 %attr(644,root,root) %{_sysconfdir}/dbus-1/system.d/*
 %attr(644,root,root) %{_libdir}/systemd/system/net-config.service
 %attr(644,root,root) %{_libdir}/systemd/system/multi-user.target.wants/net-config.service
-%attr(644,network_fw,network_fw) /usr/lib/tmpfiles.d/security-network-config.conf
+%attr(644,root,root) /usr/lib/tmpfiles.d/security-network-config.conf
 %if "%{?_lib}" == "lib64"
 %attr(644,root,root) %{_unitdir}/net-config.service
 %attr(644,root,root) %{_unitdir}/multi-user.target.wants/net-config.service
@@ -185,15 +193,14 @@ ln -sf %{_unitdir}/net-config.service %{_sysconfdir}/systemd/default-extra-depen
 %license LICENSE
 %attr(500,root,root) /opt/etc/dump.d/module.d/network_dump.sh
 %attr(500,network_fw,network_fw) /opt/var/lib/net-config/network_dump.sh
-%if 0%{?model_build_feature_wlan_wearable} == 1
-%attr(700,network_fw,network_fw) /usr/system/RestoreDir/softreset/network_softreset.sh
-%endif
 
+#### tv profile ####
 %post profile_tv
 mv %{_libdir}/systemd/system/net-config.service.tv %{_libdir}/systemd/system/net-config.service
 %if "%{?_lib}" == "lib64"
 mv %{_unitdir}/net-config.service.tv %{_unitdir}/net-config.service
 %endif
+
 %files profile_tv
 %attr(644,network_fw,network_fw) %{_libdir}/udev/rules.d/99-wifiusb-dev.rules
 %attr(644,root,root) %{_libdir}/systemd/system/net-config.service.tv
@@ -201,6 +208,19 @@ mv %{_unitdir}/net-config.service.tv %{_unitdir}/net-config.service
 %attr(644,root,root) %{_unitdir}/net-config.service.tv
 %endif
 
+#### wearable profile ####
+%preun profile_wearable
+rm %{_bindir}/net-config
+
+%post profile_wearable
+pushd %{_bindir}
+mv net-config.wearable net-config
+
+%files profile_wearable
+%attr(644,root,root) %{_bindir}/net-config.wearable
+%attr(644,network_fw,network_fw) /usr/system/RestoreDir/softreset/network_softreset.sh
+
+#### plugin ####
 %files plugin-headed
 %manifest net-config.manifest
 %attr(500,network_fw,network_fw) %{_libdir}/net-config-plugin-headed.so