Add gcov to BuildRequires
[platform/core/connectivity/net-config.git] / packaging / net-config.spec
index ec96264..3f1a4e8 100755 (executable)
@@ -1,6 +1,6 @@
 Name:          net-config
 Summary:       TIZEN Network Configuration service
-Version:       1.1.136
+Version:       1.1.141
 Release:       3
 Group:         System/Network
 License:       Apache-2.0
@@ -16,6 +16,7 @@ BuildRequires:        pkgconfig(sqlite3)
 BuildRequires: pkgconfig(libtzplatform-config)
 BuildRequires: pkgconfig(key-manager)
 BuildRequires: pkgconfig(libnl-2.0)
+BuildRequires: gcov
 Requires:              vconf
 Requires:              connman
 Requires:              systemd
@@ -82,7 +83,7 @@ TIZEN Network Configuration service extension for HAL test.
 cmake -DCMAKE_INSTALL_PREFIX=%{_prefix} \
        -DTIZEN_WLAN_PASSPOINT=1 \
        -DTIZEN_WLAN_USE_P2P_INTERFACE=1 \
-       -DTIZEN_DEBUG_ENABLE=1 \
+       -DTIZEN_DEBUG_ENABLE=0 \
        -DTIZEN_WEARABLE=1 \
        -DTIZEN_CAPTIVE_PORTAL=1 \
        -DLIB_PATH=%{_lib} \
@@ -101,7 +102,7 @@ make %{?_smp_mflags}
 cmake -DCMAKE_INSTALL_PREFIX=%{_prefix} \
        -DTIZEN_WLAN_PASSPOINT=1 \
        -DTIZEN_WLAN_USE_P2P_INTERFACE=1 \
-       -DTIZEN_DEBUG_ENABLE=1 \
+       -DTIZEN_DEBUG_ENABLE=0 \
        -DTIZEN_WEARABLE=0 \
        -DTIZEN_CAPTIVE_PORTAL=0 \
        -DLIB_PATH=%{_lib} \
@@ -224,7 +225,7 @@ mv %{_unitdir}/net-config.service.tv %{_unitdir}/net-config.service
 %endif
 
 %files profile_tv
-%attr(644,network_fw,network_fw) %{_libdir}/udev/rules.d/99-wifiusb-dev.rules
+%attr(644,root,root) %{_libdir}/udev/rules.d/99-wifiusb-dev.rules
 %attr(644,root,root) %{_libdir}/systemd/system/net-config.service.tv
 %if "%{?_lib}" == "lib64"
 %attr(644,root,root) %{_unitdir}/net-config.service.tv
@@ -253,5 +254,5 @@ mv net-config.wearable net-config
 
 %files haltests
 %manifest net-config.manifest
-%{_bindir}/*hal_tc
+%{_bindir}/*haltests