Add battery monitor framework
[platform/core/connectivity/net-config.git] / packaging / net-config.spec
index 32eaacc..0dd7a68 100755 (executable)
@@ -1,6 +1,6 @@
 Name:          net-config
 Summary:       TIZEN Network Configuration service
-Version:       1.1.146
+Version:       1.1.147
 Release:       3
 Group:         System/Network
 License:       Apache-2.0
@@ -65,6 +65,19 @@ Requires:       %{name} = %{version}-%{release}
 %description plugin-telephony
 TIZEN Network Configuration service extension for telephony FW.
 
+%package plugin-stc
+Summary:        net-config extension for STC FW
+BuildRequires: pkgconfig(capi-network-stc)
+Requires:       %{name} = %{version}-%{release}
+%description plugin-stc
+TIZEN Network Configuration service extension for STC FW.
+
+%package plugin-battery
+Summary:        net-config extension for battery FW
+Requires:       %{name} = %{version}-%{release}
+%description plugin-battery
+TIZEN Network Configuration service extension for battery FW.
+
 %package haltests
 Summary:        net-config extension for HAL test
 BuildRequires: pkgconfig(gmock)
@@ -246,6 +259,14 @@ mv net-config.wearable net-config
 %manifest net-config.manifest
 %attr(500,network_fw,network_fw) %{_libdir}/net-config-plugin-telephony.so
 
+%files plugin-stc
+%manifest net-config.manifest
+%attr(500,network_fw,network_fw) %{_libdir}/net-config-plugin-stc.so
+
+%files plugin-battery
+%manifest net-config.manifest
+%attr(500,network_fw,network_fw) %{_libdir}/net-config-plugin-battery.so
+
 %files haltests
 %manifest net-config.manifest
 %{_bindir}/*haltests