Sync with the latest one
[platform/framework/web/livebox-cpp.git] / packaging / liblivebox-cpp.spec
index 4623b63..246912f 100644 (file)
@@ -2,10 +2,11 @@ Name: liblivebox-cpp
 Summary: C++ adaptor for a livebox 
 Version: 0.2.8
 Release: 1
+VCS:     magnolia/apps/livebox/livebox-cpp#livebox-cpp_0.2.4-19-g18d4a8671e59384424cf0c3c189e598a8ab2aed2
 Group: HomeTF/Livebox
-License: Flora License
+License: Flora
 Source0: %{name}-%{version}.tar.gz
-Source1001:    liblivebox-cpp.manifest
+Source1001: %{name}.manifest
 BuildRequires: cmake, gettext-tools, coreutils
 BuildRequires: pkgconfig(dlog)
 BuildRequires: pkgconfig(livebox)
@@ -16,7 +17,7 @@ BuildRequires: pkgconfig(livebox-service)
 Livebox development library (C++)
 
 %package devel
-Summary: Files for livebox development.
+Summary: Files for livebox development
 Group: Development/Libraries
 Requires: %{name} = %{version}-%{release}
 
@@ -28,6 +29,12 @@ Livebox development library (C++) (dev)
 cp %{SOURCE1001} .
 
 %build
+%if 0%{?sec_build_binary_debug_enable}
+export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
+export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
+export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
+%endif
+
 %if 0%{?tizen_build_binary_release_type_eng}
 export CFLAGS="${CFLAGS} -DTIZEN_ENGINEER_MODE"
 export CXXFLAGS="${CXXFLAGS} -DTIZEN_ENGINEER_MODE"