Merge tizen patch based on 1.12.2
[platform/upstream/gstreamer.git] / packaging / gst-omx.spec
index f251385..2ff2c82 100755 (executable)
@@ -4,30 +4,34 @@ Version:        1.3.0
 Release:        0
 License:        LGPL-2.1+
 Group:          Multimedia/Framework
-Source:        %{name}-%{version}.tar.gz
+Source0:        %{name}-%{version}.tar.gz
+Source100:      common.tar.gz
+Source1001:     gst-omx.manifest
 BuildRequires:  which
 BuildRequires:  pkgconfig(gstreamer-1.0)
 BuildRequires:  pkgconfig(gstreamer-plugins-base-1.0)
 BuildRequires: pkgconfig(libtbm)
 BuildRequires: pkgconfig(mm-common)
+ExclusiveArch: %arm aarch64
 
 %description
 gst-openmax is a GStreamer plug-in that allows communication with OpenMAX IL components.
 Multiple OpenMAX IL implementations can be used.
 
 %prep
-%setup -q -n %{name}-%{version}
+%setup -q
+%setup -q -T -D -a 100
+cp %{SOURCE1001} .
 
 %build
 ./autogen.sh --noconfigure
 
-export CFLAGS+=" -DEXYNOS_SPECIFIC"
-export CFLAGS+=" -DGST_TIZEN_MODIFICATION"
+export CFLAGS+=" -DTIZEN_FEATURE_OMX"
 
 %ifarch aarch64
 %configure --disable-static --prefix=/usr --with-omx-target=exynos64
 %else
-%configure --disable-static --prefix=/usr --with-omx-target=exynos
+%configure --disable-static --prefix=/usr --with-omx-target=exynos --enable-vp8 --enable-hevc
 %endif
 
 make %{?jobs:-j%jobs}
@@ -35,14 +39,11 @@ make %{?jobs:-j%jobs}
 
 %install
 rm -rf %{buildroot}
-mkdir -p %{buildroot}/usr/share/license
-cp COPYING %{buildroot}/usr/share/license/%{name}
 %make_install
 
 %files
 %manifest gst-omx.manifest
 %defattr(-,root,root,-)
 %{_libdir}/gstreamer-1.0/libgstomx.so
-/etc/xdg/gstomx.conf
-/usr/share/license/%{name}
+%license COPYING