Add -fno-stack-protector to fix gummiboot build
[platform/upstream/gnu-efi.git] / packaging / gnu-efi.spec
index 119246c..a778ad3 100644 (file)
@@ -6,7 +6,9 @@ Summary:        EFI development environment
 Url:            http://sourceforge.net/projects/gnu-efi/
 Group:          System/Boot
 Source0:        http://download.sourceforge.net/%{name}/%{name}_%{version}.orig.tar.gz
+Source1001:    gnu-efi.manifest
 BuildRequires:  pciutils
+ExclusiveArch:  %ix86 x86_64
 
 
 %description
@@ -14,14 +16,18 @@ gnu-efi is a library for building EFI applications
 
 %prep
 %setup -q -n %{name}-%{version}
+cp %{SOURCE1001} .
 
 %build
+export CFLAGS+=" -fno-stack-protector "
+export CXXFLAGS+=" -fno-stack-protector "
 make
 
 %install
 make install PREFIX=%{_prefix} INSTALLROOT=%{buildroot}
 
 %files
+%manifest %{name}.manifest
 %defattr(-,root,root)
 %{_includedir}/efi/*
 %{_prefix}/lib/*