packaging: bump to 2.24.90
[platform/upstream/binutils.git] / packaging / cross-i386-binutils.spec
index 0209e5f..c34ff70 100644 (file)
@@ -12,7 +12,7 @@ BuildRequires:  bc
 BuildRequires:  makeinfo
 BuildRequires:  zlib-devel-static
 Requires(pre):  update-alternatives
-Version:        2.23.1
+Version:        2.24.90
 Release:        0
 #
 # RUN_TESTS
@@ -23,7 +23,7 @@ Release:        0
 #
 # handle test suite failures
 #
-%ifarch alpha %arm hppa mips sh4 %sparc
+%ifarch alpha %arm aarch64 hppa mips sh4 %sparc
 %define        make_check_handling     true
 %else
 # XXX check again
@@ -35,36 +35,23 @@ Release:        0
 %define        make_check_handling     false
 %endif
 # handle all binary object formats supported by SuSE (and a few more)
-%ifarch %ix86 %arm ia64 ppc ppc64 s390 s390x x86_64
+%ifarch %ix86 %arm aarch64 ia64 ppc ppc64 s390 s390x x86_64
 %define build_multitarget 1
 %else
 %define build_multitarget 0
 %endif
-%define target_list alpha armv5l armv7l armv8l hppa hppa64 i686 ia64 m68k mips powerpc powerpc64 s390 s390x sh4 sparc sparc64 x86_64
+%define target_list aarch64 alpha armv5l armv7l armv8l hppa hppa64 i686 ia64 m68k mips powerpc powerpc64 s390 s390x sh4 sparc sparc64 x86_64
 #
 #
 #
 Url:            http://www.gnu.org/software/binutils/
-%define binutils_version %(echo %version | sed 's/\\.[0-9]\\{8\\}$//')
+#%define binutils_version %(echo %version | sed 's/\\.[0-9]\\{8\\}$//')
 Summary:        GNU Binutils
 License:        GFDL-1.3 and GPL-3.0+
-Group:          Development/Tools/Building
-Source:         binutils-%{binutils_version}.tar.bz2
+Group:          Development/Building
+Source:         binutils-%{version}.tar.bz2
 Source1:        pre_checkin.sh
 Source3:        baselibs.conf
-# Patches auto-generated by git-buildpackage:
-Patch0:     0001-skip-rpaths.patch
-Patch1:     0002-x86-64-biarch.patch
-Patch2:     0003-unit-at-a-time.patch
-Patch3:     0004-ld-dtags.patch
-Patch4:     0005-ld-relro.patch
-Patch5:     0006-testsuite.patch
-Patch6:     0007-enable-targets-gold.patch
-Patch7:     0008-use-hashtype-both-by-default.patch
-Patch8:     0009-build-as-needed.patch
-Patch9:     0010-fixup-testcase-perturb.patch
-Patch10:    0011-gold-depend-on-opcodes.patch
-Patch11:    0012-bso12451.patch
 
 %description
 C compiler utilities: ar, as, gprof, ld, nm, objcopy, objdump, ranlib,
@@ -75,10 +62,10 @@ to compile a program or kernel.
 %package gold
 Summary:        The gold linker
 License:        GPL-3.0+
-Group:          Development/Tools/Building
+Group:          Development/Building
 Requires:       binutils = %{version}-%{release}
 %if 0%{!?cross:1}
-%define gold_archs %ix86 %arm x86_64 ppc ppc64 %sparc
+%define gold_archs %ix86 %arm aarch64 x86_64 ppc ppc64 %sparc
 %endif
 
 %description gold
@@ -90,7 +77,7 @@ a drop-in replacement for the older GNU linker.
 %package devel
 Summary:        GNU binutils (BFD development files)
 License:        GPL-3.0+
-Group:          Development/Libraries/C and C++
+Group:          Development/Building
 Requires:       binutils = %{version}-%{release}
 Requires:       zlib-devel
 Provides:       binutils:/usr/include/bfd.h
@@ -110,31 +97,14 @@ binutils.
 
 %prep
 echo "make check will return with %{make_check_handling} in case of testsuite failures."
-%setup -q -n binutils-%{binutils_version}
-# 0001-skip-rpaths.patch
-%patch0 -p1
-# 0002-x86-64-biarch.patch
-%patch1 -p1
-# 0003-unit-at-a-time.patch
-%patch2 -p1
-# 0004-ld-dtags.patch
-%patch3 -p1
-# 0005-ld-relro.patch
-%patch4 -p1
-# 0006-testsuite.patch
-%patch5 -p1
-# 0007-enable-targets-gold.patch
-%patch6 -p1
-# 0008-use-hashtype-both-by-default.patch
-%patch7 -p1
-# 0009-build-as-needed.patch
-%patch8 -p1
-# 0010-fixup-testcase-perturb.patch
-%patch9 -p1
-# 0011-gold-depend-on-opcodes.patch
-%patch10 -p1
-# 0012-bso12451.patch
-%patch11 -p1
+%setup -q -n binutils-%{version}
+
+%if 0%{!?cross:1}
+%ifarch %arm
+ulimit -Hs unlimited
+ulimit -s unlimited
+%endif
+%endif
 
 sed -i -e '/BFD_VERSION_DATE/s/$/-%(echo %release | sed 's/\.[0-9]*$//')/' bfd/version.h
 %build
@@ -169,6 +139,9 @@ EXTRA_TARGETS="$EXTRA_TARGETS,spu-elf"
 %ifarch %arm
 EXTRA_TARGETS="$EXTRA_TARGETS,arm-tizen-linux-gnueabi"
 %endif
+%ifarch aarch64
+EXTRA_TARGETS="$EXTRA_TARGETS,aarch64-tizen-linux"
+%endif
 %endif
 %define common_flags CFLAGS="${RPM_OPT_FLAGS}" CXXFLAGS="${RPM_OPT_FLAGS}" \\\
        --prefix=%{_prefix} --libdir=%{_libdir} \\\
@@ -180,6 +153,12 @@ EXTRA_TARGETS="$EXTRA_TARGETS,arm-tizen-linux-gnueabi"
        --with-pic --build=%{HOST} 
 mkdir build-dir
 cd build-dir
+
+%ifarch %arm
+export CONFIG_SHELL="/bin/bash"
+export SHELL="/bin/bash"
+%endif
+
 ../configure %common_flags \
        ${EXTRA_TARGETS:+--enable-targets="${EXTRA_TARGETS#,}"} \
        --enable-plugins \
@@ -219,6 +198,9 @@ EXTRA_TARGETS="$EXTRA_TARGETS,hppa64-tizen-linux"
 %if "%{TARGET}" == "arm"
 EXTRA_TARGETS="$EXTRA_TARGETS,arm-tizen-linux-gnueabi"
 %endif
+%if "%{TARGET}" == "aarch64"
+EXTRA_TARGETS="$EXTRA_TARGETS,aarch64-tizen-linux"
+%endif
 %if "%{TARGET}" == "avr" || "%{TARGET}" == "spu"
 TARGET_OS=%{TARGET}
 %else
@@ -300,7 +282,6 @@ chmod a+x $RPM_BUILD_ROOT%{_libdir}/libopcodes-*
 rm $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.so
 rm $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.la
 # Remove unwanted files to shut up rpm
-rm $RPM_BUILD_ROOT%{_infodir}/configure* $RPM_BUILD_ROOT%{_infodir}/standards.info*
 rm $RPM_BUILD_ROOT%{_mandir}/man1/dlltool.1 $RPM_BUILD_ROOT%{_mandir}/man1/windres.1 $RPM_BUILD_ROOT%{_mandir}/man1/windmc.1
 cd ..
 #%find_lang binutils