Remove hardcoded path for multiuser support
[platform/framework/web/livebox-cpp.git] / packaging / liblivebox-cpp.spec
1 Name: liblivebox-cpp
2 Summary: C++ adaptor for a livebox 
3 Version: 0.2.8
4 Release: 1
5 VCS:     magnolia/apps/livebox/livebox-cpp#livebox-cpp_0.2.4-19-g18d4a8671e59384424cf0c3c189e598a8ab2aed2
6 Group: HomeTF/Livebox
7 License: Flora
8 Source0: %{name}-%{version}.tar.gz
9 Source1001: %{name}.manifest
10 BuildRequires: cmake, gettext-tools, coreutils
11 BuildRequires: pkgconfig(dlog)
12 BuildRequires: pkgconfig(livebox)
13 BuildRequires: pkgconfig(evas)
14 BuildRequires: pkgconfig(livebox-service)
15 BuildRequires: pkgconfig(libtzplatform-config)
16 Requires:      libtzplatform-config
17
18 %description
19 Livebox development library (C++)
20
21 %package devel
22 Summary: Files for livebox development
23 Group: Development/Libraries
24 Requires: %{name} = %{version}-%{release}
25
26 %description devel
27 Livebox development library (C++) (dev)
28
29 %prep
30 %setup -q
31 cp %{SOURCE1001} .
32
33 %build
34 %if 0%{?sec_build_binary_debug_enable}
35 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
36 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
37 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
38 %endif
39
40 %if 0%{?tizen_build_binary_release_type_eng}
41 export CFLAGS="${CFLAGS} -DTIZEN_ENGINEER_MODE"
42 export CXXFLAGS="${CXXFLAGS} -DTIZEN_ENGINEER_MODE"
43 export FFLAGS="${FFLAGS} -DTIZEN_ENGINEER_MODE"
44 %endif
45 %cmake .
46 make %{?jobs:-j%jobs}
47
48 %install
49 rm -rf %{buildroot}
50 %make_install
51 mkdir -p %{buildroot}/%{_datarootdir}/license
52
53 %post
54
55 %files -n liblivebox-cpp
56 %manifest %{name}.manifest
57 %defattr(-,root,root,-)
58 %{_libdir}/*.so*
59 %{_datarootdir}/license/*
60
61 %files devel
62 %manifest %{name}.manifest
63 %defattr(-,root,root,-)
64 %{_includedir}/livebox-cpp/livebox-cpp.h
65 %{_datarootdir}/doc/livebox-cpp/livebox-cpp_PG.h
66 %{_libdir}/pkgconfig/*.pc
67
68 # End of a file