Set license using %license
[platform/upstream/libexif.git] / packaging / libexif.spec
1 Name:           libexif
2 Version:        0.6.21
3 Release:        0
4 License:        LGPL-2.1+
5 Summary:        An EXIF Tag Parsing Library for Digital Cameras
6 Url:            http://libexif.sourceforge.net
7 Group:          System/Libraries
8 Source:         %{name}-%{version}.tar.bz2
9 Source1:        baselibs.conf
10 BuildRequires:  doxygen
11 BuildRequires:  pkg-config
12
13 %define debug_package_requires %{name} = %{version}-%{release}
14
15 %description
16 This library is used to parse EXIF information from JPEGs created by
17 digital cameras.
18
19 %package devel
20 Summary:        An EXIF Tag Parsing Library for Digital Cameras (Development files)
21 Group:          Development/Libraries/C and C++
22 Requires:       %{name} = %{version}
23 Requires:       glibc-devel
24
25 %description devel
26 This library is used to parse EXIF information from JPEGs created by
27 digital cameras.
28
29 %prep
30 %setup -q
31
32 %build
33 %configure --with-pic \
34         --disable-static \
35         --with-doc-dir=%{_docdir}/%{name}
36 make %{?_smp_mflags}
37
38 %check
39 make check
40
41 %install
42 %make_install
43 %find_lang %{name}-12
44
45 %post  -p /sbin/ldconfig
46
47 %postun  -p /sbin/ldconfig
48
49 %files -f %{name}-12.lang
50 %license COPYING
51 %defattr(-,root,root)
52 %{_libdir}/*.so.*
53
54 %files devel
55 %defattr(-,root,root)
56 %doc %{_docdir}/%{name}
57 %{_libdir}/*.so
58 %{_libdir}/pkgconfig/*.pc
59 %{_includedir}/*
60
61 %changelog