Merge branch 'tizen' into tizen_3.0
[platform/upstream/gstreamer.git] / packaging / gstreamer.spec
1 %define gst_branch 1.0
2
3 Name:           gstreamer
4 Version:        1.6.1
5 Release:        6
6 Summary:        Streaming-Media Framework Runtime
7 License:        LGPL-2.0+
8 Group:          Multimedia/Framework
9 Url:            http://gstreamer.freedesktop.org/
10 Source0:        http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-%{version}.tar.xz
11 Source100:      common.tar.gz
12 BuildRequires:  bison
13 BuildRequires:  gettext-tools
14 BuildRequires:  check-devel
15 BuildRequires:  fdupes
16 BuildRequires:  flex
17 BuildRequires:  pkgconfig(glib-2.0) >= 2.32.0
18 BuildRequires:  libtool
19 BuildRequires:  pkgconfig(libxml-2.0)
20 BuildRequires:  pkgconfig(gobject-introspection-1.0) >= 1.31.1
21 BuildRequires:  pkgconfig(dlog)
22
23 %description
24 GStreamer is a streaming-media framework, based on graphs of filters
25 which operate on media data. Applications using this library can do
26 anything from real-time sound processing to playing videos, and just
27 about anything else media-related.  Its plug-in-based architecture
28 means that new data types or processing capabilities can be added by
29 installing new plug-ins.
30
31 %package utils
32 Summary:        Streaming-Media Framework Runtime
33 Group:          Multimedia/Framework
34 Provides:       gstreamer:%{_bindir}/gst-launch-%{gst_branch} = %{version}
35 # Symbol for unversioned wrappers:
36 Provides:       gstreamer-utils_versioned = %{version}
37
38 %description utils
39 GStreamer is a streaming-media framework, based on graphs of filters
40 which operate on media data. Applications using this library can do
41 anything from real-time sound processing to playing videos, and just
42 about anything else media-related.  Its plug-in-based architecture
43 means that new data types or processing capabilities can be added by
44 installing new plug-ins.
45
46 %package devel
47 Summary:        Include Files and Libraries mandatory for Development
48 Group:          Development/Libraries
49 # gstreamer-utils is required for the gstreamer-provides rpm magic.
50 Requires:       gstreamer-utils = %{version}
51 Requires:       %{name} = %{version}
52
53 %description devel
54 This package contains all necessary include files and libraries needed
55 to develop applications that require these.
56
57 %lang_package
58
59 %prep
60 %setup -q -n gstreamer-%{version}
61 %setup -q -T -D -a 100
62
63 %build
64 # FIXME: GTKDOC_CFLAGS, GST_OBJ_CFLAGS:
65 # Silently ignored compilation of uninstalled gtk-doc scanners without RPM_OPT_FLAGS.
66 export V=1
67 NOCONFIGURE=1 ./autogen.sh
68 export CFLAGS="%{optflags} \
69         -DTIZEN_FEATURE_QUEUE2_MODIFICATION\
70         -DTIZEN_FEATURE_FILESINK_MODIFICATION\
71         -DTIZEN_FEATURE_MQ_MODIFICATION\
72         -DTIZEN_FEATURE_BASEPARSE_MODIFICATION\
73         -DTIZEN_FEATURE_QUEUE_MODIFICATION\
74 %if "%{?profile}" == "tv"
75         -DTIZEN_PROFILE_TV\
76 %endif
77         -fno-strict-aliasing"
78
79 %configure\
80 %if %{with introspection}
81         --enable-introspection\
82 %endif
83         --disable-static\
84         --disable-docbook\
85         --disable-gtk-doc\
86         --enable-dlog\
87 %if "%{?profile}" == "tv"
88         --enable-tv-profile\
89 %endif
90         --disable-examples\
91         --disable-tests
92 make %{?_smp_mflags}
93
94 %install
95 %make_install
96 mkdir -p %{buildroot}%{_datadir}/gstreamer-%{gst_branch}/presets
97 mkdir -p %{buildroot}%{_docdir}/%{name}
98 %find_lang %{name}-%{gst_branch}
99 mv %{name}-%{gst_branch}.lang %{name}.lang
100 rm -rf %{buildroot}%{_datadir}/gtk-doc
101 rm -rf %{buildroot}%{_docdir}/%{name}/manual
102 rm -rf %{buildroot}%{_docdir}/%{name}/pwg
103 mkdir -p %{buildroot}%{_datadir}/gstreamer-%{gst_branch}/presets
104 %fdupes %{buildroot}
105
106 %post -p /sbin/ldconfig
107
108 %postun -p /sbin/ldconfig
109
110 %files
111 %manifest %{name}.manifest
112 %defattr(-, root, root)
113 %license COPYING
114
115 %dir %{_datadir}/gstreamer-%{gst_branch}
116 %dir %{_datadir}/gstreamer-%{gst_branch}/presets
117 %dir %{_libdir}/gstreamer-%{gst_branch}
118 %{_libdir}/gstreamer-%{gst_branch}/*.so
119 %dir %{_libexecdir}/gstreamer-%{gst_branch}
120 %{_libdir}/gstreamer-%{gst_branch}/include/gst/gstconfig.h
121 %{_libexecdir}/gstreamer-%{gst_branch}/gst-plugin-scanner
122 %{_libexecdir}/gstreamer-%{gst_branch}/gst-ptp-helper
123 %{_libdir}/*.so.*
124 %{_libdir}/girepository-1.0/Gst-1.0.typelib
125 %{_libdir}/girepository-1.0/GstBase-1.0.typelib
126 %{_libdir}/girepository-1.0/GstCheck-1.0.typelib
127 %{_libdir}/girepository-1.0/GstController-1.0.typelib
128 %{_libdir}/girepository-1.0/GstNet-1.0.typelib
129
130 %files utils
131 %manifest %{name}.manifest
132 %defattr(-, root, root)
133 %{_bindir}/*-%{gst_branch}
134 %doc %{_mandir}/man?/*-%{gst_branch}.*
135
136 %files devel
137 %manifest %{name}.manifest
138 %defattr(-, root, root)
139 %{_datadir}/aclocal/*.m4
140 %{_includedir}/*
141 %{_libdir}/*.so
142 %{_libdir}/pkgconfig/*.pc
143 %{_datadir}/gir-1.0/*.gir
144
145 %changelog