6 Summary: Streaming-Media Framework Runtime
8 Group: Multimedia/Framework
9 Url: http://gstreamer.freedesktop.org/
10 Source0: http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-%{version}.tar.xz
11 Source100: common.tar.gz
13 BuildRequires: gettext-tools
14 BuildRequires: check-devel
17 BuildRequires: glib2-devel >= 2.32.0
18 BuildRequires: libtool
19 BuildRequires: libxml2-devel
20 BuildRequires: gobject-introspection-devel >= 1.31.1
21 BuildRequires: pkgconfig(dlog)
24 GStreamer is a streaming-media framework, based on graphs of filters
25 which operate on media data. Applications using this library can do
26 anything from real-time sound processing to playing videos, and just
27 about anything else media-related. Its plug-in-based architecture
28 means that new data types or processing capabilities can be added by
29 installing new plug-ins.
32 Summary: Streaming-Media Framework Runtime
33 Group: Multimedia/Framework
34 Provides: gstreamer:%{_bindir}/gst-launch-%{gst_branch} = %{version}
35 # Symbol for unversioned wrappers:
36 Provides: gstreamer-utils_versioned = %{version}
39 GStreamer is a streaming-media framework, based on graphs of filters
40 which operate on media data. Applications using this library can do
41 anything from real-time sound processing to playing videos, and just
42 about anything else media-related. Its plug-in-based architecture
43 means that new data types or processing capabilities can be added by
44 installing new plug-ins.
47 Summary: Include Files and Libraries mandatory for Development
48 Group: Development/Libraries
49 # gstreamer-utils is required for the gstreamer-provides rpm magic.
50 Requires: gstreamer-utils = %{version}
51 Requires: %{name} = %{version}
54 This package contains all necessary include files and libraries needed
55 to develop applications that require these.
60 %setup -q -n gstreamer-%{version}
61 %setup -q -T -D -a 100
64 # FIXME: GTKDOC_CFLAGS, GST_OBJ_CFLAGS:
65 # Silently ignored compilation of uninstalled gtk-doc scanners without RPM_OPT_FLAGS.
67 NOCONFIGURE=1 ./autogen.sh
68 export CFLAGS="%{optflags} \
69 -DGST_QUEUE2_MODIFICATION\
70 -DGST_EXT_CURRENT_BYTES\
71 -DGST_TIZEN_MODIFICATION\
75 %if %{with introspection}
76 --enable-introspection\
87 mkdir -p %{buildroot}%{_datadir}/gstreamer-%{gst_branch}/presets
88 mkdir -p %{buildroot}%{_docdir}/%{name}
89 %find_lang %{name}-%{gst_branch}
90 mv %{name}-%{gst_branch}.lang %{name}.lang
91 rm -rf %{buildroot}%{_datadir}/gtk-doc
92 rm -rf %{buildroot}%{_docdir}/%{name}/manual
93 rm -rf %{buildroot}%{_docdir}/%{name}/pwg
94 mkdir -p %{buildroot}%{_datadir}/gstreamer-%{gst_branch}/presets
97 %post -p /sbin/ldconfig
99 %postun -p /sbin/ldconfig
102 %manifest %{name}.manifest
103 %defattr(-, root, root)
106 %dir %{_datadir}/gstreamer-%{gst_branch}
107 %dir %{_datadir}/gstreamer-%{gst_branch}/presets
108 %dir %{_libdir}/gstreamer-%{gst_branch}
109 %{_libdir}/gstreamer-%{gst_branch}/*.so
110 %dir %{_libexecdir}/gstreamer-%{gst_branch}
111 %{_libdir}/gstreamer-%{gst_branch}/include/gst/gstconfig.h
112 %{_libexecdir}/gstreamer-%{gst_branch}/gst-plugin-scanner
113 %{_libexecdir}/gstreamer-%{gst_branch}/gst-ptp-helper
115 %{_libdir}/girepository-1.0/Gst-1.0.typelib
116 %{_libdir}/girepository-1.0/GstBase-1.0.typelib
117 %{_libdir}/girepository-1.0/GstCheck-1.0.typelib
118 %{_libdir}/girepository-1.0/GstController-1.0.typelib
119 %{_libdir}/girepository-1.0/GstNet-1.0.typelib
122 %manifest %{name}.manifest
123 %defattr(-, root, root)
124 %{_bindir}/*-%{gst_branch}
125 %doc %{_mandir}/man?/*-%{gst_branch}.*
128 %manifest %{name}.manifest
129 %defattr(-, root, root)
130 %{_datadir}/aclocal/*.m4
133 %{_libdir}/pkgconfig/*.pc
134 %{_datadir}/gir-1.0/*.gir