Remove unnecessary so file in development package
[platform/upstream/gstreamer.git] / packaging / gstreamer.spec
1 %define gst_branch 1.0
2
3 Name:           gstreamer
4 Version:        1.6.1
5 Release:        3
6 Summary:        Streaming-Media Framework Runtime
7 License:        LGPL-2.1+
8 Group:          Multimedia/Framework
9 Url:            http://gstreamer.freedesktop.org/
10 Source0:        http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-%{version}.tar.xz
11 Source100:      common.tar.gz
12 BuildRequires:  bison
13 BuildRequires:  gettext-tools
14 BuildRequires:  check-devel
15 BuildRequires:  fdupes
16 BuildRequires:  flex
17 BuildRequires:  glib2-devel >= 2.32
18 BuildRequires:  libtool
19 BuildRequires:  libxml2-devel
20 BuildRequires:  gobject-introspection-devel >= 1.31.1
21 BuildRequires:  pkgconfig(dlog)
22 BuildRequires:  gcc-c++
23 BuildRequires:  orc >= 0.4.16
24 BuildRequires:  python
25
26 %description
27 GStreamer is a streaming-media framework, based on graphs of filters
28 which operate on media data. Applications using this library can do
29 anything from real-time sound processing to playing videos, and just
30 about anything else media-related.  Its plug-in-based architecture
31 means that new data types or processing capabilities can be added by
32 installing new plug-ins.
33
34 %package utils
35 Summary:        Streaming-Media Framework Runtime
36 Group:          Multimedia/Framework
37 Provides:       gstreamer:%{_bindir}/gst-launch-%{gst_branch} = %{version}
38 # Symbol for unversioned wrappers:
39 Provides:       gstreamer-utils_versioned = %{version}
40
41 %description utils
42 GStreamer is a streaming-media framework, based on graphs of filters
43 which operate on media data. Applications using this library can do
44 anything from real-time sound processing to playing videos, and just
45 about anything else media-related.  Its plug-in-based architecture
46 means that new data types or processing capabilities can be added by
47 installing new plug-ins.
48
49 %package devel
50 Summary:        Include Files and Libraries mandatory for Development
51 Group:          Development/Libraries
52 # gstreamer-utils is required for the gstreamer-provides rpm magic.
53 Requires:       gstreamer-utils = %{version}
54 Requires:       %{name} = %{version}
55
56 %description devel
57 This package contains all necessary include files and libraries needed
58 to develop applications that require these.
59
60 %lang_package
61
62 %prep
63 %setup -q -n gstreamer-%{version}
64 %setup -q -T -D -a 100
65
66 %build
67 # FIXME: GTKDOC_CFLAGS, GST_OBJ_CFLAGS:
68 # Silently ignored compilation of uninstalled gtk-doc scanners without RPM_OPT_FLAGS.
69 export V=1
70 NOCONFIGURE=1 ./autogen.sh
71 export CFLAGS="%{optflags} \
72         -DGST_QUEUE2_MODIFICATION\
73         -DGST_EXT_CURRENT_BYTES\
74         -DGST_TIZEN_MODIFICATION\
75         -fno-strict-aliasing"
76
77 %configure\
78         --enable-introspection\
79         --disable-static\
80         --enable-dlog\
81         --disable-examples
82 make %{?_smp_mflags}
83
84 %install
85 %make_install
86 mkdir -p %{buildroot}%{_datadir}/gstreamer-%{gst_branch}/presets
87 mkdir -p %{buildroot}%{_docdir}/%{name}
88 %find_lang %{name}-%{gst_branch}
89 mv %{name}-%{gst_branch}.lang %{name}.lang
90 rm -rf %{buildroot}%{_datadir}/gtk-doc
91 rm -rf %{buildroot}%{_docdir}/%{name}/manual
92 rm -rf %{buildroot}%{_docdir}/%{name}/pwg
93 mkdir -p %{buildroot}%{_datadir}/gstreamer-%{gst_branch}/presets
94 %fdupes %{buildroot}
95
96 %post -p /sbin/ldconfig
97
98 %postun -p /sbin/ldconfig
99
100 %files
101 %manifest %{name}.manifest
102 %license COPYING
103
104 %dir %{_datadir}/gstreamer-%{gst_branch}
105 %dir %{_datadir}/gstreamer-%{gst_branch}/presets
106 %dir %{_libdir}/gstreamer-%{gst_branch}
107 %dir %{_libexecdir}/gstreamer-%{gst_branch}
108
109 %define so_version so.0.601.0
110 %define so_version_debug %{so_version}.debug
111 %define _lib_gstreamer_dir %{_libdir}/gstreamer-%{gst_branch}
112
113 %{_lib_gstreamer_dir}/libgstcoreelements.so
114
115 %{_libdir}/libgstbase-%{gst_branch}.so
116 %{_libdir}/libgstcheck-%{gst_branch}.so
117 %{_libdir}/libgstcontroller-%{gst_branch}.so
118 %{_libdir}/libgstnet-%{gst_branch}.so
119 %{_libdir}/libgstreamer-%{gst_branch}.so
120
121 %{_libdir}/libgstbase-%{gst_branch}.so.0
122 %{_libdir}/libgstcheck-%{gst_branch}.so.0
123 %{_libdir}/libgstcontroller-%{gst_branch}.so.0
124 %{_libdir}/libgstnet-%{gst_branch}.so.0
125 %{_libdir}/libgstreamer-%{gst_branch}.so.0
126
127 %{_libdir}/libgstbase-%{gst_branch}.%{so_version}
128 %{_libdir}/libgstcheck-%{gst_branch}.%{so_version}
129 %{_libdir}/libgstcontroller-%{gst_branch}.%{so_version}
130 %{_libdir}/libgstnet-%{gst_branch}.%{so_version}
131 %{_libdir}/libgstreamer-%{gst_branch}.%{so_version}
132
133 %{_libdir}/girepository-1.0/Gst-%{gst_branch}.typelib
134 %{_libdir}/girepository-1.0/GstBase-%{gst_branch}.typelib
135 %{_libdir}/girepository-1.0/GstCheck-%{gst_branch}.typelib
136 %{_libdir}/girepository-1.0/GstController-%{gst_branch}.typelib
137 %{_libdir}/girepository-1.0/GstNet-%{gst_branch}.typelib
138
139 %{_lib_gstreamer_dir}/include/gst/gstconfig.h
140 %{_libexecdir}/gstreamer-%{gst_branch}/gst-plugin-scanner
141 %{_libexecdir}/gstreamer-%{gst_branch}/gst-ptp-helper
142
143 %files utils
144 %manifest %{name}.manifest
145 %{_bindir}/gst-inspect-%{gst_branch}
146 %{_bindir}/gst-launch-%{gst_branch}
147 %{_bindir}/gst-typefind-%{gst_branch}
148
149 %doc %{_mandir}/man?/*-%{gst_branch}.*
150
151 %define _gstinclude_dir %{_includedir}/gstreamer-%{gst_branch}/gst
152
153 %files devel
154 %manifest %{name}.manifest
155
156 %{_libdir}/libgstbase-%{gst_branch}.so
157 %{_libdir}/libgstcheck-%{gst_branch}.so
158 %{_libdir}/libgstcontroller-%{gst_branch}.so
159 %{_libdir}/libgstnet-%{gst_branch}.so
160 %{_libdir}/libgstreamer-%{gst_branch}.so
161
162 %{_libdir}/pkgconfig/gstreamer-%{gst_branch}.pc
163 %{_libdir}/pkgconfig/gstreamer-base-%{gst_branch}.pc
164 %{_libdir}/pkgconfig/gstreamer-check-%{gst_branch}.pc
165 %{_libdir}/pkgconfig/gstreamer-controller-%{gst_branch}.pc
166 %{_libdir}/pkgconfig/gstreamer-net-%{gst_branch}.pc
167
168 %{_datadir}/aclocal/gst-element-check-1.0.m4
169
170 %define gir_dir gir-%{gst_branch}
171
172 %{_datadir}/%{gir_dir}/Gst-%{gst_branch}.gir
173 %{_datadir}/%{gir_dir}/GstBase-%{gst_branch}.gir
174 %{_datadir}/%{gir_dir}/GstCheck-%{gst_branch}.gir
175 %{_datadir}/%{gir_dir}/GstController-%{gst_branch}.gir
176 %{_datadir}/%{gir_dir}/GstNet-%{gst_branch}.gir
177
178 %{_gstinclude_dir}/base/base.h
179 %{_gstinclude_dir}/base/gstadapter.h
180 %{_gstinclude_dir}/base/gstbaseparse.h
181 %{_gstinclude_dir}/base/gstbasesink.h
182 %{_gstinclude_dir}/base/gstbasesrc.h
183 %{_gstinclude_dir}/base/gstbasetransform.h
184 %{_gstinclude_dir}/base/gstbitreader.h
185 %{_gstinclude_dir}/base/gstbytereader.h
186 %{_gstinclude_dir}/base/gstbytewriter.h
187 %{_gstinclude_dir}/base/gstcollectpads.h
188 %{_gstinclude_dir}/base/gstdataqueue.h
189 %{_gstinclude_dir}/base/gstflowcombiner.h
190 %{_gstinclude_dir}/base/gstpushsrc.h
191 %{_gstinclude_dir}/base/gstqueuearray.h
192 %{_gstinclude_dir}/base/gsttypefindhelper.h
193 %{_gstinclude_dir}/check/check.h
194 %{_gstinclude_dir}/check/gstbufferstraw.h
195 %{_gstinclude_dir}/check/gstcheck.h
196 %{_gstinclude_dir}/check/gstconsistencychecker.h
197 %{_gstinclude_dir}/check/gstharness.h
198 %{_gstinclude_dir}/check/gsttestclock.h
199 %{_gstinclude_dir}/check/internal-check.h
200 %{_gstinclude_dir}/controller/controller.h
201 %{_gstinclude_dir}/controller/gstargbcontrolbinding.h
202 %{_gstinclude_dir}/controller/gstdirectcontrolbinding.h
203 %{_gstinclude_dir}/controller/gstinterpolationcontrolsource.h
204 %{_gstinclude_dir}/controller/gstlfocontrolsource.h
205 %{_gstinclude_dir}/controller/gsttimedvaluecontrolsource.h
206 %{_gstinclude_dir}/controller/gsttriggercontrolsource.h
207 %{_gstinclude_dir}/glib-compat.h
208 %{_gstinclude_dir}/gst.h
209 %{_gstinclude_dir}/gstallocator.h
210 %{_gstinclude_dir}/gstatomicqueue.h
211 %{_gstinclude_dir}/gstbin.h
212 %{_gstinclude_dir}/gstbuffer.h
213 %{_gstinclude_dir}/gstbufferlist.h
214 %{_gstinclude_dir}/gstbufferpool.h
215 %{_gstinclude_dir}/gstbus.h
216 %{_gstinclude_dir}/gstcaps.h
217 %{_gstinclude_dir}/gstcapsfeatures.h
218 %{_gstinclude_dir}/gstchildproxy.h
219 %{_gstinclude_dir}/gstclock.h
220 %{_gstinclude_dir}/gstcompat.h
221 %{_gstinclude_dir}/gstcontext.h
222 %{_gstinclude_dir}/gstcontrolbinding.h
223 %{_gstinclude_dir}/gstcontrolsource.h
224 %{_gstinclude_dir}/gstdatetime.h
225 %{_gstinclude_dir}/gstdebugutils.h
226 %{_gstinclude_dir}/gstdevice.h
227 %{_gstinclude_dir}/gstdevicemonitor.h
228 %{_gstinclude_dir}/gstdeviceprovider.h
229 %{_gstinclude_dir}/gstdeviceproviderfactory.h
230 %{_gstinclude_dir}/gstelement.h
231 %{_gstinclude_dir}/gstelementfactory.h
232 %{_gstinclude_dir}/gstelementmetadata.h
233 %{_gstinclude_dir}/gstenumtypes.h
234 %{_gstinclude_dir}/gsterror.h
235 %{_gstinclude_dir}/gstevent.h
236 %{_gstinclude_dir}/gstformat.h
237 %{_gstinclude_dir}/gstghostpad.h
238 %{_gstinclude_dir}/gstinfo.h
239 %{_gstinclude_dir}/gstiterator.h
240 %{_gstinclude_dir}/gstmacros.h
241 %{_gstinclude_dir}/gstmemory.h
242 %{_gstinclude_dir}/gstmessage.h
243 %{_gstinclude_dir}/gstmeta.h
244 %{_gstinclude_dir}/gstminiobject.h
245 %{_gstinclude_dir}/gstobject.h
246 %{_gstinclude_dir}/gstpad.h
247 %{_gstinclude_dir}/gstpadtemplate.h
248 %{_gstinclude_dir}/gstparamspecs.h
249 %{_gstinclude_dir}/gstparse.h
250 %{_gstinclude_dir}/gstpipeline.h
251 %{_gstinclude_dir}/gstplugin.h
252 %{_gstinclude_dir}/gstpluginfeature.h
253 %{_gstinclude_dir}/gstpoll.h
254 %{_gstinclude_dir}/gstpreset.h
255 %{_gstinclude_dir}/gstprotection.h
256 %{_gstinclude_dir}/gstquery.h
257 %{_gstinclude_dir}/gstregistry.h
258 %{_gstinclude_dir}/gstsample.h
259 %{_gstinclude_dir}/gstsegment.h
260 %{_gstinclude_dir}/gststructure.h
261 %{_gstinclude_dir}/gstsystemclock.h
262 %{_gstinclude_dir}/gsttaglist.h
263 %{_gstinclude_dir}/gsttagsetter.h
264 %{_gstinclude_dir}/gsttask.h
265 %{_gstinclude_dir}/gsttaskpool.h
266 %{_gstinclude_dir}/gsttoc.h
267 %{_gstinclude_dir}/gsttocsetter.h
268 %{_gstinclude_dir}/gsttypefind.h
269 %{_gstinclude_dir}/gsttypefindfactory.h
270 %{_gstinclude_dir}/gsturi.h
271 %{_gstinclude_dir}/gstutils.h
272 %{_gstinclude_dir}/gstvalue.h
273 %{_gstinclude_dir}/gstversion.h
274 %{_gstinclude_dir}/math-compat.h
275 %{_gstinclude_dir}/net/gstnet.h
276 %{_gstinclude_dir}/net/gstnetaddressmeta.h
277 %{_gstinclude_dir}/net/gstnetclientclock.h
278 %{_gstinclude_dir}/net/gstnetcontrolmessagemeta.h
279 %{_gstinclude_dir}/net/gstnettimepacket.h
280 %{_gstinclude_dir}/net/gstnettimeprovider.h
281 %{_gstinclude_dir}/net/gstptpclock.h
282 %{_gstinclude_dir}/net/net.h
283
284 %changelog