[filesink] Add property current_byte
[platform/upstream/gstreamer.git] / packaging / gstreamer.spec
1 %define gst_branch 1.0
2
3 Name:           gstreamer
4 Version:        1.4.1
5 Release:        1
6 Summary:        Streaming-Media Framework Runtime
7 License:        LGPL-2.1+
8 Group:          Multimedia/Framework
9 Url:            http://gstreamer.freedesktop.org/
10 Source0:        http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-%{version}.tar.xz
11 Source100:      common.tar.bz2
12 BuildRequires:  bison
13 BuildRequires:  gettext-tools
14 BuildRequires:  check-devel
15 BuildRequires:  fdupes
16 BuildRequires:  flex
17 BuildRequires:  glib2-devel >= 2.32.0
18 BuildRequires:  libtool
19 BuildRequires:  libxml2-devel
20 BuildRequires:  gobject-introspection-devel >= 1.31.1
21
22 %description
23 GStreamer is a streaming-media framework, based on graphs of filters
24 which operate on media data. Applications using this library can do
25 anything from real-time sound processing to playing videos, and just
26 about anything else media-related.  Its plug-in-based architecture
27 means that new data types or processing capabilities can be added by
28 installing new plug-ins.
29
30
31 %package utils
32 Summary:        Streaming-Media Framework Runtime
33 Group:          Multimedia/Framework
34 Provides:       gstreamer:%{_bindir}/gst-launch-%{gst_branch} = %{version}
35 # Symbol for unversioned wrappers:
36 Provides:       gstreamer-utils_versioned = %{version}
37
38 %description utils
39 GStreamer is a streaming-media framework, based on graphs of filters
40 which operate on media data. Applications using this library can do
41 anything from real-time sound processing to playing videos, and just
42 about anything else media-related.  Its plug-in-based architecture
43 means that new data types or processing capabilities can be added by
44 installing new plug-ins.
45
46
47 %package devel
48 Summary:        Include Files and Libraries mandatory for Development
49 Group:          Development/Libraries
50 # gstreamer-utils is required for the gstreamer-provides rpm magic.
51 Requires:       gstreamer-utils = %{version}
52 Requires:       %{name} = %{version}
53
54 %description devel
55 This package contains all necessary include files and libraries needed
56 to develop applications that require these.
57
58
59 %lang_package
60
61
62 %prep
63 %setup -q -n gstreamer-%{version}
64 %setup -q -T -D -a 100
65
66
67 %build
68 # FIXME: GTKDOC_CFLAGS, GST_OBJ_CFLAGS:
69 # Silently ignored compilation of uninstalled gtk-doc scanners without RPM_OPT_FLAGS.
70 export V=1
71 NOCONFIGURE=1 ./autogen.sh
72 export CFLAGS="%{optflags} \
73         -DGST_QUEUE2_MODIFICATION\
74         -DGST_EXT_CURRENT_BYTES\
75         -fno-strict-aliasing"
76 %configure\
77 %if %{with introspection}
78         --enable-introspection\
79 %endif
80         --disable-static
81 make %{?_smp_mflags}
82
83
84 %install
85 %make_install
86 mkdir -p %{buildroot}%{_datadir}/gstreamer-%{gst_branch}/presets
87 mkdir -p %{buildroot}%{_docdir}/%{name}
88 %find_lang %{name}-%{gst_branch}
89 mv %{name}-%{gst_branch}.lang %{name}.lang
90 rm -rf %{buildroot}%{_datadir}/gtk-doc
91 rm -rf %{buildroot}%{_docdir}/%{name}/manual
92 rm -rf %{buildroot}%{_docdir}/%{name}/pwg
93 mkdir -p %{buildroot}%{_datadir}/gstreamer-%{gst_branch}/presets
94 %fdupes %{buildroot}
95
96
97 %post -p /sbin/ldconfig
98
99
100 %postun -p /sbin/ldconfig
101
102
103 %files
104 %manifest %{name}.manifest
105 %defattr(-, root, root)
106 %license COPYING
107 %dir %{_datadir}/gstreamer-%{gst_branch}
108 %dir %{_datadir}/gstreamer-%{gst_branch}/presets
109 %dir %{_libdir}/gstreamer-%{gst_branch}
110 %{_libdir}/gstreamer-%{gst_branch}/*.so
111 %dir %{_libexecdir}/gstreamer-%{gst_branch}
112 %{_libexecdir}/gstreamer-%{gst_branch}/gst-plugin-scanner
113 %{_libdir}/*.so.*
114 %{_libdir}/girepository-1.0/Gst-1.0.typelib
115 %{_libdir}/girepository-1.0/GstBase-1.0.typelib
116 %{_libdir}/girepository-1.0/GstCheck-1.0.typelib
117 %{_libdir}/girepository-1.0/GstController-1.0.typelib
118 %{_libdir}/girepository-1.0/GstNet-1.0.typelib
119
120
121 %files utils
122 %manifest %{name}.manifest
123 %defattr(-, root, root)
124 %{_bindir}/*-%{gst_branch}
125 %doc %{_mandir}/man?/*-%{gst_branch}.*
126
127
128 %files devel
129 %manifest %{name}.manifest
130 %defattr(-, root, root)
131 %{_datadir}/aclocal/*.m4
132 %{_includedir}/*
133 %{_libdir}/*.so
134 %{_libdir}/pkgconfig/*.pc
135 %{_datadir}/gir-1.0/*.gir
136
137 %changelog