baseparse: Make possible update of audio duration at the prepare state
[platform/upstream/gstreamer.git] / packaging / gstreamer.spec
1 %define gst_branch 1.0
2
3 Name:           gstreamer
4 Version:        1.6.1
5 Release:        3
6 Summary:        Streaming-Media Framework Runtime
7 License:        LGPL-2.1+
8 Group:          Multimedia/Framework
9 Url:            http://gstreamer.freedesktop.org/
10 Source0:        http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-%{version}.tar.xz
11 Source100:      common.tar.gz
12 BuildRequires:  bison
13 BuildRequires:  gettext-tools
14 BuildRequires:  check-devel
15 BuildRequires:  fdupes
16 BuildRequires:  flex
17 BuildRequires:  glib2-devel >= 2.32.0
18 BuildRequires:  libtool
19 BuildRequires:  libxml2-devel
20 BuildRequires:  gobject-introspection-devel >= 1.31.1
21 BuildRequires:  pkgconfig(dlog)
22
23 %description
24 GStreamer is a streaming-media framework, based on graphs of filters
25 which operate on media data. Applications using this library can do
26 anything from real-time sound processing to playing videos, and just
27 about anything else media-related.  Its plug-in-based architecture
28 means that new data types or processing capabilities can be added by
29 installing new plug-ins.
30
31 %package utils
32 Summary:        Streaming-Media Framework Runtime
33 Group:          Multimedia/Framework
34 Provides:       gstreamer:%{_bindir}/gst-launch-%{gst_branch} = %{version}
35 # Symbol for unversioned wrappers:
36 Provides:       gstreamer-utils_versioned = %{version}
37
38 %description utils
39 GStreamer is a streaming-media framework, based on graphs of filters
40 which operate on media data. Applications using this library can do
41 anything from real-time sound processing to playing videos, and just
42 about anything else media-related.  Its plug-in-based architecture
43 means that new data types or processing capabilities can be added by
44 installing new plug-ins.
45
46 %package devel
47 Summary:        Include Files and Libraries mandatory for Development
48 Group:          Development/Libraries
49 # gstreamer-utils is required for the gstreamer-provides rpm magic.
50 Requires:       gstreamer-utils = %{version}
51 Requires:       %{name} = %{version}
52
53 %description devel
54 This package contains all necessary include files and libraries needed
55 to develop applications that require these.
56
57 %lang_package
58
59 %prep
60 %setup -q -n gstreamer-%{version}
61 %setup -q -T -D -a 100
62
63 %build
64 # FIXME: GTKDOC_CFLAGS, GST_OBJ_CFLAGS:
65 # Silently ignored compilation of uninstalled gtk-doc scanners without RPM_OPT_FLAGS.
66 export V=1
67 NOCONFIGURE=1 ./autogen.sh
68 export CFLAGS="%{optflags} \
69         -DGST_QUEUE2_MODIFICATION\
70         -DGST_EXT_CURRENT_BYTES\
71         -DGST_TIZEN_MODIFICATION\
72         -DGST_BASEPARSE_MODIFICATION\
73         -fno-strict-aliasing"
74
75 %configure\
76 %if %{with introspection}
77         --enable-introspection\
78 %endif
79         --disable-static\
80         --disable-docbook\
81         --disable-gtk-doc\
82         --enable-dlog\
83         --disable-examples
84 make %{?_smp_mflags}
85
86 %install
87 %make_install
88 mkdir -p %{buildroot}%{_datadir}/gstreamer-%{gst_branch}/presets
89 mkdir -p %{buildroot}%{_docdir}/%{name}
90 %find_lang %{name}-%{gst_branch}
91 mv %{name}-%{gst_branch}.lang %{name}.lang
92 rm -rf %{buildroot}%{_datadir}/gtk-doc
93 rm -rf %{buildroot}%{_docdir}/%{name}/manual
94 rm -rf %{buildroot}%{_docdir}/%{name}/pwg
95 mkdir -p %{buildroot}%{_datadir}/gstreamer-%{gst_branch}/presets
96 %fdupes %{buildroot}
97
98 %post -p /sbin/ldconfig
99
100 %postun -p /sbin/ldconfig
101
102 %files
103 %manifest %{name}.manifest
104 %defattr(-, root, root)
105 %license COPYING
106
107 %dir %{_datadir}/gstreamer-%{gst_branch}
108 %dir %{_datadir}/gstreamer-%{gst_branch}/presets
109 %dir %{_libdir}/gstreamer-%{gst_branch}
110 %{_libdir}/gstreamer-%{gst_branch}/*.so
111 %dir %{_libexecdir}/gstreamer-%{gst_branch}
112 %{_libdir}/gstreamer-%{gst_branch}/include/gst/gstconfig.h
113 %{_libexecdir}/gstreamer-%{gst_branch}/gst-plugin-scanner
114 %{_libexecdir}/gstreamer-%{gst_branch}/gst-ptp-helper
115 %{_libdir}/*.so.*
116 %{_libdir}/girepository-1.0/Gst-1.0.typelib
117 %{_libdir}/girepository-1.0/GstBase-1.0.typelib
118 %{_libdir}/girepository-1.0/GstCheck-1.0.typelib
119 %{_libdir}/girepository-1.0/GstController-1.0.typelib
120 %{_libdir}/girepository-1.0/GstNet-1.0.typelib
121
122 %files utils
123 %manifest %{name}.manifest
124 %defattr(-, root, root)
125 %{_bindir}/*-%{gst_branch}
126 %doc %{_mandir}/man?/*-%{gst_branch}.*
127
128 %files devel
129 %manifest %{name}.manifest
130 %defattr(-, root, root)
131 %{_datadir}/aclocal/*.m4
132 %{_includedir}/*
133 %{_libdir}/*.so
134 %{_libdir}/pkgconfig/*.pc
135 %{_datadir}/gir-1.0/*.gir
136
137 %changelog