6 Summary: Streaming-Media Framework Runtime
8 Group: Multimedia/Framework
9 Url: http://gstreamer.freedesktop.org/
10 Source0: http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-%{version}.tar.xz
11 Source100: common.tar.gz
13 BuildRequires: gettext-tools
14 BuildRequires: check-devel
17 BuildRequires: pkgconfig(glib-2.0) >= 2.32.0
18 BuildRequires: libtool
19 BuildRequires: pkgconfig(libxml-2.0)
20 BuildRequires: pkgconfig(gobject-introspection-1.0) >= 1.31.1
21 BuildRequires: pkgconfig(dlog)
24 GStreamer is a streaming-media framework, based on graphs of filters
25 which operate on media data. Applications using this library can do
26 anything from real-time sound processing to playing videos, and just
27 about anything else media-related. Its plug-in-based architecture
28 means that new data types or processing capabilities can be added by
29 installing new plug-ins.
32 Summary: Streaming-Media Framework Runtime
33 Group: Multimedia/Framework
34 Provides: gstreamer:%{_bindir}/gst-launch-%{gst_branch} = %{version}
35 # Symbol for unversioned wrappers:
36 Provides: gstreamer-utils_versioned = %{version}
39 GStreamer is a streaming-media framework, based on graphs of filters
40 which operate on media data. Applications using this library can do
41 anything from real-time sound processing to playing videos, and just
42 about anything else media-related. Its plug-in-based architecture
43 means that new data types or processing capabilities can be added by
44 installing new plug-ins.
47 Summary: Include Files and Libraries mandatory for Development
48 Group: Development/Libraries
49 # gstreamer-utils is required for the gstreamer-provides rpm magic.
50 Requires: gstreamer-utils = %{version}
51 Requires: %{name} = %{version}
54 This package contains all necessary include files and libraries needed
55 to develop applications that require these.
60 %setup -q -n gstreamer-%{version}
61 %setup -q -T -D -a 100
64 # FIXME: GTKDOC_CFLAGS, GST_OBJ_CFLAGS:
65 # Silently ignored compilation of uninstalled gtk-doc scanners without RPM_OPT_FLAGS.
67 NOCONFIGURE=1 ./autogen.sh
68 export CFLAGS="%{optflags} \
69 -DTIZEN_FEATURE_QUEUE2_MODIFICATION\
70 -DTIZEN_FEATURE_FILESINK_MODIFICATION\
71 -DTIZEN_FEATURE_MQ_MODIFICATION\
72 -DTIZEN_FEATURE_MQ_MODIFICATION_EXTRA_SIZE_TIME\
73 -DTIZEN_FEATURE_BASEPARSE_MODIFICATION\
74 -DTIZEN_FEATURE_QUEUE_MODIFICATION\
75 %if "%{TIZEN_PRODUCT_TV}" == "1"
77 -DRVU_LIVESTREAMING_OPTIMIZATION\
78 -DTIZEN_FEATURE_TRUSTZONE\
80 -DTIZEN_FEATURE_RTSPSRC_MODIFICATION\
84 %if %{with introspection}
85 --enable-introspection\
91 %if "%{TIZEN_PRODUCT_TV}" == "1"
100 mkdir -p %{buildroot}%{_datadir}/gstreamer-%{gst_branch}/presets
101 mkdir -p %{buildroot}%{_docdir}/%{name}
102 %find_lang %{name}-%{gst_branch}
103 mv %{name}-%{gst_branch}.lang %{name}.lang
104 rm -rf %{buildroot}%{_datadir}/gtk-doc
105 rm -rf %{buildroot}%{_docdir}/%{name}/manual
106 rm -rf %{buildroot}%{_docdir}/%{name}/pwg
107 rm -rf %{buildroot}%{_libdir}/girepository-1.0/*.typelib
108 mkdir -p %{buildroot}%{_datadir}/gstreamer-%{gst_branch}/presets
111 %post -p /sbin/ldconfig
113 %postun -p /sbin/ldconfig
116 %manifest %{name}.manifest
117 %defattr(-, root, root)
120 %dir %{_datadir}/gstreamer-%{gst_branch}
121 %dir %{_datadir}/gstreamer-%{gst_branch}/presets
122 %dir %{_libdir}/gstreamer-%{gst_branch}
123 %{_libdir}/gstreamer-%{gst_branch}/*.so
124 %dir %{_libexecdir}/gstreamer-%{gst_branch}
125 %{_libdir}/gstreamer-%{gst_branch}/include/gst/gstconfig.h
126 %{_libexecdir}/gstreamer-%{gst_branch}/gst-plugin-scanner
127 %{_libexecdir}/gstreamer-%{gst_branch}/gst-ptp-helper
129 #%{_libdir}/girepository-1.0/Gst-1.0.typelib
130 #%{_libdir}/girepository-1.0/GstBase-1.0.typelib
131 #%{_libdir}/girepository-1.0/GstCheck-1.0.typelib
132 #%{_libdir}/girepository-1.0/GstController-1.0.typelib
133 #%{_libdir}/girepository-1.0/GstNet-1.0.typelib
136 %manifest %{name}.manifest
137 %defattr(-, root, root)
139 %{_bindir}/*-%{gst_branch}
140 %doc %{_mandir}/man?/*-%{gst_branch}.*
143 %manifest %{name}.manifest
144 %defattr(-, root, root)
145 %{_datadir}/aclocal/*.m4
148 %{_libdir}/pkgconfig/*.pc
149 %{_datadir}/gir-1.0/*.gir