add GST_QUERY_RESOURCE and interface functions
[platform/upstream/gstreamer.git] / packaging / gstreamer.spec
1 %define gst_branch 1.0
2
3 Name:           gstreamer
4 Version:        1.6.1
5 Release:        4
6 Summary:        Streaming-Media Framework Runtime
7 License:        LGPL-2.0+
8 Group:          Multimedia/Framework
9 Url:            http://gstreamer.freedesktop.org/
10 Source0:        http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-%{version}.tar.xz
11 Source100:      common.tar.gz
12 BuildRequires:  bison
13 BuildRequires:  gettext-tools
14 BuildRequires:  check-devel
15 BuildRequires:  fdupes
16 BuildRequires:  flex
17 BuildRequires:  pkgconfig(glib-2.0) >= 2.32.0
18 BuildRequires:  libtool
19 BuildRequires:  pkgconfig(libxml-2.0)
20 BuildRequires:  pkgconfig(gobject-introspection-1.0) >= 1.31.1
21 BuildRequires:  pkgconfig(dlog)
22
23 %description
24 GStreamer is a streaming-media framework, based on graphs of filters
25 which operate on media data. Applications using this library can do
26 anything from real-time sound processing to playing videos, and just
27 about anything else media-related.  Its plug-in-based architecture
28 means that new data types or processing capabilities can be added by
29 installing new plug-ins.
30
31 %package utils
32 Summary:        Streaming-Media Framework Runtime
33 Group:          Multimedia/Framework
34 Provides:       gstreamer:%{_bindir}/gst-launch-%{gst_branch} = %{version}
35 # Symbol for unversioned wrappers:
36 Provides:       gstreamer-utils_versioned = %{version}
37
38 %description utils
39 GStreamer is a streaming-media framework, based on graphs of filters
40 which operate on media data. Applications using this library can do
41 anything from real-time sound processing to playing videos, and just
42 about anything else media-related.  Its plug-in-based architecture
43 means that new data types or processing capabilities can be added by
44 installing new plug-ins.
45
46 %package devel
47 Summary:        Include Files and Libraries mandatory for Development
48 Group:          Development/Libraries
49 # gstreamer-utils is required for the gstreamer-provides rpm magic.
50 Requires:       gstreamer-utils = %{version}
51 Requires:       %{name} = %{version}
52
53 %description devel
54 This package contains all necessary include files and libraries needed
55 to develop applications that require these.
56
57 %lang_package
58
59 %prep
60 %setup -q -n gstreamer-%{version}
61 %setup -q -T -D -a 100
62
63 %build
64 # FIXME: GTKDOC_CFLAGS, GST_OBJ_CFLAGS:
65 # Silently ignored compilation of uninstalled gtk-doc scanners without RPM_OPT_FLAGS.
66 export V=1
67 NOCONFIGURE=1 ./autogen.sh
68 export CFLAGS="%{optflags} \
69         -DGST_QUEUE2_MODIFICATION\
70         -DGST_EXT_CURRENT_BYTES\
71         -DGST_TIZEN_MODIFICATION\
72         -DGST_BASEPARSE_MODIFICATION\
73         -DGST_QUEUE_MODIFICATION\
74         -DGST_MQ_MODIFICATION\
75 %if "%{?profile}" == "tv"
76         -DGST_TIZEN_TV\
77 %endif
78         -fno-strict-aliasing"
79
80 %configure\
81 %if %{with introspection}
82         --enable-introspection\
83 %endif
84         --disable-static\
85         --disable-docbook\
86         --disable-gtk-doc\
87         --enable-dlog\
88         --disable-examples
89 make %{?_smp_mflags}
90
91 %install
92 %make_install
93 mkdir -p %{buildroot}%{_datadir}/gstreamer-%{gst_branch}/presets
94 mkdir -p %{buildroot}%{_docdir}/%{name}
95 %find_lang %{name}-%{gst_branch}
96 mv %{name}-%{gst_branch}.lang %{name}.lang
97 rm -rf %{buildroot}%{_datadir}/gtk-doc
98 rm -rf %{buildroot}%{_docdir}/%{name}/manual
99 rm -rf %{buildroot}%{_docdir}/%{name}/pwg
100 mkdir -p %{buildroot}%{_datadir}/gstreamer-%{gst_branch}/presets
101 %fdupes %{buildroot}
102
103 %post -p /sbin/ldconfig
104
105 %postun -p /sbin/ldconfig
106
107 %files
108 %manifest %{name}.manifest
109 %defattr(-, root, root)
110 %license COPYING
111
112 %dir %{_datadir}/gstreamer-%{gst_branch}
113 %dir %{_datadir}/gstreamer-%{gst_branch}/presets
114 %dir %{_libdir}/gstreamer-%{gst_branch}
115 %{_libdir}/gstreamer-%{gst_branch}/*.so
116 %dir %{_libexecdir}/gstreamer-%{gst_branch}
117 %{_libdir}/gstreamer-%{gst_branch}/include/gst/gstconfig.h
118 %{_libexecdir}/gstreamer-%{gst_branch}/gst-plugin-scanner
119 %{_libexecdir}/gstreamer-%{gst_branch}/gst-ptp-helper
120 %{_libdir}/*.so.*
121 %{_libdir}/girepository-1.0/Gst-1.0.typelib
122 %{_libdir}/girepository-1.0/GstBase-1.0.typelib
123 %{_libdir}/girepository-1.0/GstCheck-1.0.typelib
124 %{_libdir}/girepository-1.0/GstController-1.0.typelib
125 %{_libdir}/girepository-1.0/GstNet-1.0.typelib
126
127 %files utils
128 %manifest %{name}.manifest
129 %defattr(-, root, root)
130 %{_bindir}/*-%{gst_branch}
131 %doc %{_mandir}/man?/*-%{gst_branch}.*
132
133 %files devel
134 %manifest %{name}.manifest
135 %defattr(-, root, root)
136 %{_datadir}/aclocal/*.m4
137 %{_includedir}/*
138 %{_libdir}/*.so
139 %{_libdir}/pkgconfig/*.pc
140 %{_datadir}/gir-1.0/*.gir
141
142 %changelog