[rtsp-mediafa-factory] Remove g_strdup of no use and add g_autofree
[platform/upstream/gstreamer.git] / packaging / gst-rtsp-server.spec
1 Name:       gst-rtsp-server
2 Summary:    Multimedia Framework Library
3 Version:    1.16.2
4 Release:    9
5 Url:        http://gstreamer.freedesktop.org/
6 Group:      System/Libraries
7 License:    LGPL-2.0+
8 Source:     http://gstreamer.freedesktop.org/src/gst-rtsp-server/gst-rtsp-server-%{version}.tar.xz
9 Source100:  common.tar.bz2
10 Requires(post):  /sbin/ldconfig
11 Requires(postun):  /sbin/ldconfig
12 BuildRequires:  pkgconfig(gstreamer-1.0)
13 BuildRequires:  pkgconfig(gstreamer-plugins-base-1.0)
14
15 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
16
17 %description
18
19 %package devel
20 Summary:    Multimedia Framework RTSP server library (DEV)
21 Group:      Development/Libraries
22 Requires:   %{name} = %{version}-%{release}
23
24 %description devel
25
26 %package factory
27 Summary:    Multimedia Framework RTSP server Library (Factory)
28 Group:      Development/Libraries
29 Requires:   %{name} = %{version}-%{release}
30
31 %description factory
32
33 %prep
34 %setup -q -n gst-rtsp-server-%{version}
35 %setup -q -T -D -a 100
36
37 %build
38
39 NOCONFIGURE=1 ./autogen.sh
40
41 CFLAGS+=" -DEXPORT_API=\"__attribute__((visibility(\\\"default\\\")))\" "; export CFLAGS
42 LDFLAGS+="-Wl,--rpath=%{_prefix}/lib -Wl,--hash-style=both -Wl,--as-needed"; export LDFLAGS
43
44 # always enable sdk build. This option should go away
45 # disable build examples.
46 %configure --disable-static --disable-examples
47
48 # Call make instruction with smp support
49 make %{?jobs:-j%jobs}
50
51 %install
52 rm -rf %{buildroot}
53 %make_install
54
55 %clean
56 rm -rf %{buildroot}
57
58 %post
59 /sbin/ldconfig
60
61 %postun
62 /sbin/ldconfig
63
64 %files
65 %manifest gst-rtsp-server.manifest
66 %defattr(-,root,root,-)
67 %license COPYING
68 %{_libdir}/*.so.*
69 %{_libdir}/gstreamer-1.0/libgstrtspclientsink.so
70
71 %files devel
72 %defattr(-,root,root,-)
73 %{_libdir}/*.so
74 %{_includedir}/gstreamer-1.0/gst/rtsp-server/rtsp-*.h
75 %{_includedir}/gstreamer-1.0/gst/rtsp-server/gstwfd*.h
76 %{_libdir}/pkgconfig/*