webrtcbin: Add netsim and drop-probability-sender properties
[platform/upstream/gstreamer.git] / packaging / gst-plugins-bad.spec
1 %bcond_with wayland
2 #%bcond_with x
3 %define gst_branch 1.0
4
5 Name:           gst-plugins-bad
6 Version:        1.16.2
7 Release:        28
8 Summary:        GStreamer Streaming-Media Framework Plug-Ins
9 License:        LGPL-2.0+
10 Group:          Multimedia/Framework
11 Url:            http://gstreamer.freedesktop.org/
12 Source:         http://gstreamer.freedesktop.org/src/gst-plugins-bad/%{name}-%{version}.tar.xz
13 Source100:      common.tar.gz
14 BuildRequires:  gettext-tools
15 BuildRequires:  autoconf
16 BuildRequires:  gcc-c++
17 BuildRequires:  pkgconfig(glib-2.0) >= 2.31.14
18 BuildRequires:  pkgconfig(gstreamer-1.0) >= 1.12.0
19 BuildRequires:  pkgconfig(gstreamer-plugins-base-1.0) >= 1.12.0
20 BuildRequires:  pkgconfig(orc-0.4) >= 0.4.11
21 BuildRequires:  python
22 BuildRequires:  xsltproc
23 BuildRequires:  pkgconfig(libusb-1.0)
24 BuildRequires:  pkgconfig(gio-2.0) >= 2.25.0
25 BuildRequires:  pkgconfig(libcurl) >= 7.21.0
26 BuildRequires:  pkgconfig(libexif) >= 0.6.16
27 BuildRequires:  pkgconfig(openssl1.1)
28 BuildRequires:  pkgconfig(sndfile) >= 1.0.16
29 BuildRequires:  pkgconfig(openal)
30 BuildRequires:  pkgconfig(soundtouch) > 1.4
31 BuildRequires:  pkgconfig(nice)
32 BuildRequires:  pkgconfig(usrsctp)
33 BuildRequires:  pkgconfig(libsrtp2) >= 2.1.0
34 BuildRequires:  pkgconfig(opus)
35 %if 0%{?webrtctest:1}
36 BuildRequires:  pkgconfig(json-glib-1.0)
37 BuildRequires:  pkgconfig(libsoup-2.4)
38 %endif
39 %if %{with wayland}
40 %if 0%{?enable_gl:1}
41 BuildRequires:  pkgconfig(gles20)
42 BuildRequires:  pkgconfig(wayland-egl) >= 9.0
43 %endif
44 BuildRequires:  pkgconfig(wayland-client) >= 1.0.0
45 BuildRequires:  pkgconfig(wayland-cursor) >= 1.0.0
46 BuildRequires:  pkgconfig(libxml-2.0)
47 %endif
48 %if %{with x}
49 BuildRequires:  pkgconfig(x11)
50 %endif
51 Requires:       gstreamer >= 1.12.0
52
53 %description
54 GStreamer is a streaming media framework based on graphs of filters
55 that operate on media data. Applications using this library can do
56 anything media-related,from real-time sound processing to playing
57 videos. Its plug-in-based architecture means that new data types or
58 processing capabilities can be added simply by installing new plug-ins.
59
60
61 %package devel
62 Summary:        GStreamer Streaming-Media Framework Plug-Ins
63 Requires: %{name} = %{version}-%{release}
64 Requires: gst-plugins-base-devel
65
66 %description devel
67 GStreamer is a streaming media framework based on graphs of filters
68 that operate on media data. Applications using this library can do
69 anything media-related,from real-time sound processing to playing
70 videos. Its plug-in-based architecture means that new data types or
71 processing capabilities can be added simply by installing new plug-ins.
72
73
74 %prep
75 %setup -q -n %{name}-%{version}
76 %setup -q -T -D -a 100
77
78 %build
79 export V=1
80 NOCONFIGURE=1 ./autogen.sh
81 export CFLAGS+=" -Wall -g -fPIC\
82   -DTIZEN_FEATURE_ADAPTIVE_MODIFICATION\
83   -DTIZEN_FEATURE_HLSDEMUX_PROPERTY\
84   -DTIZEN_FEATURE_HLSDEMUX_EMPTY_VTT\
85   -DTIZEN_FEATURE_HLSDEMUX_UPDATE_SEGMENT\
86   -DTIZEN_FEATURE_TSDEMUX_MODIFICATION\
87   -DTIZEN_FEATURE_TSDEMUX_INVALID_PCR_PID\
88   -DTIZEN_FEATURE_TSDEMUX_LANG_TAG\
89   -DTIZEN_FEATURE_TSDEMUX_UPDATE_PMT\
90   -DTIZEN_FEATURE_TSDEMUX_UPDATE_STREAM\
91   -DTIZEN_FEATURE_HLS_WEBVTT\
92   -DTIZEN_FEATURE_OALSINK_MODIFICATION\
93   -DTIZEN_FEATURE_MPEGDEMUX_MODIFICATION\
94   -DTIZEN_FEATURE_H264PARSE_MODIFICATION\
95   -DTIZEN_FEATURE_AD\
96   -DTIZEN_FEATURE_HLSDEMUX_LANG_TAG\
97   -DTIZEN_FEATURE_HLSDEMUX_DISCONT\
98   -DTIZEN_FEATURE_UPSTREAM\
99   -DTIZEN_FEATURE_GST_UPSTREAM_AVOID_BUILD_BREAK\
100   -DTIZEN_FEATURE_IMPORT_NETSIM\
101   -D__TIZEN__\
102   -fstack-protector-strong\
103   -Wl,-z,relro\
104   -D_FORTIFY_SOURCE=2"
105 export CXXFLAGS+=" -DTIZEN_FEATURE_PITCH_AUDIO_META"
106 # export pthread for checking usrsctp_init at sctp configure
107 export LDFLAGS+=" -pthread "
108
109 %configure\
110         --disable-static\
111         --disable-examples\
112         --enable-experimental\
113 %if "%{tizen_profile_name}" == "tv"
114         --enable-tv\
115         --disable-autoconvert\
116         --disable-camerabin2\
117         --disable-dash\
118         --disable-hls\
119         --disable-id3tag\
120         --disable-jpegformat\
121         --disable-mpegdemux\
122         --disable-smoothstreaming\
123         --disable-rtp\
124         --disable-gl\
125 %endif
126         --disable-accurip\
127         --disable-adpcmdec\
128         --disable-audiofxbad\
129         --disable-decklink\
130         --disable-dvb\
131         --disable-fieldanalysis\
132         --disable-ivtc\
133         --disable-rawparse\
134         --disable-videofilters\
135         --disable-yadif\
136         --disable-curl\
137         --enable-dtls\
138         --disable-fbdev\
139         --disable-uvch264\
140         --disable-y4m\
141         --disable-adpcmenc\
142         --disable-aiff\
143         --disable-asfmux\
144         --disable-audiovisualizers\
145         --disable-bayer\
146         --disable-dvbsuboverlay\
147         --disable-dvdspu\
148         --disable-faceoverlay\
149         --disable-festival\
150         --disable-freeverb\
151         --disable-frei0r\
152         --disable-geometrictransform\
153         --disable-inter\
154         --disable-interlace\
155         --disable-ivfparse\
156         --disable-jp2kdecimator\
157         --disable-librfb\
158         --disable-mxf\
159         --disable-onvif\
160         --disable-pcapparse\
161         --disable-pnm\
162         --disable-removesilence\
163         --disable-segmentclip\
164         --disable-siren\
165         --disable-smooth\
166         --disable-speed\
167         --disable-subenc\
168         --disable-videosignal\
169         --disable-vmnc\
170 %if 0%{?enable_gl:1}
171         --enable-egl=yes\
172         --enable-gles2=yes\
173 %endif
174 %if 0%{?webrtctest:1}
175         --enable-webrtctest\
176 %endif
177         --enable-wayland=yes\
178         --enable-openal=yes\
179         --disable-sndfile\
180         --disable-gtk-doc\
181         --disable-mpegpsmux
182 %__make %{?_smp_mflags} V=1
183
184 %install
185 %make_install
186 %find_lang %{name}-%{gst_branch}
187 mv %{name}-%{gst_branch}.lang %{name}.lang
188
189 %lang_package
190
191
192 %clean
193 rm -rf $RPM_BUILD_ROOT
194
195 %post -p /sbin/ldconfig
196
197
198 %postun -p /sbin/ldconfig
199
200
201 %files
202 %manifest %{name}.manifest
203 %defattr(-, root, root)
204 %license COPYING.LIB
205 %if "%{tizen_profile_name}" != "tv"
206 %{_libdir}/gstreamer-%{gst_branch}/libgstautoconvert.so
207 %{_libdir}/gstreamer-%{gst_branch}/libgstcamerabin.so
208 %{_libdir}/gstreamer-%{gst_branch}/libgstid3tag.so
209 %{_libdir}/gstreamer-%{gst_branch}/libgstjpegformat.so
210 %{_libdir}/gstreamer-%{gst_branch}/libgstmpegpsdemux.so
211 %{_libdir}/gstreamer-%{gst_branch}/libgstsmoothstreaming.so
212 %{_libdir}/gstreamer-%{gst_branch}/libgstdashdemux.so
213 %if 0%{?enable_gl:1}
214 %{_libdir}/gstreamer-%{gst_branch}/libgstopengl.so
215 %endif
216 %{_libdir}/gstreamer-%{gst_branch}/libgstsoundtouch.so
217 %{_libdir}/libgstinsertbin-%{gst_branch}.so.0*
218 %{_libdir}/libgstphotography-%{gst_branch}.so.0*
219 %{_libdir}/libgstbasecamerabinsrc-%{gst_branch}.so.0*
220 %{_libdir}/libgsturidownloader-%{gst_branch}.so.0*
221 %{_libdir}/libgstadaptivedemux-%{gst_branch}.so.0*
222 %if 0%{?enable_gl:1}
223 %{_libdir}/libgstgl-%{gst_branch}.so.0*
224 %endif
225 %{_libdir}/libgstisoff-%{gst_branch}.so.0*
226 %endif
227 %{_libdir}/gstreamer-%{gst_branch}/libgstgdp.so
228 %{_libdir}/gstreamer-%{gst_branch}/libgstdebugutilsbad.so
229 %{_libdir}/gstreamer-%{gst_branch}/libgstmpegtsdemux.so
230 %{_libdir}/gstreamer-%{gst_branch}/libgstmpegtsmux.so
231 %{_libdir}/gstreamer-%{gst_branch}/libgstsdpelem.so
232 %{_libdir}/gstreamer-%{gst_branch}/libgstshm.so
233 %{_libdir}/gstreamer-%{gst_branch}/libgstvideoparsersbad.so
234 %{_libdir}/gstreamer-%{gst_branch}/libgstmidi.so
235 %{_libdir}/gstreamer-%{gst_branch}/libgstopenal.so
236 %{_libdir}/gstreamer-%{gst_branch}/libgsthls.so
237 %{_libdir}/gstreamer-%{gst_branch}/libgstnetsim.so
238 %{_libdir}/gstreamer-%{gst_branch}/libgsttimecode.so
239 %{_libdir}/gstreamer-%{gst_branch}/libgstvideoframe_audiolevel.so
240 %{_libdir}/gstreamer-%{gst_branch}/libgstaudiomixmatrix.so
241 %{_libdir}/gstreamer-%{gst_branch}/libgstaudiobuffersplit.so
242 %{_libdir}/gstreamer-%{gst_branch}/libgstaudiolatency.so
243 %{_libdir}/gstreamer-%{gst_branch}/libgstipcpipeline.so
244 %{_libdir}/gstreamer-%{gst_branch}/libgstproxy.so
245 %{_libdir}/gstreamer-%{gst_branch}/libgstwebrtc.so
246 %{_libdir}/gstreamer-%{gst_branch}/libgstdtls.so
247 %{_libdir}/gstreamer-%{gst_branch}/libgstsctp.so
248 %{_libdir}/gstreamer-%{gst_branch}/libgstsrtp.so
249 %{_libdir}/gstreamer-%{gst_branch}/libgstopusparse.so
250 %{_libdir}/gstreamer-%{gst_branch}/libgstgaudieffects.so
251 %{_libdir}/gstreamer-%{gst_branch}/libgstcoloreffects.so
252
253 %{_libdir}/libgstsctp-%{gst_branch}.so.0*
254 %{_libdir}/libgstwebrtc-%{gst_branch}.so.0*
255 %{_libdir}/libgstcodecparsers-%{gst_branch}.so.0*
256 %{_libdir}/libgstmpegts-%{gst_branch}.so.0*
257 %{_libdir}/libgstbadaudio-%{gst_branch}.so.0*
258 %{_libdir}/libgstplayer-%{gst_branch}.so.0*
259 %if 0%{?webrtctest:1}
260 %{_bindir}/webrtc*
261 %endif
262
263 %files devel
264 %manifest %{name}.manifest
265 %defattr(-, root, root)
266 %{_includedir}/gstreamer-%{gst_branch}
267 %if "%{tizen_profile_name}" != "tv"
268 %if 0%{?enable_gl:1}
269 %{_libdir}/gstreamer-%{gst_branch}/include/gst/gl/gstglconfig.h
270 %endif
271 %endif
272 %{_libdir}/*.so
273 %{_libdir}/pkgconfig/gstreamer-codecparsers-%{gst_branch}.pc
274 %{_libdir}/pkgconfig/gstreamer-plugins-bad-%{gst_branch}.pc
275 %{_libdir}/pkgconfig/gstreamer-insertbin-%{gst_branch}.pc
276 %{_libdir}/pkgconfig/gstreamer-mpegts-%{gst_branch}.pc
277 %if 0%{?enable_gl:1}
278 %{_libdir}/pkgconfig/gstreamer-gl-1.0.pc
279 %endif
280 %{_libdir}/pkgconfig/gstreamer-bad-audio-1.0.pc
281 %{_libdir}/pkgconfig/gstreamer-player-1.0.pc
282 %{_libdir}/pkgconfig/gstreamer-sctp-1.0.pc
283 %{_libdir}/pkgconfig/gstreamer-webrtc-1.0.pc