Merge tizen patch based on 1.12.2
[platform/upstream/gstreamer.git] / packaging / gst-omx.spec
1 Name:           gst-omx
2 Summary:        GStreamer plug-in that allows communication with OpenMAX IL components
3 Version:        1.3.0
4 Release:        0
5 License:        LGPL-2.1+
6 Group:          Multimedia/Framework
7 Source0:        %{name}-%{version}.tar.gz
8 Source100:      common.tar.gz
9 Source1001:     gst-omx.manifest
10 BuildRequires:  which
11 BuildRequires:  pkgconfig(gstreamer-1.0)
12 BuildRequires:  pkgconfig(gstreamer-plugins-base-1.0)
13 BuildRequires: pkgconfig(libtbm)
14 BuildRequires: pkgconfig(mm-common)
15 ExclusiveArch: %arm aarch64
16
17 %description
18 gst-openmax is a GStreamer plug-in that allows communication with OpenMAX IL components.
19 Multiple OpenMAX IL implementations can be used.
20
21 %prep
22 %setup -q
23 %setup -q -T -D -a 100
24 cp %{SOURCE1001} .
25
26 %build
27 ./autogen.sh --noconfigure
28
29 export CFLAGS+=" -DTIZEN_FEATURE_OMX"
30
31 %ifarch aarch64
32 %configure --disable-static --prefix=/usr --with-omx-target=exynos64
33 %else
34 %configure --disable-static --prefix=/usr --with-omx-target=exynos --enable-vp8 --enable-hevc
35 %endif
36
37 make %{?jobs:-j%jobs}
38
39
40 %install
41 rm -rf %{buildroot}
42 %make_install
43
44 %files
45 %manifest gst-omx.manifest
46 %defattr(-,root,root,-)
47 %{_libdir}/gstreamer-1.0/libgstomx.so
48 %license COPYING
49