[audioencoder] Fix bug - codec data is missed, so memory leak is happened and muxed...
[platform/upstream/gstreamer.git] / packaging / gst-libav.spec
1 Name:       gst-libav
2 Summary:    Libav plugin for GStreamer
3 Version:    1.6.1
4 Release:    3
5 Group:      Multimedia/Framework
6 License:    LGPL-2.0+
7 Source:     %{name}-%{version}.tar.gz
8 Source100:  common.tar.gz
9 Source101:  libav.tar.gz
10 URL:        http://cgit.freedesktop.org/gstreamer/gst-libav
11 BuildRequires:  gettext
12 BuildRequires:  which
13 BuildRequires:  yasm
14 BuildRequires:  bzip2-devel
15 BuildRequires:  pkgconfig(gstreamer-1.0)
16 BuildRequires:  pkgconfig(gstreamer-plugins-base-1.0)
17 BuildRequires:  pkgconfig(glib-2.0)
18 BuildRequires:  pkgconfig(zlib)
19 BuildRequires:  pkgconfig(vorbis)
20 BuildRequires:  pkgconfig(theora)
21 BuildRequires:  pkgconfig(orc-0.4)
22
23 %description
24 This GStreamer plugin supports a large number of audio and video compression
25 formats through the use of the libav library.  The plugin contains GStreamer
26 elements for decoding 90+ formats (AVI, MPEG, OGG, Matroska, ASF, ...),
27 demuxing 30+ formats and colorspace conversion.
28
29
30 %prep
31 %setup -q -n gst-libav-%{version}
32 %setup -q -T -D -a 100
33 %setup -q -T -D -a 101
34
35 %build
36 NOCONFIGURE=1 ./autogen.sh
37
38 export CFLAGS+=" -Wall -g -fPIC\
39  -DGST_TIZEN_MODIFICATION\
40  -DLIBAV_RANK_MODIFICATION"
41
42 %configure  --disable-static \
43         --enable-lgpl\
44         --prefix=%{_prefix} \
45         --with-html-dir=/tmp/dump\
46         --with-libav-extra-configure="--disable-demuxer=mm"
47
48
49 make %{?jobs:-j%jobs}
50
51 %install
52 rm -rf %{buildroot}
53 %make_install
54
55
56 %files
57 %manifest %{name}.manifest
58 %defattr(-,root,root,-)
59 %license COPYING.LIB
60 %{_libdir}/gstreamer-1.0/libgstlibav.so
61
62