avauddec: fix buffer leak when send packet failed
[platform/upstream/gstreamer.git] / packaging / gst-libav.spec
1 Name:       gst-libav
2 Summary:    Libav plugin for GStreamer
3 Version:    1.16.2
4 Release:    2
5 Group:      Multimedia/Framework
6 License:    LGPL-2.0+
7 Source:     %{name}-%{version}.tar.gz
8 Source100:  common.tar.gz
9 Source101:  libav.tar.gz
10 URL:        http://cgit.freedesktop.org/gstreamer/gst-libav
11 BuildRequires:  gettext
12 BuildRequires:  which
13 BuildRequires:  yasm
14 BuildRequires:  bzip2-devel
15 BuildRequires:  pkgconfig(gstreamer-1.0)
16 BuildRequires:  pkgconfig(gstreamer-plugins-base-1.0)
17 BuildRequires:  pkgconfig(glib-2.0)
18 BuildRequires:  pkgconfig(zlib)
19 BuildRequires:  pkgconfig(vorbis)
20 BuildRequires:  pkgconfig(theora)
21 BuildRequires:  pkgconfig(orc-0.4)
22
23 %description
24 This GStreamer plugin supports a large number of audio and video compression
25 formats through the use of the libav library.  The plugin contains GStreamer
26 elements for decoding 90+ formats (AVI, MPEG, OGG, Matroska, ASF, ...),
27 demuxing 30+ formats and colorspace conversion.
28
29
30 %prep
31 %setup -q -n gst-libav-%{version}
32 %setup -q -T -D -a 100
33 %setup -q -T -D -a 101
34
35 %build
36 NOCONFIGURE=1 ./autogen.sh
37
38 export CFLAGS+=" -Wall -g -fPIC\
39  -DGST_TIZEN_MODIFICATION\
40  -DTIZEN_FEATURE_LIBAV   \
41 %if "%{tizen_profile_name}" == "tv"
42  -DTIZEN_PRODUCT_TV \
43 %endif
44  -DLIBAV_RANK_MODIFICATION"
45
46 EXTRA_CONFIGURE="--disable-demuxer=mm --disable-decoder=jpeg2000 --disable-decoder=hevc"
47 %{?asan:EXTRA_CONFIGURE="$EXTRA_CONFIGURE --disable-asm"}
48 %configure  --disable-static \
49         --enable-lgpl\
50         --disable-jpeg\
51         --prefix=%{_prefix} \
52         --with-html-dir=/tmp/dump\
53         --with-libav-extra-configure="$EXTRA_CONFIGURE"
54
55
56 make %{?jobs:-j%jobs}
57
58 %install
59 rm -rf %{buildroot}
60 %make_install
61
62
63 %files
64 %manifest %{name}.manifest
65 %defattr(-,root,root,-)
66 %license COPYING.LIB
67 %{_libdir}/gstreamer-1.0/libgstlibav.so
68
69