"Initial commit to Gerrit"
[profile/ivi/gpsd.git] / packaging / gpsd.spec
1 Name:       gpsd
2 Summary:    GPS Daemon communication library
3 Version:    2.95
4 Release:    1
5 Group:      TO_BE/FILLED_IN
6 License:    BSD
7 Source0:    %{name}-%{version}.tar.gz
8 Requires(post): /sbin/ldconfig
9 Requires(postun): /sbin/ldconfig
10 BuildRequires:  which
11 BuildRequires:  pkgconfig(ncurses)
12 BuildRequires:  pkgconfig(xt)
13 BuildRequires:  pkgconfig(xaw7)
14 BuildRequires:  pkgconfig(dbus-1)
15 BuildRequires:  pkgconfig(dbus-glib-1)
16 BuildRequires:  pkgconfig(glib-2.0)
17 BuildRequires:  python
18
19
20 %description
21 GPS (Global Positioning System) daemon gpsd is a service daemon that monitors one or more GPSes attached to a host
22  computer through serial or USB ports, making all data on the location/course/
23  velocity of the sensors available to be queried on TCP port 2947 of the host
24  computer.
25  .
26  With gpsd, multiple GPS client applications can share access to GPSes without
27  contention or loss of data. Also, gpsd responds to queries with a format that
28  is substantially easier to parse than the NMEA 0183 emitted by most GPSes.
29
30
31 %package -n libgps
32 Summary:    C library for communicating with GPS devices
33 Group:      TO_BE/FILLED
34
35 %description -n libgps
36 libgps is a service library for querying GPS devices. There are two
37 interfaces supported by it:
38 monitors one or more GPS devices. It is intended for concurrent use by
39 several applications.
40 device to which the GPS is attached.
41
42
43 %package -n libgps-devel
44 Summary:    C library for communicating with GPS devices (development files)
45 Group:      TO_BE/FILLED
46
47 %description -n libgps-devel
48 libgps is a service library for querying GPS devices. There are two
49 interfaces supported by it:
50 monitors one or more GPS devices. It is intended for concurrent use by
51 several applications.
52 device to which the GPS is attached.
53 .
54 This package contains the header and development files needed to build
55 programs and packages using libgps.
56
57
58 %prep
59 %setup -q
60
61 %build
62
63 export LDFLAGS+="-Wl,--no-as-needed -Wl,-z,defs"
64 ./autogen.sh
65 ./configure --prefix=/usr --disable-python --disable-static
66
67 make %{?jobs:-j%jobs}
68
69 %install
70 %make_install
71
72
73 %post -n libgps -p /sbin/ldconfig
74
75 %postun -n libgps -p /sbin/ldconfig
76
77
78 %files
79
80 %files 
81 /usr/bin/*
82 /usr/sbin/*
83
84 %files -n libgps
85 /usr/lib/*.so.*
86
87 %files -n libgps-devel
88 /usr/lib/*.so
89 /usr/include/*
90 /usr/lib/pkgconfig/*
91