Merge branch 'tizen_2.2' into tizen
[platform/core/uifw/e17.git] / packaging / e17.spec
1 Name:       e17
2 Summary:    The Enlightenment window manager
3 Version:    1.0.0.001+svn.76808slp2+build47
4 Release:    2
5 Group:      System/GUI/Other
6 License:    BSD
7 URL:        http://www.enlightenment.org/
8 Source0:    %{name}-%{version}.tar.gz
9 Source2:    packaging/e17.service
10 Source3:    packaging/e17_early.service
11 BuildRequires:  pkgconfig(alsa)
12 BuildRequires:  pkgconfig(ecore)
13 BuildRequires:  pkgconfig(ecore-con)
14 BuildRequires:  pkgconfig(ecore-evas)
15 BuildRequires:  pkgconfig(ecore-fb)
16 BuildRequires:  pkgconfig(ecore-file)
17 BuildRequires:  pkgconfig(ecore-imf)
18 BuildRequires:  pkgconfig(ecore-imf-evas)
19 BuildRequires:  pkgconfig(ecore-input)
20 BuildRequires:  pkgconfig(ecore-input-evas)
21 BuildRequires:  pkgconfig(ecore-ipc)
22 BuildRequires:  pkgconfig(ecore-x)
23 BuildRequires:  pkgconfig(edbus)
24 BuildRequires:  pkgconfig(elementary)
25 BuildRequires:  pkgconfig(edje)
26 BuildRequires:  pkgconfig(eet)
27 BuildRequires:  pkgconfig(efreet)
28 BuildRequires:  pkgconfig(efreet-mime)
29 BuildRequires:  pkgconfig(efreet-trash)
30 BuildRequires:  pkgconfig(ehal)
31 BuildRequires:  pkgconfig(eina)
32 BuildRequires:  pkgconfig(evas)
33 BuildRequires:  pkgconfig(eio)
34 BuildRequires:  pkgconfig(utilX)
35 BuildRequires:  pkgconfig(x11)
36 BuildRequires:  pkgconfig(xext)
37 BuildRequires:  pkgconfig(dlog)
38 BuildRequires:  edje-bin
39 BuildRequires:  embryo-bin
40 BuildRequires:  eet-bin
41 BuildRequires:  gettext-devel
42
43
44 %description
45 The Enlightenment DR17 Window Manager Enlightenment is an advanced window manager for X11. Unique
46  features include: a fully animated background, nice drop shadows
47  around windows, backed by an extremely clean and optimized
48  foundation of APIs.
49  .
50  This package contains the core files for Enlightenment DR17.
51
52
53
54 %package devel
55 Summary:    The Enlightenment window mgr (devel)
56 Group:      Development/Libraries
57 Requires:   %{name} = %{version}-%{release}
58
59 %description devel
60 The Enlightenment window manager (devel)
61
62 %package data
63 Summary:    The Enlightenment window mgr (data)
64 Group:      Development/Libraries
65 Requires:   %{name} = %{version}-%{release}
66
67 %description data
68 The Enlightenment window manager (data)
69
70
71 %prep
72 %setup -q
73
74
75 %build
76
77 %autogen --disable-static
78 LIBS='-ledbus' ./configure --prefix=/usr --disable-static \
79     --disable-temperature \
80     --disable-mixer \
81     --disable-everything \
82     --disable-dropshadow \
83     --disable-pager \
84     --disable-battery \
85     --disable-cpufreq \
86     --disable-start \
87     --disable-exebuf \
88     --disable-winlist \
89     --disable-fileman \
90     --disable-fileman-opinfo \
91     --disable-wizard \
92     --disable-conf \
93     --disable-conf-wallpaper \
94     --disable-conf-wallpaper2 \
95     --disable-conf-colors \
96     --disable-conf-fonts \
97     --disable-conf-borders \
98     --disable-conf-icon-theme \
99     --disable-conf-mouse-cursor \
100     --disable-conf-transitions \
101     --disable-conf-startup \
102     --disable-conf-intl \
103     --disable-conf-imc \
104     --disable-conf-profiles \
105     --disable-msgbus-lang \
106     --disable-conf-engine \
107     --disable-conf-desks \
108     --disable-conf-desk \
109     --disable-conf-display \
110     --disable-conf-desklock \
111     --disable-conf-screensaver \
112     --disable-conf-dpms \
113     --disable-conf-shelves \
114     --disable-conf-shelves \
115     --disable-conf-keybindings \
116     --disable-conf-mousebindings \
117     --disable-conf-edgebindings \
118     --disable-conf-mouse \
119     --disable-conf-window-display \
120     --disable-conf-window-focus \
121     --disable-conf-window-remembers \
122     --disable-conf-window-manipulation \
123     --disable-conf-menus \
124     --disable-conf-clientlist \
125     --disable-conf-dialogs \
126     --disable-conf-performance \
127     --disable-conf-winlist \
128     --disable-conf-exebuf \
129     --disable-conf-paths \
130     --disable-conf-mime \
131     --disable-conf-interaction \
132     --disable-conf-scale \
133     --disable-mixel \
134     --disable-connman \
135     --disable-illume \
136     --disable-syscon \
137     --disable-bluez \
138     --disable-ofono \
139     --disable-msgbus \
140     --disable-systray \
141     --disable-conf_acpibindings \
142     --disable-everything-apps \
143     --disable-everything-aspell \
144     --disable-everything-calc \
145     --disable-everything-files \
146     --disable-everything-settings \
147     --disable-everything-windows \
148     --disable-illume-bluetooth \
149     --disable-illume-home \
150     --disable-illume-toggle \
151     --disable-illume-indicator \
152     --disable-illume-kbd-toggle \
153     --disable-illume-keyboard \
154     --disable-illume-mode-toggle \
155     --disable-illume-softkey \
156     --disable-comp \
157     --disable-illume2 \
158     --disable-conf_randr \
159     --disable-tasks \
160     --disable-backlight \
161     --disable-shot \
162     --disable-notification \
163     --disable-quickaccess \
164     --disable-tiling \
165     --disable-xkbswitch \
166     --disable-access \
167     --enable-extra-features
168
169 make %{?jobs:-j%jobs}
170
171 %install
172 %make_install
173
174
175 #systemd setup
176 mkdir -p %{buildroot}/usr/lib/systemd/user/core-efl.target.wants
177 install -m 0644 %SOURCE2 %{buildroot}/usr/lib/systemd/user/
178 ln -s ../e17.service %{buildroot}/usr/lib/systemd/user/core-efl.target.wants/e17.service
179 install -m 0644 %SOURCE3 %{buildroot}/usr/lib/systemd/user/
180 ln -s ../e17_early.service %{buildroot}/usr/lib/systemd/user/core-efl.target.wants/e17_early.service
181 rm -rf %{buildroot}/usr/etc/xdg/*
182 rm -rf %{buildroot}/usr/lib/enlightenment/utils/*
183 rm -rf %{buildroot}/usr/share/enlightenment/AUTHORS
184 rm -rf %{buildroot}/usr/share/enlightenment/COPYING
185 rm -rf %{buildroot}/usr/share/enlightenment/data/backgrounds/*
186 rm -rf %{buildroot}/usr/share/enlightenment/data/config/*
187 rm -rf %{buildroot}/usr/share/enlightenment/data/icons/*
188 rm -rf %{buildroot}/usr/share/enlightenment/data/images/enlightenment.png
189 rm -rf %{buildroot}/usr/share/enlightenment/data/input_methods/*
190 rm -rf %{buildroot}/usr/share/locale/*
191 rm -rf %{buildroot}/usr/share/xsessions/*
192 rm -rf %{buildroot}/usr/share/applications/enlightenment_filemanager.desktop
193 rm -rf %{buildroot}/usr/share/enlightenment/data/flags/*
194 rm -rf %{buildroot}/usr/share/enlightenment/data/favorites/*
195 rm -rf %{buildroot}/usr/share/enlightenment/data/favorites/.order
196
197 %files
198 %manifest e17.manifest
199 %license COPYING
200 %defattr(-,root,root,-)
201 /usr/bin/enlightenment
202 /usr/bin/enlightenment_imc
203 /usr/bin/enlightenment_remote
204 /usr/bin/enlightenment_start
205 /usr/bin/enlightenment_filemanager
206 /usr/bin/enlightenment_open
207 /usr/lib/enlightenment/modules
208 /usr/lib/enlightenment/preload/*
209 %config /usr/etc/enlightenment/sysactions.conf
210 /usr/lib/systemd/user/e17.service
211 /usr/lib/systemd/user/core-efl.target.wants/e17.service
212 /usr/lib/systemd/user/e17_early.service
213 /usr/lib/systemd/user/core-efl.target.wants/e17_early.service
214
215 %files devel
216 %defattr(-,root,root,-)
217 /usr/lib/pkgconfig/enlightenment.pc
218 /usr/include/enlightenment/*.h
219
220 %files data
221 %manifest e17-data.manifest
222 %defattr(-,root,root,-)
223 /usr/share/enlightenment/data/themes
224 /etc/smack/accesses.d/e17.rule
225
226 /usr/share/enlightenment/data/images/test.edj
227 /usr/share/enlightenment/data/images/test.png
228 /usr/share/enlightenment/data/images/test.svg
229 /usr/share/enlightenment/data/images/test.jpg