4 Summary: The DALi Tizen Adaptor
7 Group: System/Libraries
9 URL: https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
10 Source0: %{name}-%{version}.tar.gz
12 %if "%{profile}" == "mobile"
13 %define dali_profile MOBILE
14 %define dali_feedback_plugin 0
15 %define dali_bullet_plugin 0
16 %define dali_assimp_plugin 0
19 %if "%{profile}" == "tv"
20 %define dali_profile TV
21 %define dali_feedback_plugin 0
22 %define dali_bullet_plugin 0
23 %define dali_assimp_plugin 0
26 %if "%{profile}" == "wearable"
27 %define dali_profile WEARABLE
28 %define dali_feedback_plugin 0
29 %define dali_bullet_plugin 0
30 %define dali_assimp_plugin 0
33 %if "%{profile}" == "common"
34 %define dali_profile COMMON
35 %define dali_feedback_plugin 0
36 %define dali_bullet_plugin 0
37 %define dali_assimp_plugin 0
40 Requires(post): /sbin/ldconfig
41 Requires(postun): /sbin/ldconfig
42 Requires: boost-thread
44 BuildRequires: pkgconfig
46 BuildRequires: pkgconfig(sensor)
47 BuildRequires: pkgconfig(aul)
48 BuildRequires: boost-devel
49 BuildRequires: giflib-devel
50 BuildRequires: pkgconfig(fontconfig)
51 BuildRequires: pkgconfig(elementary)
52 BuildRequires: pkgconfig(capi-appfw-application)
53 BuildRequires: libjpeg-turbo-devel
54 BuildRequires: pkgconfig(evas)
55 BuildRequires: dali-devel
56 BuildRequires: dali-integration-devel
57 BuildRequires: libxml2-devel
58 BuildRequires: vconf-devel
59 BuildRequires: vconf-keys-devel
60 BuildRequires: tts-devel
61 BuildRequires: pkgconfig(dlog)
62 BuildRequires: libdrm-devel
63 BuildRequires: pkgconfig(libexif)
64 BuildRequires: pkgconfig(capi-system-system-settings)
65 BuildRequires: pkgconfig(libpng)
66 BuildRequires: pkgconfig(glesv2)
67 BuildRequires: pkgconfig(egl)
70 BuildRequires: pkgconfig(ecore-wayland)
71 BuildRequires: pkgconfig(wayland-egl)
72 BuildRequires: pkgconfig(wayland-client)
74 BuildRequires: pkgconfig(xi)
75 BuildRequires: pkgconfig(xfixes)
76 BuildRequires: pkgconfig(xdamage)
77 BuildRequires: pkgconfig(utilX)
80 %if 0%{?dali_assimp_plugin}
81 BuildRequires: pkgconfig(assimp)
85 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
86 platform abstraction and application shell
88 ##############################
90 ##############################
92 Summary: Development components for the DALi Tizen Adaptor
93 Group: Development/Building
94 Requires: %{name} = %{version}-%{release}
97 Development components for the DALi Tizen Adaptor - public headers and package configs
99 ##############################
100 # Dali Feedback Plugin
101 ##############################
102 %package dali-feedback-plugin
103 Summary: Plugin to play haptic and audio feedback for Dali
104 Group: System/Libraries
105 %if 0%{?dali_feedback_plugin}
106 #Requires: libdeviced
107 BuildRequires: pkgconfig(mm-sound)
108 BuildRequires: pkgconfig(haptic)
109 BuildRequires: libfeedback-devel
112 %description dali-feedback-plugin
113 Feedback plugin to play haptic and audio feedback for Dali
115 ##############################
116 # Dali Dynamics/Bullet Plugin
117 ##############################
118 %package dali-bullet-plugin
119 Summary: Plugin to provide physics
120 Group: System/Libraries
121 %if 0%{?dali_bullet_plugin}
122 BuildRequires: pkgconfig(bullet)
125 %description dali-bullet-plugin
126 Dynamics plugin to wrap the libBulletDynamics libraries
128 ##############################
130 ##############################
133 %define dali_data_rw_dir /usr/share/dali/
134 %define dali_data_ro_dir /usr/share/dali/
135 %define user_font_cache_dir %{dali_data_rw_dir}/glyphcache/
136 %define user_shader_cache_dir %{dali_data_rw_dir}/core/shaderbin/
137 %define font_preloaded_path /usr/share/fonts/
138 %define font_downloaded_path /opt/share/fonts/
139 %define font_application_path /usr/share/app_fonts/
140 %define font_configuration_file /opt/etc/fonts/conf.avail/99-slp.conf
141 %define dali_plugin_sound_files %{dali_data_ro_dir}/plugins/sounds/
142 %define dali_plugin_theme_files %{dali_data_ro_dir}/themes/feedback-themes/
144 %define dev_include_path %{_includedir}
146 ##############################
148 ##############################
151 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections "
152 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections "
155 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
160 CXXFLAGS+=" -DWAYLAND"
161 configure_flags="--enable-wayland"
165 cd %{_builddir}/%{name}-%{version}/build/tizen && autoreconf --install
166 cd %{_builddir}/%{name}-%{version}/build/tizen && CXXFLAGS=$CXXFLAGS LDFLAGS=$LDFLAGS DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}" FONT_PRELOADED_PATH="%{font_preloaded_path}" FONT_DOWNLOADED_PATH="%{font_downloaded_path}" FONT_APPLICATION_PATH="%{font_application_path}" FONT_CONFIGURATION_FILE="%{font_configuration_file}"
168 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=20 --enable-profile=%{dali_profile} \
169 %if 0%{?dali_feedback_plugin}
172 %if 0%{?dali_bullet_plugin}
175 %if 0%{?dali_assimp_plugin}
178 $configure_flags --libdir=%{_libdir}
180 make %{?jobs:-j%jobs}
182 ##############################
184 ##############################
188 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
191 mkdir -p %{buildroot}/usr/share/license
192 cp -af %{_builddir}/%{name}-%{version}/LICENSE %{buildroot}/usr/share/license/%{name}
194 ##############################
196 # 1 - Pre Install new package
197 # 2 - Install new package
198 # 3 - Post install new package
199 # 4 - Pre uninstall old package
200 # 5 - Remove files not overwritten by new package
201 # 6 - Post uninstall old package
202 ##############################
205 rm -f %{user_font_cache_dir}/*
206 rm -f %{user_shader_cache_dir}/*
209 ##############################
210 # Post Install new package
211 ##############################
214 chown 5000:5000 %{user_font_cache_dir}
215 chown 5000:5000 %{user_shader_cache_dir}
218 %if 0%{?dali_feedback_plugin}
219 %post dali-feedback-plugin
224 %if 0%{?dali_bullet_plugin}
225 %post dali-bullet-plugin
230 ##############################
231 # Pre Uninstall old package
232 ##############################
234 rm -f %{user_font_cache_dir}/*
235 rm -f %{user_shader_cache_dir}/*
238 ##############################
239 # Post Uninstall old package
240 ##############################
245 %if 0%{?dali_feedback_plugin}
246 %postun dali-feedback-plugin
251 %if 0%{?dali_bullet_plugin}
252 %postun dali-bullet-plugin
257 ##############################
258 # Files in Binary Packages
259 ##############################
262 %manifest dali-adaptor.manifest
263 %defattr(-,root,root,-)
264 %{_libdir}/libdali-adap*.so*
265 %defattr(-,app,app,-)
266 %dir %{user_font_cache_dir}
267 %dir %{user_shader_cache_dir}
269 %{_datadir}/license/%{name}
272 %defattr(-,root,root,-)
273 %{dev_include_path}/dali/*
274 %{_libdir}/pkgconfig/dali*.pc
276 %if 0%{?dali_feedback_plugin}
277 %files dali-feedback-plugin
278 %defattr(-,root,root,-)
279 %{_libdir}/libdali-feedback-plugin.so*
280 %{dali_plugin_sound_files}/*
281 %{dali_plugin_theme_files}/*
284 %if 0%{?dali_bullet_plugin}
285 %files dali-bullet-plugin
286 %defattr(-,root,root,-)
287 %{_libdir}/libdali-bullet-plugin.so*