4 Summary: The DALi Tizen Adaptor
7 Group: System/Libraries
9 URL: https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
10 Source0: %{name}-%{version}.tar.gz
12 %if "%{profile}" == "mobile"
13 %define dali_profile MOBILE
14 %define dali_feedback_plugin 0
15 %define dali_bullet_plugin 0
16 %define dali_assimp_plugin 0
19 %if "%{profile}" == "tv"
20 %define dali_profile TV
21 %define dali_feedback_plugin 0
22 %define dali_bullet_plugin 0
23 %define dali_assimp_plugin 0
26 %if "%{profile}" == "wearable"
27 %define dali_profile WEARABLE
28 %define dali_feedback_plugin 0
29 %define dali_bullet_plugin 0
30 %define dali_assimp_plugin 0
33 %if "%{profile}" == "common"
34 %define dali_profile COMMON
35 %define dali_feedback_plugin 0
36 %define dali_bullet_plugin 0
37 %define dali_assimp_plugin 0
40 Requires(post): /sbin/ldconfig
41 Requires(postun): /sbin/ldconfig
42 Requires: boost-thread
44 BuildRequires: pkgconfig
46 BuildRequires: pkgconfig(sensor)
47 BuildRequires: pkgconfig(aul)
48 BuildRequires: boost-devel
49 BuildRequires: giflib-devel
50 BuildRequires: pkgconfig(fontconfig)
51 BuildRequires: pkgconfig(elementary)
52 BuildRequires: pkgconfig(capi-appfw-application)
53 BuildRequires: libjpeg-turbo-devel
54 BuildRequires: pkgconfig(evas)
55 BuildRequires: dali-devel
56 BuildRequires: dali-integration-devel
57 BuildRequires: libxml2-devel
58 BuildRequires: vconf-devel
59 BuildRequires: vconf-keys-devel
60 BuildRequires: tts-devel
61 BuildRequires: pkgconfig(dlog)
62 BuildRequires: libdrm-devel
63 BuildRequires: pkgconfig(libexif)
64 BuildRequires: pkgconfig(capi-system-system-settings)
65 BuildRequires: pkgconfig(libpng)
66 BuildRequires: pkgconfig(glesv2)
67 BuildRequires: pkgconfig(egl)
70 BuildRequires: pkgconfig(ecore-wayland)
71 BuildRequires: pkgconfig(wayland-egl)
72 BuildRequires: pkgconfig(wayland-client)
74 BuildRequires: pkgconfig(xi)
75 BuildRequires: pkgconfig(xfixes)
76 BuildRequires: pkgconfig(xdamage)
77 BuildRequires: pkgconfig(utilX)
80 BuildRequires: pkgconfig(harfbuzz)
81 BuildRequires: fribidi-devel
83 %if 0%{?dali_assimp_plugin}
84 BuildRequires: pkgconfig(assimp)
88 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
89 platform abstraction and application shell
91 ##############################
93 ##############################
95 Summary: Development components for the DALi Tizen Adaptor
96 Group: Development/Building
97 Requires: %{name} = %{version}-%{release}
100 Development components for the DALi Tizen Adaptor - public headers and package configs
102 ##############################
103 # Dali Feedback Plugin
104 ##############################
105 %package dali-feedback-plugin
106 Summary: Plugin to play haptic and audio feedback for Dali
107 Group: System/Libraries
108 %if 0%{?dali_feedback_plugin}
109 #Requires: libdeviced
110 BuildRequires: pkgconfig(mm-sound)
111 BuildRequires: pkgconfig(haptic)
112 BuildRequires: libfeedback-devel
115 %description dali-feedback-plugin
116 Feedback plugin to play haptic and audio feedback for Dali
118 ##############################
119 # Dali Dynamics/Bullet Plugin
120 ##############################
121 %package dali-bullet-plugin
122 Summary: Plugin to provide physics
123 Group: System/Libraries
124 %if 0%{?dali_bullet_plugin}
125 BuildRequires: pkgconfig(bullet)
128 %description dali-bullet-plugin
129 Dynamics plugin to wrap the libBulletDynamics libraries
131 ##############################
133 ##############################
136 %define dali_data_rw_dir /usr/share/dali/
137 %define dali_data_ro_dir /usr/share/dali/
138 %define user_font_cache_dir %{dali_data_rw_dir}/glyphcache/
139 %define user_shader_cache_dir %{dali_data_rw_dir}/core/shaderbin/
140 %define font_preloaded_path /usr/share/fonts/
141 %define font_downloaded_path /opt/share/fonts/
142 %define font_application_path /usr/share/app_fonts/
143 %define font_configuration_file /opt/etc/fonts/conf.avail/99-slp.conf
144 %define dali_plugin_sound_files %{dali_data_ro_dir}/plugins/sounds/
145 %define dali_plugin_theme_files %{dali_data_ro_dir}/themes/feedback-themes/
147 %define dev_include_path %{_includedir}
149 ##############################
151 ##############################
154 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections "
155 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections "
158 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
163 CXXFLAGS+=" -DWAYLAND"
164 configure_flags="--enable-wayland"
168 cd %{_builddir}/%{name}-%{version}/build/tizen && autoreconf --install
169 cd %{_builddir}/%{name}-%{version}/build/tizen && CXXFLAGS=$CXXFLAGS LDFLAGS=$LDFLAGS DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}" FONT_PRELOADED_PATH="%{font_preloaded_path}" FONT_DOWNLOADED_PATH="%{font_downloaded_path}" FONT_APPLICATION_PATH="%{font_application_path}" FONT_CONFIGURATION_FILE="%{font_configuration_file}"
171 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=20 --enable-profile=%{dali_profile} \
172 %if 0%{?dali_feedback_plugin}
175 %if 0%{?dali_bullet_plugin}
178 %if 0%{?dali_assimp_plugin}
181 $configure_flags --libdir=%{_libdir}
183 make %{?jobs:-j%jobs}
185 ##############################
187 ##############################
191 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
194 mkdir -p %{buildroot}/usr/share/license
195 cp -af %{_builddir}/%{name}-%{version}/LICENSE %{buildroot}/usr/share/license/%{name}
197 ##############################
199 # 1 - Pre Install new package
200 # 2 - Install new package
201 # 3 - Post install new package
202 # 4 - Pre uninstall old package
203 # 5 - Remove files not overwritten by new package
204 # 6 - Post uninstall old package
205 ##############################
208 rm -f %{user_font_cache_dir}/*
209 rm -f %{user_shader_cache_dir}/*
212 ##############################
213 # Post Install new package
214 ##############################
217 chown 5000:5000 %{user_font_cache_dir}
218 chown 5000:5000 %{user_shader_cache_dir}
221 %if 0%{?dali_feedback_plugin}
222 %post dali-feedback-plugin
227 %if 0%{?dali_bullet_plugin}
228 %post dali-bullet-plugin
233 ##############################
234 # Pre Uninstall old package
235 ##############################
237 rm -f %{user_font_cache_dir}/*
238 rm -f %{user_shader_cache_dir}/*
241 ##############################
242 # Post Uninstall old package
243 ##############################
248 %if 0%{?dali_feedback_plugin}
249 %postun dali-feedback-plugin
254 %if 0%{?dali_bullet_plugin}
255 %postun dali-bullet-plugin
260 ##############################
261 # Files in Binary Packages
262 ##############################
265 %manifest dali-adaptor.manifest
266 %defattr(-,root,root,-)
267 %{_libdir}/libdali-adap*.so*
268 %defattr(-,app,app,-)
269 %dir %{user_font_cache_dir}
270 %dir %{user_shader_cache_dir}
272 %{_datadir}/license/%{name}
275 %defattr(-,root,root,-)
276 %{dev_include_path}/dali/*
277 %{_libdir}/pkgconfig/dali*.pc
279 %if 0%{?dali_feedback_plugin}
280 %files dali-feedback-plugin
281 %defattr(-,root,root,-)
282 %{_libdir}/libdali-feedback-plugin.so*
283 %{dali_plugin_sound_files}/*
284 %{dali_plugin_theme_files}/*
287 %if 0%{?dali_bullet_plugin}
288 %files dali-bullet-plugin
289 %defattr(-,root,root,-)
290 %{_libdir}/libdali-bullet-plugin.so*