2 # This spec file is used to build DALi Adaptor for different Tizen Profiles
3 # Current profiles are: Mobile, TV, Wearable, Common
5 # The profile variable is defined outside of the spec file in a build.conf file.
6 # It will contain the profile and whether or not to build with X11 or Wayland
8 # gbs will try to download the build.conf for the platform automatically from the repo location when
9 # performing a gbs build ( use gbs build -v to see it download location) E.g.
10 # http://download.tizen.org/snapshots/tizen/tv/tizen-tv/repos/arm-wayland/packages/repodata/xxxx-build.conf.gz
12 # Do not provide .so automatically for the extensions.
13 # This if statement is for backward compatibility with GBM/Obsolete build systems
14 %if "%{?profile}" != "wearable" && "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
15 %global __provides_exclude_from ^.*\\.(wearable|mobile|tv|ivi|common)$
19 Summary: The DALi Tizen Adaptor
22 Group: System/Libraries
23 License: Apache-2.0 and BSD-3-Clause and MIT
24 URL: https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
25 Source0: %{name}-%{version}.tar.gz
27 Requires(post): /sbin/ldconfig
28 Requires(postun): /sbin/ldconfig
31 %define tizen_platform_config_supported 1
32 BuildRequires: pkgconfig(libtzplatform-config)
34 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
35 # if wearable || "undefined"
36 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
37 BuildRequires: pkgconfig(capi-appfw-watch-application)
38 BuildRequires: pkgconfig(appcore-watch)
39 BuildRequires: pkgconfig(screen_connector_provider)
42 BuildRequires: pkgconfig(gles20)
43 BuildRequires: pkgconfig(glesv2)
44 BuildRequires: pkgconfig(ttrace)
46 BuildRequires: dali2-devel
47 BuildRequires: dali2-integration-devel
49 BuildRequires: pkgconfig
52 BuildRequires: giflib-devel
53 BuildRequires: pkgconfig(fontconfig)
54 BuildRequires: libjpeg-turbo-devel
55 BuildRequires: pkgconfig(vconf)
56 BuildRequires: tts-devel
57 BuildRequires: pkgconfig(dlog)
58 BuildRequires: libdrm-devel
59 BuildRequires: pkgconfig(libexif)
60 BuildRequires: pkgconfig(libpng)
61 BuildRequires: pkgconfig(egl)
62 BuildRequires: libcurl-devel
63 BuildRequires: pkgconfig(harfbuzz)
64 BuildRequires: fribidi-devel
66 BuildRequires: pkgconfig(capi-system-info)
67 BuildRequires: pkgconfig(capi-system-sensor)
69 BuildRequires: pkgconfig(cairo)
71 BuildRequires: pkgconfig(wayland-egl)
72 BuildRequires: pkgconfig(wayland-client)
73 BuildRequires: wayland-devel
74 BuildRequires: wayland-extension-client-devel
76 # WebP support only from Tizen 6 onwards
77 %if 0%{?tizen_version_major} >= 6
78 BuildRequires: pkgconfig(libwebp)
79 BuildRequires: pkgconfig(libwebpdecoder)
80 BuildRequires: pkgconfig(libwebpdemux)
81 BuildRequires: pkgconfig(libwebpmux)
84 # We use ecore mainloop
85 %if 0%{?tizen_version_major} >= 5
86 BuildRequires: pkgconfig(ecore-wl2)
87 BuildRequires: pkgconfig(wayland-egl-tizen)
89 BuildRequires: pkgconfig(ecore-wayland)
92 # We need tbm_surface in tizen 3.0 wayland
93 BuildRequires: pkgconfig(libtbm)
96 BuildRequires: pkgconfig(appcore-ui)
97 BuildRequires: pkgconfig(appcore-widget-base)
98 BuildRequires: pkgconfig(bundle)
99 BuildRequires: pkgconfig(capi-appfw-app-common)
100 BuildRequires: pkgconfig(capi-appfw-app-control)
101 BuildRequires: pkgconfig(ecore-imf)
103 BuildRequires: pkgconfig(capi-system-system-settings)
105 # for feedback plugin
106 BuildRequires: pkgconfig(mm-sound)
107 BuildRequires: pkgconfig(feedback)
108 BuildRequires: pkgconfig(component-based-core-base)
111 Requires: %{name}-compat = %{version}-%{release}
112 Recommends: %{name}-profile_common = %{version}-%{release}
115 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
116 platform abstraction and application shell
118 ###########################################
119 # Dali adapter for profiles
120 ###########################################
122 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
123 # if mobile || "undefined"
124 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
125 %package profile_mobile
126 Summary: The DALi Tizen Adaptor for mobile
127 Provides: %{name}-compat = %{version}-%{release}
128 Conflicts: %{name}-profile_tv
129 Conflicts: %{name}-profile_wearable
130 Conflicts: %{name}-profile_ivi
131 Conflicts: %{name}-profile_common
133 %description profile_mobile
134 The DALi Tizen Adaptor for mobile.
137 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
138 # if tv ||"undefined"
139 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
141 Summary: The DALi Tizen Adaptor for tv
142 Provides: %{name}-compat = %{version}-%{release}
143 Conflicts: %{name}-profile_mobile
144 Conflicts: %{name}-profile_wearable
145 Conflicts: %{name}-profile_ivi
146 Conflicts: %{name}-profile_common
148 %description profile_tv
149 The DALi Tizen Adaptor for tv.
152 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
153 # if wearable || "undefined"
154 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
155 %package profile_wearable
156 Summary: The DALi Tizen Adaptor for wearable
157 Provides: %{name}-compat = %{version}-%{release}
158 Conflicts: %{name}-profile_mobile
159 Conflicts: %{name}-profile_tv
160 Conflicts: %{name}-profile_ivi
161 Conflicts: %{name}-profile_common
163 %description profile_wearable
164 The DALi Tizen Adaptor for wearable.
167 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
168 # if ivi ||"undefined"
169 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
171 Summary: The DALi Tizen Adaptor for ivi
172 Provides: %{name}-compat = %{version}-%{release}
173 Conflicts: %{name}-profile_mobile
174 Conflicts: %{name}-profile_wearable
175 Conflicts: %{name}-profile_tv
176 Conflicts: %{name}-profile_common
178 %description profile_ivi
179 The DALi Tizen Adaptor for ivi.
182 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
183 # if common ||"undefined"
184 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
185 # Currently Tizen Common we use does not have wayland extensions like xdg-shell
186 %package profile_common
187 Summary: The DALi Tizen Adaptor for common
188 Provides: %{name}-compat = %{version}-%{release}
189 Conflicts: %{name}-profile_mobile
190 Conflicts: %{name}-profile_wearable
191 Conflicts: %{name}-profile_tv
192 Conflicts: %{name}-profile_ivi
194 %description profile_common
195 The DALi Tizen Adaptor for common.
198 ##############################
200 ##############################
202 Summary: Development components for the DALi Tizen Adaptor
203 Group: Development/Building
204 Requires: %{name} = %{version}-%{release}
205 Requires: %{name}-integration-devel = %{version}-%{release}
208 Development components for the DALi Tizen Adaptor - public headers and package configs
210 ##############################
212 ##############################
213 %package integration-devel
214 Summary: Integration development package for the Adaptor
215 Group: Development/Building
216 Requires: %{name} = %{version}-%{release}
218 %description integration-devel
219 Integration development package for the Adaptor - headers for integrating with an adaptor library.
221 ##############################
222 # Dali Feedback Plugin
223 ##############################
224 %package dali2-feedback-plugin
225 Summary: Plugin to play haptic and audio feedback for Dali
226 Group: System/Libraries
227 Requires: %{name} = %{version}-%{release}
228 %description dali2-feedback-plugin
229 Feedback plugin to play haptic and audio feedback for Dali
231 ##############################
233 ##############################
237 #Use TZ_PATH when tizen version is 3.x or greater
239 %define dali_data_rw_dir %TZ_SYS_RO_SHARE/dali/
240 %define dali_data_ro_dir %TZ_SYS_RO_SHARE/dali/
241 %define font_preloaded_path %TZ_SYS_RO_SHARE/fonts/
242 %define font_downloaded_path %TZ_SYS_SHARE/fonts/
243 %define font_application_path %TZ_SYS_RO_SHARE/app_fonts/
244 %define font_configuration_file %TZ_SYS_ETC/fonts/conf.avail/99-slp.conf
246 %define user_shader_cache_dir %{dali_data_ro_dir}/core/shaderbin/
247 %define dali_plugin_sound_files /plugins/sounds/
249 ##############################
251 ##############################
254 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections -DGL_GLEXT_PROTOTYPES"
255 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -lttrace -Wl,-Bsymbolic-functions "
258 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
262 CXXFLAGS+=" -DWAYLAND"
263 cmake_flags=" -DENABLE_WAYLAND=ON"
265 # Use this conditional when Tizen version is 5.x or greater
266 %if 0%{?tizen_version_major} >= 5
267 CXXFLAGS+=" -DOVER_TIZEN_VERSION_5"
269 # Need Ecore-Wayland2 when Tizen version is 5.x or greater
270 CFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
271 CXXFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
272 cmake_flags+=" -DENABLE_ECORE_WAYLAND2=ON"
275 %if 0%{?enable_debug}
276 cmake_flags+=" -DCMAKE_BUILD_TYPE=Debug"
279 %if 0%{?enable_trace}
280 cmake_flags+=" -DENABLE_TRACE=ON"
284 cd %{_builddir}/%{name}-%{version}/build/tizen
286 DALI_DATA_RW_DIR="%{dali_data_rw_dir}" ; export DALI_DATA_RW_DIR
287 DALI_DATA_RO_DIR="%{dali_data_ro_dir}" ; export DALI_DATA_RO_DIR
288 FONT_PRELOADED_PATH="%{font_preloaded_path}" ; export FONT_PRELOADED_PATH
289 FONT_DOWNLOADED_PATH="%{font_downloaded_path}" ; export FONT_DOWNLOADED_PATH
290 FONT_APPLICATION_PATH="%{font_application_path}" ; export FONT_APPLICATION_PATH
291 FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION_FILE
292 %if 0%{?tizen_platform_config_supported}
293 TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TIZEN_PLATFORM_CONFIG_SUPPORTED
296 cmake_flags+=" -DCMAKE_INSTALL_PREFIX=$PREFIX"
297 cmake_flags+=" -DCMAKE_INSTALL_LIBDIR=%{_libdir}"
298 cmake_flags+=" -DCMAKE_INSTALL_INCLUDEDIR=%{_includedir}"
299 cmake_flags+=" -DENABLE_TIZEN_MAJOR_VERSION=%{tizen_version_major}"
300 cmake_flags+=" -DENABLE_FEEDBACK=YES"
301 cmake_flags+=" -DENABLE_APPFW=YES"
302 cmake_flags+=" -DCOMPONENT_APPLICATION_SUPPORT=YES"
304 # Set up the build via Cmake
305 #######################################################################
306 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
307 # if mobile || "undefined"
308 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
313 cmake -DENABLE_PROFILE=MOBILE $cmake_flags ..
316 make %{?jobs:-j%jobs}
321 #######################################################################
322 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
323 # if tv ||"undefined"
324 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
329 cmake -DENABLE_PROFILE=TV $cmake_flags ..
332 make %{?jobs:-j%jobs}
337 #######################################################################
338 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
339 # if wearable || "undefined"
340 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
345 cmake -DENABLE_PROFILE=WEARABLE $cmake_flags ..
348 make %{?jobs:-j%jobs}
353 #######################################################################
354 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
355 # if ivi ||"undefined"
356 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
361 cmake -DENABLE_PROFILE=IVI $cmake_flags ..
364 make %{?jobs:-j%jobs}
369 #######################################################################
371 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
372 # if common ||"undefined"
373 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
378 cmake -DENABLE_PROFILE=COMMON $cmake_flags ..
381 make %{?jobs:-j%jobs}
386 ##############################
388 ##############################
392 pushd %{_builddir}/%{name}-%{version}/build/tizen
394 # if mobile || "undefined"
395 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
398 %if "%{?profile}" != "mobile"
399 pushd %{buildroot}%{_libdir}
400 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.mobile # If we're only building this profile, then there's no need to copy the lib
402 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
407 # if tv ||"undefined"
408 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
411 %if "%{?profile}" != "tv"
412 pushd %{buildroot}%{_libdir}
413 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.tv # If we're only building this profile, then there's no need to copy the lib
415 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
420 # if wearable || "undefined"
421 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
424 %if "%{?profile}" != "wearable"
425 pushd %{buildroot}%{_libdir}
426 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.wearable # If we're only building this profile, then there's no need to copy the lib
428 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
433 # if ivi ||"undefined"
434 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
437 %if "%{?profile}" != "ivi"
438 pushd %{buildroot}%{_libdir}
439 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.ivi # If we're only building this profile, then there's no need to copy the lib
441 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
446 # if common ||"undefined"
447 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
450 # No clean so we can gather symbol/size information for the common profile
454 # Create a symbolic link in integration-api to preserve legacy repo build
455 pushd %{buildroot}%{_includedir}/dali/integration-api
456 ln -sf adaptor-framework adaptors
459 ##############################
461 # 1 - Pre Install new package
462 # 2 - Install new package
463 # 3 - Post install new package
464 # 4 - Pre uninstall old package
465 # 5 - Remove files not overwritten by new package
466 # 6 - Post uninstall old package
467 ##############################
469 ##############################
470 # Adaptor package Commands
476 for i in mobile tv wearable ivi; do [[ -f libdali2-adaptor.so.$i ]] && ln -sf libdali2-adaptor.so.$i libdali2-adaptor.so.2.0.0; done
488 ##############################
489 # Mobile Profile Commands
490 # if mobile || "undefined"
491 # No need to create a symbolic link on install required if only building this profile
492 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
494 %if "%{?profile}" != "mobile"
496 ln -sf libdali2-adaptor.so.mobile libdali2-adaptor.so.2.0.0
502 %postun profile_mobile
507 ##############################
508 # TV Profile Commands
509 # No need to create a symbolic link on install required if only building this profile
510 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
512 %if "%{?profile}" != "tv"
514 ln -sf libdali2-adaptor.so.tv libdali2-adaptor.so.2.0.0
525 ##############################
526 # Wearable Profile Commands
527 # No need to create a symbolic link on install required if only building this profile
528 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
529 %post profile_wearable
530 %if "%{?profile}" != "wearable"
532 ln -sf libdali2-adaptor.so.wearable libdali2-adaptor.so.2.0.0
538 %postun profile_wearable
543 ##############################
544 # IVI Profile Commands
545 # No need to create a symbolic link on install required if only building this profile
546 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
548 %if "%{?profile}" != "ivi"
550 ln -sf libdali2-adaptor.so.ivi libdali2-adaptor.so.2.0.0
561 ##############################
562 # Common Profile Commands
563 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
568 %postun profile_common
573 ##############################
574 # Files in Binary Packages
575 ##############################
578 %manifest dali-adaptor.manifest
579 %defattr(-,root,root,-)
580 %dir %{user_shader_cache_dir}
583 %defattr(-,root,root,-)
584 %{_libdir}/libdali2-adaptor.so
585 %{_libdir}/libdali2-adaptor.so.2
586 %{_libdir}/libdali2-adaptor.so.2.0.0
588 #################################################
590 %files dali2-feedback-plugin
591 %manifest dali-adaptor.manifest
592 %defattr(-,root,root,-)
593 %{_libdir}/libdali2-feedback-plugin.so*
594 %{dali_plugin_sound_files}/*
596 #################################################
598 # if common ||"undefined"
599 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
600 %files profile_common
601 %manifest dali-adaptor.manifest
602 # default .so files are housed in the main pkg.
605 # if mobile || "undefined"
606 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
607 %files profile_mobile
608 %manifest dali-adaptor.manifest
609 %defattr(-,root,root,-)
610 %if "%{?profile}" != "mobile"
611 %{_libdir}/libdali2-adaptor.so.mobile
615 # if tv ||"undefined"
616 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
618 %manifest dali-adaptor.manifest
619 %defattr(-,root,root,-)
620 %if "%{?profile}" != "tv"
621 %{_libdir}/libdali2-adaptor.so.tv
625 # if wearable || "undefined"
626 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
627 %files profile_wearable
628 %manifest dali-adaptor.manifest
629 %defattr(-,root,root,-)
630 %if "%{?profile}" != "wearable"
631 %{_libdir}/libdali2-adaptor.so.wearable
635 # if ivi ||"undefined"
636 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
638 %manifest dali-adaptor.manifest
639 %defattr(-,root,root,-)
640 %if "%{?profile}" != "ivi"
641 %{_libdir}/libdali2-adaptor.so.ivi
646 %defattr(-,root,root,-)
647 %{_includedir}/dali/dali.h
648 %{_includedir}/dali/public-api/*
649 %{_includedir}/dali/devel-api/*
650 %{_includedir}/dali/doc/*
651 %{_libdir}/pkgconfig/dali2-adaptor.pc
653 %files integration-devel
654 %defattr(-,root,root,-)
655 %{_includedir}/dali/integration-api/adaptor-framework/*
656 %{_includedir}/dali/integration-api/adaptors
657 %{_libdir}/pkgconfig/dali2-adaptor-integration.pc