2 # This spec file is used to build DALi Adaptor for different Tizen Profiles
3 # Current profiles are: Mobile, TV, Wearable, Common
5 # The profile variable is defined outside of the spec file in a build.conf file.
6 # It will contain the profile and whether or not to build with X11 or Wayland
8 # gbs will try to download the build.conf for the platform automatically from the repo location when
9 # performing a gbs build ( use gbs build -v to see it download location) E.g.
10 # http://download.tizen.org/snapshots/tizen/tv/tizen-tv/repos/arm-wayland/packages/repodata/xxxx-build.conf.gz
12 # Do not provide .so automatically for the extensions.
13 # This if statement is for backward compatibility with GBM/Obsolete build systems
14 %if "%{?profile}" != "wearable" && "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
15 %global __provides_exclude_from ^.*\\.(wearable|mobile|tv|ivi|common)$
19 Summary: The DALi Tizen Adaptor
22 Group: System/Libraries
23 License: Apache-2.0 and BSD-3-Clause and MIT
24 URL: https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
25 Source0: %{name}-%{version}.tar.gz
27 Requires(post): /sbin/ldconfig
28 Requires(postun): /sbin/ldconfig
31 %define tizen_platform_config_supported 1
32 BuildRequires: pkgconfig(libtzplatform-config)
34 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
35 # if wearable || "undefined"
36 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
37 BuildRequires: pkgconfig(capi-appfw-watch-application)
38 BuildRequires: pkgconfig(appcore-watch)
41 BuildRequires: pkgconfig(screen_connector_provider)
42 BuildRequires: pkgconfig(gles20)
43 BuildRequires: pkgconfig(glesv2)
44 BuildRequires: pkgconfig(ttrace)
46 BuildRequires: dali2-devel
47 BuildRequires: dali2-integration-devel
49 BuildRequires: pkgconfig
52 BuildRequires: giflib-devel
53 BuildRequires: pkgconfig(fontconfig)
54 BuildRequires: libjpeg-turbo-devel
55 BuildRequires: pkgconfig(vconf)
56 BuildRequires: tts-devel
57 BuildRequires: pkgconfig(dlog)
58 BuildRequires: libdrm-devel
59 BuildRequires: pkgconfig(libexif)
60 BuildRequires: pkgconfig(libpng)
61 BuildRequires: pkgconfig(egl)
62 BuildRequires: libcurl-devel
63 BuildRequires: pkgconfig(harfbuzz)
64 BuildRequires: hyphen-devel
65 BuildRequires: fribidi-devel
67 BuildRequires: pkgconfig(capi-system-info)
68 BuildRequires: pkgconfig(capi-system-sensor)
70 BuildRequires: pkgconfig(cairo)
72 BuildRequires: pkgconfig(wayland-egl)
73 BuildRequires: pkgconfig(wayland-client)
74 BuildRequires: pkgconfig(input-method-client)
75 BuildRequires: wayland-devel
76 BuildRequires: wayland-extension-client-devel
78 # WebP support only from Tizen 6 onwards
79 %if 0%{?tizen_version_major} >= 6
80 BuildRequires: pkgconfig(libwebp)
81 BuildRequires: pkgconfig(libwebpdecoder)
82 BuildRequires: pkgconfig(libwebpdemux)
83 BuildRequires: pkgconfig(libwebpmux)
86 # We use ecore mainloop
87 %if 0%{?tizen_version_major} >= 5
88 BuildRequires: pkgconfig(ecore-wl2)
89 BuildRequires: pkgconfig(wayland-egl-tizen)
91 BuildRequires: pkgconfig(ecore-wayland)
94 # We need tbm_surface in tizen 3.0 wayland
95 BuildRequires: pkgconfig(libtbm)
98 BuildRequires: pkgconfig(app-core-ui-cpp)
99 BuildRequires: pkgconfig(appcore-widget-base)
100 BuildRequires: pkgconfig(bundle)
101 BuildRequires: pkgconfig(capi-appfw-app-common)
102 BuildRequires: pkgconfig(capi-appfw-app-control)
103 BuildRequires: pkgconfig(ecore-imf)
105 BuildRequires: pkgconfig(capi-system-system-settings)
107 # for ATSPI (Accessibility) support
108 BuildRequires: pkgconfig(eldbus)
110 # for feedback plugin
111 BuildRequires: pkgconfig(mm-sound)
112 BuildRequires: pkgconfig(feedback)
113 BuildRequires: pkgconfig(component-based-core-base)
116 %if ( 0%{?tizen_version_major} == 6 && 0%{?tizen_version_minor} >= 5 ) || 0%{?tizen_version_major} >= 7
117 BuildRequires: pkgconfig(thorvg)
121 Requires: %{name}-compat = %{version}-%{release}
122 Recommends: %{name}-profile_common = %{version}-%{release}
125 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
126 platform abstraction and application shell
128 ###########################################
129 # Dali adapter for profiles
130 ###########################################
132 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
133 # if mobile || "undefined"
134 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
135 %package profile_mobile
136 Summary: The DALi Tizen Adaptor for mobile
137 Provides: %{name}-compat = %{version}-%{release}
138 Conflicts: %{name}-profile_tv
139 Conflicts: %{name}-profile_wearable
140 Conflicts: %{name}-profile_ivi
141 Conflicts: %{name}-profile_common
143 %description profile_mobile
144 The DALi Tizen Adaptor for mobile.
147 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
148 # if tv ||"undefined"
149 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
151 Summary: The DALi Tizen Adaptor for tv
152 Provides: %{name}-compat = %{version}-%{release}
153 Conflicts: %{name}-profile_mobile
154 Conflicts: %{name}-profile_wearable
155 Conflicts: %{name}-profile_ivi
156 Conflicts: %{name}-profile_common
158 %description profile_tv
159 The DALi Tizen Adaptor for tv.
162 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
163 # if wearable || "undefined"
164 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
165 %package profile_wearable
166 Summary: The DALi Tizen Adaptor for wearable
167 Provides: %{name}-compat = %{version}-%{release}
168 Conflicts: %{name}-profile_mobile
169 Conflicts: %{name}-profile_tv
170 Conflicts: %{name}-profile_ivi
171 Conflicts: %{name}-profile_common
173 %description profile_wearable
174 The DALi Tizen Adaptor for wearable.
177 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
178 # if ivi ||"undefined"
179 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
181 Summary: The DALi Tizen Adaptor for ivi
182 Provides: %{name}-compat = %{version}-%{release}
183 Conflicts: %{name}-profile_mobile
184 Conflicts: %{name}-profile_wearable
185 Conflicts: %{name}-profile_tv
186 Conflicts: %{name}-profile_common
188 %description profile_ivi
189 The DALi Tizen Adaptor for ivi.
192 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
193 # if common ||"undefined"
194 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
195 # Currently Tizen Common we use does not have wayland extensions like xdg-shell
196 %package profile_common
197 Summary: The DALi Tizen Adaptor for common
198 Provides: %{name}-compat = %{version}-%{release}
199 Conflicts: %{name}-profile_mobile
200 Conflicts: %{name}-profile_wearable
201 Conflicts: %{name}-profile_tv
202 Conflicts: %{name}-profile_ivi
204 %description profile_common
205 The DALi Tizen Adaptor for common.
208 ##############################
210 ##############################
212 Summary: Development components for the DALi Tizen Adaptor
213 Group: Development/Building
214 Requires: %{name} = %{version}-%{release}
215 Requires: %{name}-integration-devel = %{version}-%{release}
218 Development components for the DALi Tizen Adaptor - public headers and package configs
220 ##############################
222 ##############################
223 %package integration-devel
224 Summary: Integration development package for the Adaptor
225 Group: Development/Building
226 Requires: %{name} = %{version}-%{release}
228 %description integration-devel
229 Integration development package for the Adaptor - headers for integrating with an adaptor library.
231 ##############################
232 # Dali Feedback Plugin
233 ##############################
234 %package dali2-feedback-plugin
235 Summary: Plugin to play haptic and audio feedback for Dali
236 Group: System/Libraries
237 Requires: %{name} = %{version}-%{release}
238 %description dali2-feedback-plugin
239 Feedback plugin to play haptic and audio feedback for Dali
241 #Use TZ_PATH when tizen version is 3.x or greater
242 %define dali_data_rw_dir %TZ_SYS_RO_SHARE/dali/
243 %define dali_data_ro_dir %TZ_SYS_RO_SHARE/dali/
244 %define font_preloaded_path %TZ_SYS_RO_SHARE/fonts/
245 %define font_downloaded_path %TZ_SYS_SHARE/fonts/
246 %define font_application_path %TZ_SYS_RO_SHARE/app_fonts/
247 %define font_configuration_file %TZ_SYS_ETC/fonts/conf.avail/99-slp.conf
249 %define user_shader_cache_dir %{dali_data_ro_dir}/core/shaderbin/
250 %define dali_plugin_sound_files /plugins/sounds/
252 ##############################
254 ##############################
259 ##############################
261 ##############################
264 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections -DGL_GLEXT_PROTOTYPES"
265 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -lttrace -Wl,-Bsymbolic-functions "
268 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
272 CXXFLAGS+=" -DWAYLAND"
273 cmake_flags=" -DENABLE_WAYLAND=ON -DENABLE_ATSPI=ON -DENABLE_TRACE=ON"
275 # Use this conditional when Tizen version is 5.x or greater
276 %if 0%{?tizen_version_major} >= 5
277 CXXFLAGS+=" -DOVER_TIZEN_VERSION_5"
279 # Need Ecore-Wayland2 when Tizen version is 5.x or greater
280 CFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
281 CXXFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
282 cmake_flags+=" -DENABLE_ECORE_WAYLAND2=ON"
285 # Use this conditional when Tizen version is 7.x or greater
286 %if 0%{?tizen_version_major} >= 7
287 CXXFLAGS+=" -DOVER_TIZEN_VERSION_7"
290 %if 0%{?enable_debug}
291 cmake_flags+=" -DCMAKE_BUILD_TYPE=Debug"
294 %if 0%{?enable_logging}
295 cmake_flags+=" -DENABLE_NETWORK_LOGGING=ON"
299 cd %{_builddir}/%{name}-%{version}/build/tizen
301 DALI_DATA_RW_DIR="%{dali_data_rw_dir}" ; export DALI_DATA_RW_DIR
302 DALI_DATA_RO_DIR="%{dali_data_ro_dir}" ; export DALI_DATA_RO_DIR
303 FONT_PRELOADED_PATH="%{font_preloaded_path}" ; export FONT_PRELOADED_PATH
304 FONT_DOWNLOADED_PATH="%{font_downloaded_path}" ; export FONT_DOWNLOADED_PATH
305 FONT_APPLICATION_PATH="%{font_application_path}" ; export FONT_APPLICATION_PATH
306 FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION_FILE
307 %if 0%{?tizen_platform_config_supported}
308 TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TIZEN_PLATFORM_CONFIG_SUPPORTED
311 cmake_flags+=" -DCMAKE_INSTALL_PREFIX=$PREFIX"
312 cmake_flags+=" -DCMAKE_INSTALL_LIBDIR=%{_libdir}"
313 cmake_flags+=" -DCMAKE_INSTALL_INCLUDEDIR=%{_includedir}"
314 cmake_flags+=" -DENABLE_TIZEN_MAJOR_VERSION=%{tizen_version_major}"
315 cmake_flags+=" -DENABLE_FEEDBACK=YES"
316 cmake_flags+=" -DENABLE_APPFW=YES"
317 cmake_flags+=" -DCOMPONENT_APPLICATION_SUPPORT=YES"
319 # Set up the build via Cmake
320 #######################################################################
321 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
322 # if mobile || "undefined"
323 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
328 cmake -DENABLE_PROFILE=MOBILE $cmake_flags ..
331 make %{?jobs:-j%jobs}
336 #######################################################################
337 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
338 # if tv ||"undefined"
339 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
344 cmake -DENABLE_PROFILE=TV $cmake_flags ..
347 make %{?jobs:-j%jobs}
352 #######################################################################
353 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
354 # if wearable || "undefined"
355 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
360 cmake -DENABLE_PROFILE=WEARABLE $cmake_flags ..
363 make %{?jobs:-j%jobs}
368 #######################################################################
369 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
370 # if ivi ||"undefined"
371 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
376 cmake -DENABLE_PROFILE=IVI $cmake_flags ..
379 make %{?jobs:-j%jobs}
384 #######################################################################
386 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
387 # if common ||"undefined"
388 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
393 cmake -DENABLE_PROFILE=COMMON $cmake_flags ..
396 make %{?jobs:-j%jobs}
401 ##############################
403 ##############################
407 pushd %{_builddir}/%{name}-%{version}/build/tizen
409 # if mobile || "undefined"
410 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
413 %if "%{?profile}" != "mobile"
414 pushd %{buildroot}%{_libdir}
415 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.mobile # If we're only building this profile, then there's no need to copy the lib
417 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
422 # if tv ||"undefined"
423 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
426 %if "%{?profile}" != "tv"
427 pushd %{buildroot}%{_libdir}
428 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.tv # If we're only building this profile, then there's no need to copy the lib
430 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
435 # if wearable || "undefined"
436 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
439 %if "%{?profile}" != "wearable"
440 pushd %{buildroot}%{_libdir}
441 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.wearable # If we're only building this profile, then there's no need to copy the lib
443 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
448 # if ivi ||"undefined"
449 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
452 %if "%{?profile}" != "ivi"
453 pushd %{buildroot}%{_libdir}
454 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.ivi # If we're only building this profile, then there's no need to copy the lib
456 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
461 # if common ||"undefined"
462 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
465 # No clean so we can gather symbol/size information for the common profile
469 # Create a symbolic link in integration-api to preserve legacy repo build
470 pushd %{buildroot}%{_includedir}/dali/integration-api
471 ln -sf adaptor-framework adaptors
474 ##############################
476 # 1 - Pre Install new package
477 # 2 - Install new package
478 # 3 - Post install new package
479 # 4 - Pre uninstall old package
480 # 5 - Remove files not overwritten by new package
481 # 6 - Post uninstall old package
482 ##############################
484 ##############################
485 # Adaptor package Commands
491 for i in mobile tv wearable ivi; do [[ -f libdali2-adaptor.so.$i ]] && ln -sf libdali2-adaptor.so.$i libdali2-adaptor.so.2.0.0; done
503 ##############################
504 # Mobile Profile Commands
505 # if mobile || "undefined"
506 # No need to create a symbolic link on install required if only building this profile
507 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
509 %if "%{?profile}" != "mobile"
511 ln -sf libdali2-adaptor.so.mobile libdali2-adaptor.so.2.0.0
517 %postun profile_mobile
522 ##############################
523 # TV Profile Commands
524 # No need to create a symbolic link on install required if only building this profile
525 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
527 %if "%{?profile}" != "tv"
529 ln -sf libdali2-adaptor.so.tv libdali2-adaptor.so.2.0.0
540 ##############################
541 # Wearable Profile Commands
542 # No need to create a symbolic link on install required if only building this profile
543 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
544 %post profile_wearable
545 %if "%{?profile}" != "wearable"
547 ln -sf libdali2-adaptor.so.wearable libdali2-adaptor.so.2.0.0
553 %postun profile_wearable
558 ##############################
559 # IVI Profile Commands
560 # No need to create a symbolic link on install required if only building this profile
561 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
563 %if "%{?profile}" != "ivi"
565 ln -sf libdali2-adaptor.so.ivi libdali2-adaptor.so.2.0.0
576 ##############################
577 # Common Profile Commands
578 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
583 %postun profile_common
588 ##############################
589 # Files in Binary Packages
590 ##############################
593 %manifest dali-adaptor.manifest
594 %defattr(-,root,root,-)
595 %dir %{user_shader_cache_dir}
598 %defattr(-,root,root,-)
599 %{_libdir}/libdali2-adaptor.so
600 %{_libdir}/libdali2-adaptor.so.2
601 %{_libdir}/libdali2-adaptor.so.2.0.0
603 #################################################
605 %files dali2-feedback-plugin
606 %manifest dali-adaptor.manifest
607 %defattr(-,root,root,-)
608 %{_libdir}/libdali2-feedback-plugin.so*
609 %{dali_plugin_sound_files}/*
611 #################################################
613 # if common ||"undefined"
614 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
615 %files profile_common
616 %manifest dali-adaptor.manifest
617 # default .so files are housed in the main pkg.
620 # if mobile || "undefined"
621 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
622 %files profile_mobile
623 %manifest dali-adaptor.manifest
624 %defattr(-,root,root,-)
625 %if "%{?profile}" != "mobile"
626 %{_libdir}/libdali2-adaptor.so.mobile
630 # if tv ||"undefined"
631 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
633 %manifest dali-adaptor.manifest
634 %defattr(-,root,root,-)
635 %if "%{?profile}" != "tv"
636 %{_libdir}/libdali2-adaptor.so.tv
640 # if wearable || "undefined"
641 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
642 %files profile_wearable
643 %manifest dali-adaptor.manifest
644 %defattr(-,root,root,-)
645 %if "%{?profile}" != "wearable"
646 %{_libdir}/libdali2-adaptor.so.wearable
650 # if ivi ||"undefined"
651 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
653 %manifest dali-adaptor.manifest
654 %defattr(-,root,root,-)
655 %if "%{?profile}" != "ivi"
656 %{_libdir}/libdali2-adaptor.so.ivi
661 %defattr(-,root,root,-)
662 %{_includedir}/dali/dali.h
663 %{_includedir}/dali/public-api/*
664 %{_includedir}/dali/devel-api/*
665 %{_includedir}/dali/doc/*
666 %{_libdir}/pkgconfig/dali2-adaptor.pc
668 %files integration-devel
669 %defattr(-,root,root,-)
670 %{_includedir}/dali/integration-api/adaptor-framework/*
671 %{_includedir}/dali/integration-api/adaptors
672 %{_libdir}/pkgconfig/dali2-adaptor-integration.pc