Revert "[Tizen] Implement WebEngineLite interface and plugin for Minimized Web Engine"
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
1 # NOTES
2 # This spec file is used to build DALi Adaptor for different Tizen Profiles
3 # Current profiles are:  Mobile, TV, Wearable, Common
4 #
5 # The profile variable is defined outside of the spec file in a build.conf file.
6 # It will contain the profile and whether or not to build with X11 or Wayland
7 #
8 # gbs will try to download the build.conf for the platform automatically from the repo location when
9 # performing a gbs build ( use gbs build -v to see it download location) E.g.
10 # http://download.tizen.org/snapshots/tizen/tv/tizen-tv/repos/arm-wayland/packages/repodata/xxxx-build.conf.gz
11
12 # Do not provide .so automatically for the extensions.
13 # This if statement is for backward compatibility with GBM/Obsolete build systems
14 %if "%{?profile}" != "wearable" && "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
15 %global __provides_exclude_from ^.*\\.(wearable|mobile|tv|ivi|common)$
16 %endif
17
18 %bcond_with wayland
19
20 Name:       dali-adaptor
21 Summary:    The DALi Tizen Adaptor
22 Version:    1.2.54
23 Release:    1
24 Group:      System/Libraries
25 License:    Apache-2.0 and BSD-3-Clause and MIT
26 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
27 Source0:    %{name}-%{version}.tar.gz
28
29 Requires(post): /sbin/ldconfig
30 Requires(postun): /sbin/ldconfig
31 Requires:       giflib
32
33 #need libtzplatform-config for directory if tizen version is 3.x
34
35 %if 0%{?tizen_version_major} >= 3
36 %define tizen_platform_config_supported 1
37 BuildRequires:  pkgconfig(libtzplatform-config)
38 %endif
39
40 # Get the profile from tizen_profile_name if tizen version is 2.x and tizen_profile_name exists.
41
42 %if "%{tizen_version_major}" == "2" && 0%{?tizen_profile_name:1}
43 %define profile %{tizen_profile_name}
44 %endif
45
46 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
47 # if wearable || "undefined"
48 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
49 BuildRequires:  pkgconfig(capi-appfw-watch-application)
50 BuildRequires:  pkgconfig(appcore-watch)
51 BuildRequires:  pkgconfig(screen_connector_provider)
52 %endif
53
54 BuildRequires:  pkgconfig(gles20)
55 BuildRequires:  pkgconfig(glesv2)
56
57 BuildRequires:  pkgconfig
58 BuildRequires:  gawk
59 BuildRequires:  giflib-devel
60 BuildRequires:  pkgconfig(fontconfig)
61 BuildRequires:  libjpeg-turbo-devel
62 BuildRequires:  dali-devel
63 BuildRequires:  dali-integration-devel
64 BuildRequires:  pkgconfig(vconf)
65 BuildRequires:  tts-devel
66 BuildRequires:  pkgconfig(dlog)
67 BuildRequires:  libdrm-devel
68 BuildRequires:  pkgconfig(libexif)
69 BuildRequires:  pkgconfig(libpng)
70 BuildRequires:  pkgconfig(egl)
71 BuildRequires:  libcurl-devel
72 BuildRequires:  pkgconfig(harfbuzz)
73 BuildRequires:  fribidi-devel
74
75 BuildRequires:  pkgconfig(capi-system-info)
76 BuildRequires:  pkgconfig(capi-system-sensor)
77
78 %if %{with wayland}
79
80 ####### BUILDING FOR WAYLAND #######
81 BuildRequires:  pkgconfig(wayland-egl)
82 BuildRequires:  pkgconfig(wayland-client)
83 BuildRequires:  wayland-devel
84 BuildRequires:  wayland-extension-client-devel
85
86 # dali-adaptor uses ecore mainloop
87 BuildRequires:  pkgconfig(ecore-wayland)
88
89 # dali-adaptor needs tbm_surface in tizen 3.0 wayland
90 BuildRequires:  pkgconfig(libtbm)
91
92 # tpkp-curl (certificate pinning for libcurl functions) is only available in Tizen 3.0
93 BuildRequires:  pkgconfig(tpkp-curl)
94
95 ####### BUILDING FOR X11#######
96 %else
97 BuildRequires:  pkgconfig(egl)
98 BuildRequires:  pkgconfig(xext)
99 BuildRequires:  pkgconfig(xi)
100 BuildRequires:  pkgconfig(xfixes)
101 BuildRequires:  pkgconfig(xdamage)
102 BuildRequires:  pkgconfig(utilX)
103 %endif
104
105 # for dali-adaptor
106 BuildRequires:  pkgconfig(evas)
107
108 %if 0%{?tizen_version_major} == 3
109 BuildRequires:  pkgconfig(capi-appfw-application)
110 BuildRequires:  pkgconfig(elementary)
111 %else
112 BuildRequires:  pkgconfig(bundle)
113 BuildRequires:  pkgconfig(appcore-ui)
114 BuildRequires:  pkgconfig(appcore-multiwindow)
115 BuildRequires:  pkgconfig(capi-appfw-app-common)
116 BuildRequires:  pkgconfig(capi-appfw-app-control)
117 BuildRequires:  pkgconfig(screen_connector_provider)
118 BuildRequires:  pkgconfig(ecore-imf)
119 %endif
120
121 BuildRequires:  pkgconfig(capi-system-system-settings)
122
123 # for feedback plugin
124 BuildRequires:  pkgconfig(mm-sound)
125 %if 0%{?tizen_version_major} >= 3
126 BuildRequires:  pkgconfig(feedback)
127 %endif
128
129 # for videoplayer Plugin
130 BuildRequires:  pkgconfig(capi-media-player)
131
132
133 # for multiprofile
134 Requires:   %{name}-compat = %{version}-%{release}
135 Recommends: %{name}-profile_common = %{version}-%{release}
136
137 %description
138 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
139 platform abstraction and application shell
140
141 ###########################################
142 # Dali adapter for profiles
143 ###########################################
144
145 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
146 # if mobile || "undefined"
147 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
148 %package profile_mobile
149 Summary:        The DALi Tizen Adaptor for mobile
150 Provides:       %{name}-compat = %{version}-%{release}
151 Conflicts:      %{name}-profile_tv
152 Conflicts:      %{name}-profile_wearable
153 Conflicts:      %{name}-profile_ivi
154 Conflicts:      %{name}-profile_common
155 %description profile_mobile
156 The DALi Tizen Adaptor for mobile.
157 %endif
158
159 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
160 # if tv ||"undefined"
161 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
162 %package profile_tv
163 Summary:        The DALi Tizen Adaptor for tv
164 Provides:       %{name}-compat = %{version}-%{release}
165 Conflicts:      %{name}-profile_mobile
166 Conflicts:      %{name}-profile_wearable
167 Conflicts:      %{name}-profile_ivi
168 Conflicts:      %{name}-profile_common
169 %description profile_tv
170 The DALi Tizen Adaptor for tv.
171 %endif
172
173 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
174 # if wearable || "undefined"
175 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
176 %package profile_wearable
177 Summary:        The DALi Tizen Adaptor for wearable
178 Provides:       %{name}-compat = %{version}-%{release}
179 Conflicts:      %{name}-profile_mobile
180 Conflicts:      %{name}-profile_tv
181 Conflicts:      %{name}-profile_ivi
182 Conflicts:      %{name}-profile_common
183 %description profile_wearable
184 The DALi Tizen Adaptor for wearable.
185 %endif
186
187 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
188 # if ivi ||"undefined"
189 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
190 %package profile_ivi
191 Summary:        The DALi Tizen Adaptor for ivi
192 Provides:       %{name}-compat = %{version}-%{release}
193 Conflicts:      %{name}-profile_mobile
194 Conflicts:      %{name}-profile_wearable
195 Conflicts:      %{name}-profile_tv
196 Conflicts:      %{name}-profile_common
197 %description profile_ivi
198 The DALi Tizen Adaptor for ivi.
199 %endif
200
201 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
202 # if common ||"undefined"
203 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
204 # Currently Tizen Common we use does not have wayland extensions like xdg-shell
205 %package profile_common
206 %define tizen_2_2_compatibility 0
207 Summary:        The DALi Tizen Adaptor for common
208 Provides:       %{name}-compat = %{version}-%{release}
209 Conflicts:      %{name}-profile_mobile
210 Conflicts:      %{name}-profile_wearable
211 Conflicts:      %{name}-profile_tv
212 Conflicts:      %{name}-profile_ivi
213 %description profile_common
214 The DALi Tizen Adaptor for common.
215 %endif
216
217 ##############################
218 # devel
219 ##############################
220 %package devel
221 Summary:    Development components for the DALi Tizen Adaptor
222 Group:      Development/Building
223 Requires:   %{name} = %{version}-%{release}
224 Requires:   %{name}-integration-devel = %{version}-%{release}
225
226 %description devel
227 Development components for the DALi Tizen Adaptor - public headers and package configs
228
229 ##############################
230 # integration-devel
231 ##############################
232 %package integration-devel
233 Summary:    Integration development package for the Adaptor
234 Group:      Development/Building
235 Requires:   %{name} = %{version}-%{release}
236
237 %description integration-devel
238 Integration development package for the Adaptor - headers for integrating with an adaptor library.
239
240 ##############################
241 # Dali Feedback Plugin
242 ##############################
243 %package dali-feedback-plugin
244 Summary:    Plugin to play haptic and audio feedback for Dali
245 Group:      System/Libraries
246 Requires:   %{name} = %{version}-%{release}
247 %description dali-feedback-plugin
248 Feedback plugin to play haptic and audio feedback for Dali
249
250 ##############################
251 # Dali VideoPlayer Plugin
252 ##############################
253 %if %{with wayland}
254
255 %package dali-video-player-plugin
256 Summary:    Plugin to play a video file for Dali
257 Group:      System/Libraries
258 %description dali-video-player-plugin
259 VideoPlayer plugin to play a video file for Dali
260 %endif
261
262 ##############################
263 # Preparation
264 ##############################
265 %prep
266 %setup -q
267
268 #Use TZ_PATH when tizen version is 3.x or greater
269
270 %if 0%{?tizen_version_major} >= 3
271 %define dali_data_rw_dir         %TZ_SYS_RO_SHARE/dali/
272 %define dali_data_ro_dir         %TZ_SYS_RO_SHARE/dali/
273 %define font_preloaded_path      %TZ_SYS_RO_SHARE/fonts/
274 %define font_downloaded_path     %TZ_SYS_SHARE/fonts/
275 %define font_application_path    %TZ_SYS_RO_SHARE/app_fonts/
276 %define font_configuration_file  %TZ_SYS_ETC/fonts/conf.avail/99-slp.conf
277 %else
278 %define dali_data_rw_dir         /usr/share/dali/
279 %define dali_data_ro_dir         /usr/share/dali/
280 %define font_preloaded_path      /usr/share/fonts/
281 %define font_downloaded_path     /opt/share/fonts/
282 %define font_application_path    /usr/share/app_fonts/
283 %define font_configuration_file  /opt/etc/fonts/conf.avail/99-slp.conf
284 %endif
285
286 %define user_shader_cache_dir    %{dali_data_ro_dir}/core/shaderbin/
287 %define dali_plugin_sound_files  /plugins/sounds/
288 %define dev_include_path %{_includedir}
289
290 ##############################
291 # Build
292 ##############################
293 %build
294 PREFIX+="/usr"
295 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections -DGL_GLEXT_PROTOTYPES"
296 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -Wl,-Bsymbolic-functions "
297
298 %ifarch %{arm}
299 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
300 %endif
301
302 %if %{with wayland}
303 CFLAGS+=" -DWAYLAND"
304 CXXFLAGS+=" -DWAYLAND"
305 configure_flags="--enable-wayland"
306 %endif
307
308 # Use this conditional when Tizen version is 4.x or greater
309 %if 0%{?tizen_version_major} >= 4
310 CXXFLAGS+=" -DOVER_TIZEN_VERSION_4"
311 %endif
312
313 %if 0%{?tizen_2_2_compatibility}
314 CFLAGS+=" -DTIZEN_SDK_2_2_COMPATIBILITY"
315 CXXFLAGS+=" -DTIZEN_SDK_2_2_COMPATIBILITY"
316 %endif
317
318 libtoolize --force
319 cd %{_builddir}/%{name}-%{version}/build/tizen
320 autoreconf --install
321
322 DALI_DATA_RW_DIR="%{dali_data_rw_dir}" ; export DALI_DATA_RW_DIR
323 DALI_DATA_RO_DIR="%{dali_data_ro_dir}"  ; export DALI_DATA_RO_DIR
324 FONT_PRELOADED_PATH="%{font_preloaded_path}" ; export FONT_PRELOADED_PATH
325 FONT_DOWNLOADED_PATH="%{font_downloaded_path}" ; export FONT_DOWNLOADED_PATH
326 FONT_APPLICATION_PATH="%{font_application_path}"  ; export FONT_APPLICATION_PATH
327 FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION_FILE
328 %if 0%{?tizen_platform_config_supported}
329 TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TIZEN_PLATFORM_CONFIG_SUPPORTED
330 %endif
331
332 # Default to GLES 2.0 if not specified.
333 %define target_gles_version 20
334
335 # Set up the build via configure.
336 #######################################################################
337 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
338 # if mobile || "undefined"
339 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
340
341 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
342            --enable-shaderbincache=DISABLE --enable-profile=MOBILE \
343            --enable-tizen-major-version=%{tizen_version_major} \
344 %if 0%{?tizen_version_major} >= 3
345            --enable-feedback \
346 %endif
347            --enable-videoplayer \
348 %if 0%{?tizen_2_2_compatibility}
349            --with-tizen-2-2-compatibility \
350 %endif
351 %if %{with wayland}
352            --enable-efl=no \
353 %else
354            --enable-efl=yes \
355 %endif
356 %if 0%{?enable_debug}
357            --enable-debug \
358 %endif
359            --enable-appfw=yes \
360            $configure_flags --libdir=%{_libdir}
361
362 # Build.
363 make %{?jobs:-j%jobs}
364
365 pushd %{_builddir}/%{name}-%{version}/build/tizen
366 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
367 popd
368
369 pushd %{buildroot}%{_libdir}
370 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.mobile"; done
371 popd
372
373 make clean
374
375 %endif
376
377 #######################################################################
378 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
379 # if tv ||"undefined"
380 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
381
382 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
383            --enable-shaderbincache=DISABLE --enable-profile=TV \
384            --enable-tizen-major-version=%{tizen_version_major} \
385 %if 0%{?tizen_version_major} >= 3
386            --enable-feedback \
387 %endif
388            --enable-videoplayer \
389 %if 0%{?tizen_2_2_compatibility}
390            --with-tizen-2-2-compatibility \
391 %endif
392 %if %{with wayland}
393            --enable-efl=no \
394 %else
395            --enable-efl=yes \
396 %endif
397 %if 0%{?enable_debug}
398            --enable-debug \
399 %endif
400            --enable-appfw=yes \
401            $configure_flags --libdir=%{_libdir}
402
403 # Build.
404 make %{?jobs:-j%jobs}
405
406 pushd %{_builddir}/%{name}-%{version}/build/tizen
407 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
408 popd
409
410 pushd %{buildroot}%{_libdir}
411 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.tv"; done
412 popd
413
414 make clean
415 %endif
416
417 #######################################################################
418 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
419 # if wearable || "undefined"
420 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
421
422 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
423            --enable-shaderbincache=DISABLE --enable-profile=WEARABLE \
424            --enable-tizen-major-version=%{tizen_version_major} \
425 %if 0%{?tizen_version_major} >= 3
426            --enable-feedback \
427 %endif
428            --enable-videoplayer \
429 %if 0%{?tizen_2_2_compatibility}
430            --with-tizen-2-2-compatibility \
431 %endif
432 %if %{with wayland}
433            --enable-efl=no \
434 %else
435            --enable-efl=yes \
436 %endif
437 %if 0%{?enable_debug}
438            --enable-debug \
439 %endif
440            --enable-appfw=yes \
441            $configure_flags --libdir=%{_libdir}
442
443 # Build.
444 make %{?jobs:-j%jobs}
445
446 pushd %{_builddir}/%{name}-%{version}/build/tizen
447 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
448 popd
449
450 pushd %{buildroot}%{_libdir}
451 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.wearable"; done
452 popd
453
454 make clean
455 %endif
456
457 #######################################################################
458 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
459 # if ivi ||"undefined"
460 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
461
462 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
463            --enable-shaderbincache=DISABLE --enable-profile=IVI \
464            --enable-tizen-major-version=%{tizen_version_major} \
465 %if 0%{?tizen_version_major} >= 3
466            --enable-feedback \
467 %endif
468            --enable-videoplayer \
469 %if 0%{?tizen_2_2_compatibility}
470            --with-tizen-2-2-compatibility \
471 %endif
472 %if %{with wayland}
473            --enable-efl=no \
474 %else
475            --enable-efl=yes \
476 %endif
477 %if 0%{?enable_debug}
478            --enable-debug \
479 %endif
480            --enable-appfw=yes \
481            $configure_flags --libdir=%{_libdir}
482
483 # Build.
484 make %{?jobs:-j%jobs}
485
486 pushd %{_builddir}/%{name}-%{version}/build/tizen
487 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
488 popd
489
490 pushd %{buildroot}%{_libdir}
491 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.ivi"; done
492 popd
493
494 make clean
495 %endif
496
497 #######################################################################
498 # common ( build dali_videoplayer_plugin for common uses )
499 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
500 # if common ||"undefined"
501 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
502
503 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
504            --enable-shaderbincache=DISABLE --enable-profile=COMMON \
505            --enable-tizen-major-version=%{tizen_version_major} \
506 %if 0%{?tizen_version_major} >= 3
507            --enable-feedback \
508 %endif
509            --enable-videoplayer \
510 %if 0%{?tizen_2_2_compatibility}
511            --with-tizen-2-2-compatibility \
512 %endif
513 %if %{with wayland}
514            --enable-efl=no \
515 %else
516            --enable-efl=yes \
517 %endif
518 %if 0%{?enable_debug}
519            --enable-debug \
520 %endif
521            --enable-appfw=yes \
522            $configure_flags --libdir=%{_libdir}
523
524 # Build.
525 make %{?jobs:-j%jobs}
526
527 %endif
528
529
530 ##############################
531 # Installation
532 ##############################
533 %install
534 rm -rf %{buildroot}
535
536 pushd %{_builddir}/%{name}-%{version}/build/tizen
537 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
538
539
540 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
541 # !unified && (wearable || tv || ivi || mobile)
542 %if "%{?profile}" == "wearable" || "%{?profile}" == "tv" || "%{?profile}" == "ivi" || "%{?profile}" == "mobile"
543 rm -rf %{buildroot}%{_libdir}/libdali-adap*.so*
544 %endif
545
546 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
547 # wearable || tv || ivi || mobile || unified
548 %if "%{?profile}" != "common"
549 for FILE in libdali-*.so*; do mv "$FILE" "%{buildroot}%{_libdir}/$FILE"; done
550 %endif
551 popd
552
553 ##############################
554 # Upgrade order:
555 # 1 - Pre Install new package
556 # 2 - Install new package
557 # 3 - Post install new package
558 # 4 - Pre uninstall old package
559 # 5 - Remove files not overwritten by new package
560 # 6 - Post uninstall old package
561 ##############################
562
563 %pre
564 exit 0
565
566 ##############################
567 #  Post Install new package
568 ##############################
569 %post
570 /sbin/ldconfig
571 exit 0
572
573 ##############################
574 #  Pre Uninstall old package
575 ##############################
576 %preun
577 exit 0
578
579 ##############################
580 #  Post Uninstall old package
581 ##############################
582 %postun
583 /sbin/ldconfig
584 exit 0
585
586 %if %{with wayland}
587 %post dali-video-player-plugin
588 /sbin/ldconfig
589 exit 0
590 %endif
591
592 %if %{with wayland}
593 %postun dali-video-player-plugin
594 /sbin/ldconfig
595 exit 0
596 %endif
597
598
599 ##############################
600
601 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
602 # if mobile || "undefined"
603 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
604 %post profile_mobile
605 pushd %{_libdir}
606 for FILE in libdali-adap*.so*.mobile; do ln -sf "$FILE" "${FILE%.mobile}"; done
607 popd
608 /sbin/ldconfig
609 exit 0
610
611 %postun profile_mobile
612 /sbin/ldconfig
613 exit 0
614 %endif
615
616 ##############################
617
618 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
619 # if tv ||"undefined"
620 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
621 %post profile_tv
622 pushd %{_libdir}
623 for FILE in libdali-adap*.so*.tv; do ln -sf "$FILE" "${FILE%.tv}"; done
624 popd
625 /sbin/ldconfig
626 exit 0
627
628 %postun profile_tv
629 /sbin/ldconfig
630 exit 0
631 %endif
632
633 ##############################
634
635 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
636 # if wearable || "undefined"
637 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
638 %post profile_wearable
639 pushd %{_libdir}
640 for FILE in libdali-adap*.so*.wearable; do ln -sf "$FILE" "${FILE%.wearable}"; done
641 popd
642 /sbin/ldconfig
643 exit 0
644
645 %postun profile_wearable
646 /sbin/ldconfig
647 exit 0
648 %endif
649
650 ##############################
651
652 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
653 # if ivi ||"undefined"
654 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
655 %post profile_ivi
656 pushd %{_libdir}
657 for FILE in libdali-adap*.so*.ivi; do ln -sf "$FILE" "${FILE%.ivi}"; done
658 popd
659 /sbin/ldconfig
660 exit 0
661
662 %postun profile_ivi
663 /sbin/ldconfig
664 exit 0
665 %endif
666
667
668 ##############################
669 # Files in Binary Packages
670 ##############################
671
672 %files
673 %manifest dali-adaptor.manifest
674 %defattr(-,root,root,-)
675 %defattr(-,app,app,-)
676 %dir %{user_shader_cache_dir}
677 %{_bindir}/*
678 %license LICENSE
679
680 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
681 # if common ||"undefined"
682 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
683 %defattr(-,root,root,-)
684 %{_libdir}/libdali-adap*.so*
685 %exclude %{_libdir}/libdali-adap*.so*.mobile
686 %exclude %{_libdir}/libdali-adap*.so*.wearable
687 %exclude %{_libdir}/libdali-adap*.so*.tv
688 %exclude %{_libdir}/libdali-adap*.so*.ivi
689 %endif
690
691 %if %{with wayland}
692 %files dali-video-player-plugin
693 %manifest dali-adaptor.manifest
694 %defattr(-,root,root,-)
695 %{_libdir}/libdali-video-player-plugin.so*
696 %license LICENSE
697 %endif
698
699 %if 0%{?tizen_version_major} >= 3
700 %files dali-feedback-plugin
701 %manifest dali-adaptor.manifest
702 %defattr(-,root,root,-)
703 %{_libdir}/libdali-feedback-plugin.so*
704 %{dali_plugin_sound_files}/*
705 %endif
706
707 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
708 # if common ||"undefined"
709 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
710 %files profile_common
711 # default .so files are housed in the main pkg.
712 %endif
713
714 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
715 # if mobile || "undefined"
716 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
717 %files profile_mobile
718 %manifest dali-adaptor.manifest
719 %defattr(-,root,root,-)
720 %{_libdir}/libdali-adap*.so*.mobile
721 %endif
722
723 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
724 # if tv ||"undefined"
725 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
726 %files profile_tv
727 %manifest dali-adaptor.manifest
728 %defattr(-,root,root,-)
729 %{_libdir}/libdali-adap*.so*.tv
730 %endif
731
732 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
733 # if wearable || "undefined"
734 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
735 %files profile_wearable
736 %manifest dali-adaptor.manifest
737 %defattr(-,root,root,-)
738 %{_libdir}/libdali-adap*.so*.wearable
739 %endif
740
741 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
742 # if ivi ||"undefined"
743 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
744 %files profile_ivi
745 %manifest dali-adaptor.manifest
746 %defattr(-,root,root,-)
747 %{_libdir}/libdali-adap*.so*.ivi
748 %endif
749
750
751 %files devel
752 %defattr(-,root,root,-)
753 %{dev_include_path}/dali/dali.h
754 %{dev_include_path}/dali/public-api/*
755 %{dev_include_path}/dali/devel-api/*
756 %{dev_include_path}/dali/doc/*
757 %{_libdir}/pkgconfig/dali-adaptor.pc
758
759 %files integration-devel
760 %defattr(-,root,root,-)
761 %{dev_include_path}/dali/integration-api/adaptors/*
762 %{_libdir}/pkgconfig/dali-adaptor-integration.pc