[3.0] NativeImageSource with tbm_surface for tizen 3.0 wayland
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
1 # NOTES
2 # This spec file is used to build DALi Adaptor for different Tizen Profiles
3 # Current profiles are:  Mobile, TV, Wearable, Common
4 #
5 # The profile variable is defined outside of the spec file in a build.conf file.
6 # It will contain the profile and whether or not to build with X11 or Wayland
7 #
8 # gbs will try to download the build.conf for the platform automatically from the repo location when
9 # performing a gbs build ( use gbs build -v to see it download location) E.g.
10 # http://download.tizen.org/snapshots/tizen/tv/tizen-tv/repos/arm-wayland/packages/repodata/xxxx-build.conf.gz
11
12
13 %bcond_with wayland
14
15 Name:       dali-adaptor
16 Summary:    The DALi Tizen Adaptor
17 Version:    1.1.16
18 Release:    1
19 Group:      System/Libraries
20 License:    Apache-2.0 and BSD-2-Clause and MIT
21 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
22 Source0:    %{name}-%{version}.tar.gz
23
24 # Get the profile from tizen_profile_name if it exists.
25 %if 0%{?tizen_profile_name:1}
26 %define profile %{tizen_profile_name}
27 %endif
28
29 %if "%{profile}" == "mobile"
30 %define dali_profile MOBILE
31 %define dali_feedback_plugin 0
32 %define shaderbincache_flag DISABLE
33 %endif
34
35 %if "%{profile}" == "tv"
36 %define dali_profile TV
37 %define dali_feedback_plugin 0
38 %define shaderbincache_flag ENABLE
39 %endif
40
41 %if "%{profile}" == "wearable"
42 %define dali_profile WEARABLE
43 %define dali_feedback_plugin 0
44 %define shaderbincache_flag DISABLE
45 %endif
46
47 %if "%{profile}" == "common"
48 %define dali_profile COMMON
49 %define dali_feedback_plugin 0
50 %define tizen_2_2_compatibility 0
51 %define shaderbincache_flag DISABLE
52 %endif
53
54 # macro is enabled by passing gbs build --define "with_libuv 1"
55 %define build_with_libuv 0%{?with_libuv:1}
56
57 Requires(post): /sbin/ldconfig
58 Requires(postun): /sbin/ldconfig
59 Requires:       giflib
60 BuildRequires:  pkgconfig
61 BuildRequires:  gawk
62 BuildRequires:  pkgconfig(sensor)
63 BuildRequires:  pkgconfig(aul)
64 BuildRequires:  giflib-devel
65 BuildRequires:  pkgconfig(fontconfig)
66 BuildRequires:  libjpeg-turbo-devel
67 BuildRequires:  dali-devel
68 BuildRequires:  dali-integration-devel
69 BuildRequires:  pkgconfig(vconf)
70 BuildRequires:  tts-devel
71 BuildRequires:  pkgconfig(dlog)
72 BuildRequires:  libdrm-devel
73 BuildRequires:  pkgconfig(libexif)
74 BuildRequires:  pkgconfig(libpng)
75 BuildRequires:  pkgconfig(glesv2)
76 BuildRequires:  libcurl-devel
77 BuildRequires:  pkgconfig(harfbuzz)
78
79 BuildRequires:  fribidi-devel
80
81
82 %if 0%{?tizen_2_2_compatibility} != 1
83 BuildRequires:  pkgconfig(capi-system-info)
84 %endif
85
86 %if 0%{?build_with_libuv}
87 # Tizen currently does not have libuv as a separate libuv package
88 # So we have to look into the uv headers bundled inside node-js
89 BuildRequires:  nodejs-devel
90 %endif
91
92
93
94 %define dali_needs_efl_libraries 1
95 %define dali_needs_appfw_libraries 1
96 %if %{with wayland}
97
98 ####### BUILDING FOR WAYLAND #######
99 BuildRequires:  pkgconfig(wayland-egl)
100 BuildRequires:  pkgconfig(wayland-client)
101 BuildRequires:  wayland-devel
102 # Currently Tizen Common we use does not have wayland extensions like xdg-shell
103 %if "%{profile}" != "common"
104 BuildRequires:  wayland-extension-client-devel
105 %endif
106 %if %{build_with_libuv}
107 ####### BUILDING FOR PURE WAYLAND #######
108 # if we're building with wayland and runnning under node.js then we are using libuv mainloop
109 # and DALis own wayland client (it needs wayland-client headers).
110 # EFL libraries and APP Framework libraries are not required in this case
111 %define dali_needs_efl_libraries 0
112 %define dali_needs_appfw_libraries 0
113 BuildRequires:  libxkbcommon-devel
114 %else
115 ####### BUILDING FOR ECORE WAYLAND #######
116 BuildRequires:  pkgconfig(ecore-wayland)
117 %endif
118
119 # dali-adaptor needs tbm_surface in tizen 3.0 wayland
120 BuildRequires:  pkgconfig(libtbm)
121
122 # tpkp-curl (certificate pinning for libcurl functions) is only available in Tizen 3.0
123 BuildRequires:  pkgconfig(tpkp-curl)
124
125 ####### BUILDING FOR X11#######
126 %else
127 BuildRequires:  pkgconfig(egl)
128 BuildRequires:  pkgconfig(xext)
129 BuildRequires:  pkgconfig(xi)
130 BuildRequires:  pkgconfig(xfixes)
131 BuildRequires:  pkgconfig(xdamage)
132 BuildRequires:  pkgconfig(utilX)
133 %endif
134
135 ###### Building with EFL libraries
136 %if 0%{?dali_needs_efl_libraries}
137 BuildRequires:  pkgconfig(evas)
138 BuildRequires:  pkgconfig(elementary)
139 %endif
140
141 ###### Build with APP Framework
142 %if 0%{?dali_needs_appfw_libraries}
143 BuildRequires:  pkgconfig(capi-appfw-application)
144 BuildRequires:  pkgconfig(capi-system-system-settings)
145 %endif
146
147 %if 0%{?over_tizen_2_2}
148 BuildRequires:  pkgconfig(capi-system-info)
149 %endif
150
151
152
153
154
155 %description
156 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
157 platform abstraction and application shell
158
159 ##############################
160 # devel
161 ##############################
162 %package devel
163 Summary:    Development components for the DALi Tizen Adaptor
164 Group:      Development/Building
165 Requires:   %{name} = %{version}-%{release}
166 Requires:   %{name}-integration-devel = %{version}-%{release}
167
168 %description devel
169 Development components for the DALi Tizen Adaptor - public headers and package configs
170
171 ##############################
172 # integration-devel
173 ##############################
174 %package integration-devel
175 Summary:    Integration development package for the Adaptor
176 Group:      Development/Building
177 Requires:   %{name} = %{version}-%{release}
178
179 %description integration-devel
180 Integration development package for the Adaptor - headers for integrating with an adaptor library.
181
182 ##############################
183 # Dali Feedback Plugin
184 ##############################
185 %package dali-feedback-plugin
186 Summary:    Plugin to play haptic and audio feedback for Dali
187 Group:      System/Libraries
188 %if 0%{?dali_feedback_plugin}
189 #Requires:       libdeviced
190 BuildRequires:  pkgconfig(mm-sound)
191 BuildRequires:  pkgconfig(haptic)
192 BuildRequires:  libfeedback-devel
193 %endif
194
195 %description dali-feedback-plugin
196 Feedback plugin to play haptic and audio feedback for Dali
197
198 ##############################
199 # Preparation
200 ##############################
201 %prep
202 %setup -q
203 %define dali_data_rw_dir         /usr/share/dali/
204 %define dali_data_ro_dir         /usr/share/dali/
205 %define user_shader_cache_dir    %{dali_data_ro_dir}/core/shaderbin/
206 %define font_preloaded_path      /usr/share/fonts/
207 %define font_downloaded_path     /opt/share/fonts/
208 %define font_application_path    /usr/share/app_fonts/
209 %define font_configuration_file  /opt/etc/fonts/conf.avail/99-slp.conf
210 %define dali_plugin_sound_files  %{dali_data_ro_dir}/plugins/sounds/
211
212 %define dev_include_path %{_includedir}
213
214 ##############################
215 # Build
216 ##############################
217 %build
218 PREFIX+="/usr"
219 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections "
220 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -Wl,-Bsymbolic-functions "
221
222 %ifarch %{arm}
223 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
224 %endif
225
226 %if %{with wayland}
227 CFLAGS+=" -DWAYLAND"
228 CXXFLAGS+=" -DWAYLAND"
229 configure_flags="--enable-wayland"
230 %endif
231
232 %if 0%{?tizen_2_2_compatibility}
233 CFLAGS+=" -DTIZEN_SDK_2_2_COMPATIBILITY"
234 CXXFLAGS+=" -DTIZEN_SDK_2_2_COMPATIBILITY"
235 %endif
236
237 libtoolize --force
238 cd %{_builddir}/%{name}-%{version}/build/tizen
239 autoreconf --install
240
241 DALI_DATA_RW_DIR="%{dali_data_rw_dir}" ; export DALI_DATA_RW_DIR
242 DALI_DATA_RO_DIR="%{dali_data_ro_dir}"  ; export DALI_DATA_RO_DIR
243 FONT_PRELOADED_PATH="%{font_preloaded_path}" ; export FONT_PRELOADED_PATH
244 FONT_DOWNLOADED_PATH="%{font_downloaded_path}" ; export FONT_DOWNLOADED_PATH
245 FONT_APPLICATION_PATH="%{font_application_path}"  ; export FONT_APPLICATION_PATH
246 FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION_FILE
247
248 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=20 --enable-shaderbincache=%{shaderbincache_flag} --enable-profile=%{dali_profile} \
249 %if 0%{?dali_feedback_plugin}
250            --enable-feedback \
251 %endif
252 %if 0%{?tizen_2_2_compatibility}
253            --with-tizen-2-2-compatibility \
254 %endif
255 %if 0%{?dali_needs_efl_libraries}
256             --enable-efl=yes \
257 %else
258             --enable-efl=no \
259 %endif
260 %if 0%{?dali_needs_appfw_libraries}
261             --enable-appfw=yes \
262 %else
263             --enable-appfw=no \
264 %endif
265 %if %{?build_with_libuv}
266            --with-libuv=/usr/include/node/ \
267 %endif
268            $configure_flags --libdir=%{_libdir}
269
270 make %{?jobs:-j%jobs}
271
272 ##############################
273 # Installation
274 ##############################
275 %install
276 rm -rf %{buildroot}
277 cd build/tizen
278 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
279
280 # LICENSE
281 mkdir -p %{buildroot}/usr/share/license
282 cp -af %{_builddir}/%{name}-%{version}/LICENSE %{buildroot}/usr/share/license/%{name}
283
284 ##############################
285 # Upgrade order:
286 # 1 - Pre Install new package
287 # 2 - Install new package
288 # 3 - Post install new package
289 # 4 - Pre uninstall old package
290 # 5 - Remove files not overwritten by new package
291 # 6 - Post uninstall old package
292 ##############################
293
294 %pre
295 exit 0
296
297 ##############################
298 #  Post Install new package
299 ##############################
300 %post
301 /sbin/ldconfig
302 exit 0
303
304 %if 0%{?dali_feedback_plugin}
305 %post dali-feedback-plugin
306 /sbin/ldconfig
307 exit 0
308 %endif
309
310 ##############################
311 #   Pre Uninstall old package
312 ##############################
313 %preun
314 exit 0
315
316 ##############################
317 #   Post Uninstall old package
318 ##############################
319 %postun
320 /sbin/ldconfig
321 exit 0
322
323 %if 0%{?dali_feedback_plugin}
324 %postun dali-feedback-plugin
325 /sbin/ldconfig
326 exit 0
327 %endif
328
329 ##############################
330 # Files in Binary Packages
331 ##############################
332
333 %files
334 %manifest dali-adaptor.manifest
335 %defattr(-,root,root,-)
336 %{_libdir}/libdali-adap*.so*
337 %defattr(-,app,app,-)
338 %dir %{user_shader_cache_dir}
339 %{_bindir}/*
340 %{_datadir}/license/%{name}
341
342 %files devel
343 %defattr(-,root,root,-)
344 %{dev_include_path}/dali/dali.h
345 %{dev_include_path}/dali/public-api/*
346 %{dev_include_path}/dali/devel-api/*
347 %{dev_include_path}/dali/doc/*
348 %{_libdir}/pkgconfig/dali.pc
349
350 %files integration-devel
351 %defattr(-,root,root,-)
352 %{dev_include_path}/dali/integration-api/adaptors/*
353 %{_libdir}/pkgconfig/dali-adaptor-integration.pc
354
355 %if 0%{?dali_feedback_plugin}
356 %files dali-feedback-plugin
357 %defattr(-,root,root,-)
358 %{_libdir}/libdali-feedback-plugin.so*
359 %{dali_plugin_sound_files}/*
360 %endif
361