Modified to install LICENSE information
[platform/core/uifw/anthy.git] / packaging / anthy.spec
1 %define __libtoolize :
2
3 #
4 Summary: A Japanese character input system library.(with dictionary)
5 Name: anthy
6 Version: 9100h
7 Release: 1
8 URL: http://www.sourceforge.jp/projects/anthy/
9 Source0: %{name}-%{version}.tar.gz
10 Source1001:     anthy.manifest
11 #
12 # URL: http://cannadic.oucrc.org
13 # Source1: cannadic-0.93.tar.gz
14 License: GPL
15 Group: System Environment/Libraries
16 BuildRoot: %{_tmppath}/%{name}-root
17
18 %description
19
20 %prep
21 %setup -q
22 cp %{SOURCE1001} .
23 #tar zxf %{_sourcedir}/cannadic-0.93.tar.gz
24 #ln -s ../cannadic-0.93/gcanna.t mkanthydic
25 #ln -s ../cannadic-0.93/gcannaf.t mkanthydic
26
27 %build
28 %configure
29
30 make
31
32 %install
33 rm -rf ${RPM_BUILD_ROOT}
34 mkdir -p %{buildroot}%{_datadir}/license
35 cp COPYING %{buildroot}%{_datadir}/license/%{name}
36 %makeinstall
37
38 %clean
39 rm -rf ${RPM_BUILD_ROOT}
40
41 %post
42 /sbin/ldconfig
43
44 %postun -p /sbin/ldconfig
45
46 %files
47 %manifest %{name}.manifest
48 %defattr(-,root,root)
49 %{_datadir}/license/%{name}
50 %{_bindir}/*
51 %{_sysconfdir}/*
52 %{_datadir}/anthy
53 #%{_datadir}/emacs/site-lisp/*
54 %{_libdir}/pkgconfig/*
55 %{_libdir}/libanthy*
56 %{_includedir}/*
57 #%doc README doc
58
59 %changelog
60 * Thu Jan  3 2002 Yusuke Tabata <yusuke@kmc.gr.jp>
61 - changed my mail address and URL of web page
62
63 * Thu Nov 11 2001 Takayoshi Nobuoka <taka@trans-nt.com>
64 - add %{_sysconfdir}/* at %files
65
66 * Wed Sep  9 2001 Takayoshi Nobuoka <taka@trans-nt.com>
67 - use _bindir and so on.
68
69 * Sun Aug 19 2001 Tabatee <yusuke@kmc.kyoto-u.ac.jp>
70 - Initial build.