slow down parallelism
[platform/upstream/make.git] / packaging / make.spec
index 97b78f2..4ea617b 100644 (file)
@@ -1,91 +1,71 @@
-#
-# Do NOT Edit the Auto-generated Part!
-# Generated by: spectacle version 0.22
-#
-# >> macros
-# << macros
-
 Name:           make
-Version:        3.81
-Release:        1
+Url:            http://www.gnu.org/software/make/make.html
+Provides:       gmake
+PreReq:         %install_info_prereq
+Version:        3.82
+Release:        0
+Summary:        GNU make
 License:        GPL-2.0+
-Summary:        A GNU tool which simplifies the build process for users
-Url:            http://www.gnu.org/software/make/
-Group:          Development/Tools
-Source0:        ftp://ftp.gnu.org/gnu/make/make-%{version}.tar.bz2
-Source100:      make.yaml
-Patch0:         make-3.79.1-noclock_gettime.patch
-Patch1:         make-3.80-j8k.patch
-Patch2:         make-3.80-getcwd.patch
-Patch3:         make-3.81-err-reporting.patch
-Patch4:         make-3.81-memory.patch
-Patch5:         make-3.81-rlimit.patch
-Patch6:         make-3.81-newlines.patch
-Patch7:         make-3.81-jobserver.patch
+Group:          Development/Tools/Building
+Source:         make-%version.tar.bz2
+Patch2:         make-slowdown-parallelism.diff
+Patch3:         make-disable-broken-tests.diff
+Patch4:         make-savannah-bug30723-expand_makeflags_before_reexec.diff
+Patch5:         make-savannah-bug30612-handling_of_archives.diff
+Patch6:         make-fix_whitespace_tokenization.diff
+Patch7:         make-glob-faster.patch
+# PATCH-FIX-UPSTREAM make-arglength.patch dimstar@opensuse.org -- http://article.gmane.org/gmane.comp.gnu.make.bugs/4219
+Patch8:         make-arglength.patch
+# PATCH-FIX-UPSTREAM make-parallel-build.patch dmistar@opensuse.org -- http://savannah.gnu.org/bugs/?30653 
+Patch9:         make-parallel-build.patch
+Patch64:        make-library-search-path.diff
+BuildRoot:      %{_tmppath}/%{name}-%{version}-build
 
 %description
-A GNU tool for controlling the generation of executables and other
-non-source files of a program from the program's source files. Make
-allows users to build and install packages without any significant
-knowledge about the details of the build process. The details about
-how the program should be built are provided for make in the program's
-makefile.
+The GNU make command with extensive documentation.
 
 %prep
 %setup -q
-
-# make-3.79.1-noclock_gettime.patch
-%patch0 -p1
-# make-3.80-j8k.patch
-%patch1 -p1
-# make-3.80-getcwd.patch
-%patch2 -p1
-# make-3.81-err-reporting.patch
+%patch2
 %patch3 -p1
-# make-3.81-memory.patch
-%patch4 -p1
-# make-3.81-rlimit.patch
-%patch5 -p1
-# make-3.81-newlines.patch
+%patch4
+%patch5
 %patch6 -p1
-# make-3.81-jobserver.patch
-%patch7 -p1
-# >> setup
-# << setup
+%patch7 -p0
+%patch8 -p1
+%patch9 -p1
+if [ %_lib == lib64 ]; then
+%patch64
+fi
 
 %build
-# >> build pre
-# << build pre
-
-%configure --disable-static \
-    --disable-nls
-
+CFLAGS=$RPM_OPT_FLAGS \
+./configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --disable-nls
 make %{?_smp_mflags}
 
-# >> build post
-# << build post
-%install
-# >> install pre
-# << install pre
-%make_install
-
-# >> install post
-ln -sf make %{buildroot}%{_bindir}/gmake
-ln -sf make.1 %{buildroot}%{_mandir}/man1/gmake.1
-rm -rf %{buildroot}%{_infodir}
-# << install post
-
-
+%check
+make check
 
+%install
+make DESTDIR=$RPM_BUILD_ROOT install
+ln -s make $RPM_BUILD_ROOT/usr/bin/gmake
+%find_lang %name
 
+%files -f %name.lang
+%defattr(-,root,root)
+/usr/bin/make
+/usr/bin/gmake
+%doc /usr/share/info/make.info-*.gz
+%doc /usr/share/info/make.info.gz
+%doc /usr/share/man/man1/make.1.gz
 
+%clean
+rm -rf $RPM_BUILD_ROOT
 
-%files
-%defattr(-,root,root,-)
-# >> files
-%doc NEWS README COPYING AUTHORS
-%{_bindir}/*
-%doc %{_mandir}/man*/*
-# << files
+%post
+%install_info --info-dir=%{_infodir} %{_infodir}/%{name}.info.gz
 
+%postun
+%install_info_delete --info-dir=%{_infodir} %{_infodir}/%{name}.info.gz
 
+%changelog