Add zypp::dumpBacktrace to dump current stack trace to a stream.
[platform/upstream/libzypp.git] / zypp / CMakeLists.txt
index cac4aee..fe78e42 100644 (file)
@@ -191,6 +191,7 @@ INSTALL(  FILES ${zypp_HEADERS} DESTINATION "${CMAKE_INSTALL_PREFIX}/include/zyp
 
 SET( zypp_base_SRCS
   base/InterProcessMutex.cc
+  base/Backtrace.cc
   base/SerialNumber.cc
   base/Random.cc
   base/Measure.cc
@@ -215,6 +216,7 @@ SET( zypp_base_SRCS
 
 SET( zypp_base_HEADERS
   base/InterProcessMutex.h
+  base/Backtrace.h
   base/Collector.h
   base/SerialNumber.h
   base/Easy.h